Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    lonestarecm
    @lonestarecm
    Hello. Is it possible to buy two completed stmbl right now?
    DMS-Sci
    @DMS-Sci
    I'm all out of STMBL kits, and the last time I checked with PCBAWay it was so expensive to order another batch due to the STM microprocessor shortage that it wasn't worth it.
    I have plenty of IRAM 256-2067A2 chips, laser cut cases, capacitors, even case labels... everything to make more drives except the populated boards.
    Edward Scott
    @edwardscott_gitlab
    I planning to retrofit new controls to an Emco 120P lathe. The lathe uses a Siemens DC spindle motor. The motor is rated at 2.6Kw with a 400V armature and requires the use of field weakening. More details can be found at https://emcocncretrofits.fandom.com/wiki/120_Spindle
    Is the V4.1 capable of driving this motor?
    Edward Scott
    @edwardscott_gitlab
    I strongly suspect I will never need the full 2.6Kw...
    Seppo Pietarinen
    @spietari

    I'm trying to get the FB0 ABZ encoder's Z routed to index_enable in LinuxCNC. By default it seems that sserial0.index_out is connected like this in STMBL:

    idx_home0.index_en <= sserial0.index_out

    I can see the index pulse in ServoTerm if I connect enc_fb0.index to term0.wave4.

    The connection in LinuxCNC is done like this:
    net xindex joint.0.index-enable <=> hm2_5i25.0.stbl.0.0.index_enable

    The issue is that joint.0.index-enable is false all the time.

    These are the lines in sserial.c that I suspect:
        //set bidirectional pins
        PIN(index_out)       = data_out.index_enable;
        data_in.index_enable = (PIN(index_clear) > 0) ? 0 : data_out.index_enable;
    Seppo Pietarinen
    @spietari
    Ok, it think I understood the principle now. LinuxCNC sets index_enable true to indicate index is needed. When STMBL sees the index signal the index_clear bit sets index_enable to false that LinuxCNC can see.
    John Dammeyer
    @jcdammeyer
    What's the difference between a Brushless DC Servo and an AC Servo?
    Nico Stute
    @crinq
    the name, nothing else
    roguish
    @roguish:matrix.org
    [m]
    hello all. What is the status of the stmbl drive? has the replacement for the unobtainable power IC been completed? Is anyone currently building units?
    Seppo Pietarinen
    @spietari
    Hi, I'm looking into building some more units. The biggest issue is the F405 mcu that is made of unobtainium.
    issyvarsano
    @issyvarsano
    its still availabe , but only in rolls
    Seppo Pietarinen
    @spietari
    Where do you find those?
    roguish
    @roguish:matrix.org
    [m]
    @spietari: I would really like a few, like 4 or 5 maybe, and can easily fund them.......
    issyvarsano
    @issyvarsano
    reel is near 500 pcs
    roguish
    @roguish:matrix.org
    [m]
    I see some on Ebay. $30 - $50
    Marius Alksnys
    @propcoder:matrix.org
    [m]

    How about this:
    https://www.win-source.net/stmicroelectronics-stm32f407vet6tr.html

    STM32F407VE has ethernet and STM32F407VG has not. I found this is the only difference.
    ?

    Nico Stute
    @crinq
    STM32F405VG has more flash than STM32F407VG
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    Oh, I didn't even notice it's 7
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    [Where] can I get STMBL kit(s) without 405 ?
    Or if we order some STM32F405VG from aliexpress, would it be possible to receive some smd-assembled stmbl kits?
    tlorincz72
    @tlorincz72
    Hi, i would like to implement Mistu HG-KR43B servomotor , but encoder comm speed is 5 Mb/sec. Have stmbl enough hardware resources to serve this?
    Andries
    @GoldDiggerTh
    Hi, i want to order a the STMBL pcb at jlcpcb. Unfortunately I don’t think it is getting exported correctly. The previewer doesn’t show anything. Same goes with pcbway ( it is missing all the tracks, etc) I’m very unexperienced with kicad ( i normally use eagle) I have tried many tutorials and plugins to export the geber files but each time something is wrong. Does anyone have an idea that could go wrong ? Or could give me working geber files of the latest working version.
    Nico Stute
    @crinq

    Oh, I didn't even notice it's 7

    the 7 is ethernet
    G and E is 1M/512k flash

    Marius Alksnys
    @propcoder:matrix.org
    [m]
    I found a seller who claims he can sell STM32F407VGT6 for 23.5 USD each.
    Should we organize group purchase?
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    :point_up: Edit: I found a seller who claims he can sell STM32F407VGT6 for 23.5 USD @100pcs + 40USD for postage.
    Should we organize group purchase?
    50-23.8; 30-24.2; 10-24.5$. The postage is $50
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    So, is anyone interested in assembly or have some boards assembled already?
    Seppo Pietarinen
    @spietari
    I'll probably have some assembled boards in a few weeks
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    :point_up: Edit: Is there some freedom in quantity?

    I'll probably have some assembled boards in a few weeks

    Is there some freedom in quantity?

    I would like to get 1 to 5 stmbl boards, or even better, kits soon
    Seppo Pietarinen
    @spietari
    Yes hoping have good quantity
    roguish
    @roguish:matrix.org
    [m]
    @spietari: I am interested in a few kits......
    tlorincz72
    @tlorincz72
    The problem solved with the mitsu HG-KR servomotor. It works fine with the stmbl. Thank you!
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    I want to connect a servo motor with Tamagawa 23-bit absolute encoder to STMBL.
    I see three pairs of wires and a shield. While only 4 contacts are mentioned in STMBL docs.
    issyvarsano
    @issyvarsano
    @propcoder:matrix.org yes , only 4 cables are needed , the stmbl does not support battery for the abs encoder
    abd be aware that with abs. encoder in case of long cables you can have interference and packet loss
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    They where working with other servo drives
    Docs show (while I am not sure) that these are data and clock pairs
    Maybe this pic explains that I need to connect those pairs in parallel. I think battery is connected to yet another wire, not available at the drive connector
    issyvarsano
    @issyvarsano
    yes
    you need sd+ , SD- +5V and gnd
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    So, leave clock unconnected?
    issyvarsano
    @issyvarsano
    there is no clock on the tamagawa protocol
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    Ok, I will try
    issyvarsano
    @issyvarsano
    the speed is fixed to 2,5 mb/s
    Marius Alksnys
    @propcoder:matrix.org
    [m]
    Thank you, @issyvarsano it works!