Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 18 04:18
    KoichiWada opened #1523
  • Jan 18 04:00
    kunihiko-t opened #1522
  • Jan 15 15:09
    alexander-dc81 commented #1520
  • Jan 15 15:07
    goevexx commented #1520
  • Jan 15 15:06
    alexander-dc81 commented #1520
  • Jan 15 15:03
    goevexx commented #1520
  • Jan 14 17:26
    alexander-dc81 commented #1520
  • Jan 14 17:26
    alexander-dc81 closed #1520
  • Jan 14 17:25
    alexander-dc81 opened #1521
  • Jan 14 17:24
    alexander-dc81 opened #1520
  • Dec 03 2020 00:41

    brendensoares on develop

    More lint fixes and dead code r… Merge pull request #1518 from p… (compare)

  • Dec 03 2020 00:41
    brendensoares closed #1518
  • Dec 03 2020 00:41
    brendensoares commented #1518
  • Dec 03 2020 00:36
    brendensoares commented #1518
  • Nov 20 2020 05:17
    mikyk10 opened #1519
  • Nov 03 2020 10:54
    r32rf closed #1517
  • Nov 03 2020 10:54
    r32rf commented #1517
  • Oct 23 2020 12:53
    ptman opened #1518
  • Oct 22 2020 23:26
    notzippy commented #1517
  • Oct 22 2020 14:22
    r32rf commented #1517
Steve
@notzippy
the other issue has been ongoing with the gocache library and how it misses keys
cache_test.go:241: Error getting str: revel/cache: key not found /
The cache is eventually consistent, so thinking of just pulling this test due to reasons
What about a lint against revel/cmd ?
matrixbot
@matrixbot
Paul sure, I'll take a look at revel/cmd and revel/modules
matrixbot
@matrixbot
Paul notzippy, revel/cmd#199
1 reply
matrixbot
@matrixbot
Paul notzippy, thanks!
Steve
@notzippy
If you have time to do the revel/modules as well that would be great
matrixbot
@matrixbot
Paul I will
matrixbot
@matrixbot
Paul notzippy, revel/modules#105
matrixbot
@matrixbot
Paul notzippy, was there something you wanted with the last PR?
Steve
@notzippy
I just merged in a PR that was on the examples already which caused a conflict, I had resolved it.
GeorgeXc
@GeorgeXc

tried to add code below into the file app/init.go: func init()

revel.AddHTTPMux("/this/is", http.HandlerFunc(func(w http.ResponseWriter, r *http.Request) {
        fmt.Fprintln(w, "Hi there, shorter prefix", r.URL.Path)
        w.WriteHeader(200)
    }))

but when run revel run -a appName meet an error

the error list below
revel run -m prod -a r1app
Revel executing: run a Revel application
Parsing packages, (may require download if not cached)... Completed
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x30 pc=0x14a52fd]

goroutine 1 [running]:
github.com/revel/revel.AddHTTPMux(...)
        /Users/byc/go/pkg/mod/github.com/revel/revel@v1.0.0/server-engine.go:162
r1app/app.init.0()
        /Users/byc/code/revelprojs/r1app/app/init.go:54 +0x15d
CRIT  11:52:31 revel_logger.go:59: Error running:                            error="exit status 2"
GeorgeXc
@GeorgeXc
Thanks
matrixbot
@matrixbot
Paul notzippy, thanks, I made a new PR =)
Steven Hughes
@alas-plus
Heya all, so I asked this question on stack overflow about running a revel app on GCP. I'm new to both, So I wasn't sure where I was going wrong. Looking into it I think my problem is the engine listening on port X. My Cloud Run App had one port open specifically so it was unable to start the engine. So i guess my questions are 2:
1) Is it not a good idea to run using the revel cmd in "prod"
2) Is there a way to configure which port the engine runs on
Steven Hughes
@alas-plus

Well I managed to get it to work by building the app instead and running it that way. I think the only advantage of run is hot swap, which I don't need when deployed.

I also wonder, has an official docker image been considered? I see some that are years old, but having one that was in CI/CD and such would be nice. Would save me from go getting revel every build :laughing:

matrixbot
@matrixbot
Paul everyone needs a slightly different docker image
Paul why not make your own?
matrixbot
@matrixbot
Paul Steven Hughes (Gitter): if you found a solution, you should submit an answer
Steve
@notzippy
Docker has been considered, for a production built image it would likely be best to have a two stage image, but for development that is unnecessary. Right now we are doing some housecleaning. But that item is on the radar
matrixbot
@matrixbot
Paul notzippy, I made another PR
Garrett Flanders
@flanyanero
I would like to use revel to implement subdomain level routing. Does anyone know of an example or how to do that?
matrixbot
@matrixbot
Paul You'll probably have to do it yourself based on the host header
Steve
@notzippy
@flanyanero I had been looking at that as well for some time, you could implement this by creating or extending the server engine https://revel.github.io/manual/server-engine.html
matrixbot
@matrixbot
Paul notzippy, brendensoares, thanks for helping me with the hacktoberfest PRs, got the required amount to claim a planted tree (random "free" t-shirts are probably a climate negative)
Steve
@notzippy
Nice
MadOtis
@MadOtis
Hello! Trying to go through the getting started tutorial for Revel and running into a small problem. 'revel new' seems to work and I see a project created with all the source goodness, yet when I try to 'revel run -a', I get an error: "Parsing packages, (may require download if not cached)...2020/12/01 11:15:04 internal error: nil Pkg importing "internal/cpu" from "internal/bytealg" and quits. I'm running go 1.14.6 on a Mac (Catalina) latest patches. Any suggestions?
matrixbot
@matrixbot
Paul I'm not on mac, so hard to tell
Paul internal/ sounds like it's a problem with go, not revel
Paul have you tried latest go?
Brenden Soares
@brendensoares
@MadOtis I ran on Mac/go 1.15 recently without any issues
I use gvm to manage multiple versions of Go, can you try that?
maybe try 1.15 to compare?
matrixbot
@matrixbot
Paul btw, does anyone have time to check revel/revel#1518
Brenden Soares
@brendensoares
Paul, you're doing what I wanted to do years ago lol
did you look into those failed CI builds? Looks like a build script problem
Brenden Soares
@brendensoares
script:
  - |
    if [[ "$TRAVIS_OS_NAME" != "windows" ]]; then
      go test -v github.com/revel/revel/...
    else
      go test -v github.com/revel/revel/.
    fi
my gut says this is not related to your changes
commented on the PR and merged
matrixbot
@matrixbot
Paul brendensoares, thanks!
Paul yeah, the previous PRs also had problems that weren't related according to notzippy
Paul
@ptman:kapsi.fi
[m]
ah, new better bridge