Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Mar 11 2020 13:43
    GarvTambi commented on 0e218f5
  • Mar 04 2020 15:32
    aracelivegamagro removed as member
  • Mar 04 2020 15:23
    aracelivegamagro added as member
  • Jan 15 2020 19:03
    fmrico added as member
  • Jul 11 2019 11:45
    orensbruli commented on aed5ae1
  • Jul 11 2019 11:23
    orensbruli commented on aed5ae1
  • Apr 25 2019 22:00
    pilarbachiller edited as member
  • Apr 25 2019 22:00
    pilarbachiller added as member
  • Apr 25 2019 22:00
    orensbruli edited as member
  • Apr 25 2019 22:00
    orensbruli added as member
  • Mar 28 2019 03:41
    parasKumarSahu commented on 2ec7dec
GARV TAMBI
@GarvTambi

@Vishwaak Not workit out....

CMake Deprecation Warning at CMakeLists.txt:7 (cmake_policy):
The OLD behavior for policy CMP0048 will be removed from a future version
of CMake.

The cmake-policies(7) manual explains that the OLD behaviors of all
policies are deprecated and that a policy should be set to OLD only under
specific short-term circumstances. Projects should be ported to the NEW
behavior and not rely on setting a policy to OLD.

-- COMPILING WITH QT5
-- Found OpenMP
-- PYTHON BINDINGS: NO
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- COMPILING WITHOUT FCL SUPPORT = 0

-- RoboComp root is now set to /home/garv/Desktop/robocomp/

-- Ice version: 3.7.0
-- The following Ice libraries were not found:
-- Ice (required)
-- IceStorm (required)
-- IceUtil (optional)
CMake Error at /home/garv/anaconda3/lib/python3.7/site-packages/cmake/data/share/cmake-3.15/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Failed to find all Ice components (missing: Ice_LIBRARY
_Ice_REQUIRED_LIBS_FOUND) (found version "3.7.0")
Call Stack (most recent call first):
/home/garv/anaconda3/lib/python3.7/site-packages/cmake/data/share/cmake-3.15/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
/home/garv/anaconda3/lib/python3.7/site-packages/cmake/data/share/cmake-3.15/Modules/FindIce.cmake:530 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
cmake/robocompLocal.cmake:25 (FIND_PACKAGE)
tools/rcinnerModelSimulator/src/CMakeLists.txt:40 (ROBOCOMP_INITIALIZE)

-- Configuring incomplete, errors occurred!
See also "/home/garv/Desktop/robocomp/build/CMakeFiles/CMakeOutput.log".

Nivedita Rufus
@niveditarufus
@GarvTambi As said by @Vishwaak you have to set python variable to default python and not anaconda. In your error messages we can still see /home/garv/anaconda3/lib/python3.7.
Kushagra Shekhawat
@kushagra414
@GarvTambi can you tell me the output of this command which python
GARV TAMBI
@GarvTambi
@kushagra414 /home/garv/anaconda3/bin/python
Xerous Wazler
@Vishwaak
It's still pointing to the anaconda python . You need to remove the path from your path varaiable and poin it back to systems default python
echo $PATH
remove /home/garv/anaconda3/lib/python3.7 from path varaible .
export PATH= the edited path
Restart you system , then try to recompile
Kushagra Shekhawat
@kushagra414
@GarvTambi Refer to this issue robocomp/robocomp#248
It will solve your problem
GARV TAMBI
@GarvTambi
@kushagra414 and @Vishwaak which python command show this -
/usr/bin/python
Is everything alright
Xerous Wazler
@Vishwaak
Yes it should resolve the issue @GarvTambi
GARV TAMBI
@GarvTambi

After the above issue reslolve again stuck final step...

garv@garv-Inspiron-5567:~/Desktop/robocomp/build$ sudo make install
[sudo] password for garv:
make: * No rule to make target 'install'. Stop.

Kushagra Shekhawat
@kushagra414
@GarvTambi did you run cmake .. and then make commands?
GARV TAMBI
@GarvTambi

@kushagra414 when I run the cmake .. command it shows like this -

garv@garv-Inspiron-5567:~/Desktop/robocomp/build$ cmake ..
-- COMPILING WITH QT5
-- Found OpenMP
-- PYTHON BINDINGS: NO
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- COMPILING WITHOUT FCL SUPPORT = 0

-- RoboComp root is now set to /home/garv/Desktop/robocomp/

-- Ice version: 3.7.0
-- The following Ice libraries were not found:
-- Ice (required)
-- IceStorm (required)
-- IceUtil (optional)
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Failed to find all Ice components (missing: Ice_LIBRARY
_Ice_REQUIRED_LIBS_FOUND) (found version "3.7.0")
Call Stack (most recent call first):
/usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.10/Modules/FindIce.cmake:531 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
cmake/robocompLocal.cmake:25 (FIND_PACKAGE)
tools/rcinnerModelSimulator/src/CMakeLists.txt:40 (ROBOCOMP_INITIALIZE)

-- Configuring incomplete, errors occurred!
See also "/home/garv/Desktop/robocomp/build/CMakeFiles/CMakeOutput.log".

Kushagra Shekhawat
@kushagra414
sudo apt-get update
sudo apt-get install git git-annex cmake make g++ libgsl-dev libopenscenegraph-dev cmake-qt-gui zeroc-ice-all-dev freeglut3-dev libboost-system-dev libboost-thread-dev qt5-default libqt5xmlpatterns5-dev libqt5opengl5-dev libxt-dev libboost-test-dev libboost-filesystem-dev libccd-dev zeroc-ice-all-runtime
sudo apt-get install python3-pip python3-setuptools python3-pyparsing=2.2.0+dfsg1-2 python3-numpy python3-libxml2 python3-xmltodict python3-zeroc-ice
sudo pip3 install networkx pyside2 argcomplete termcolor cogapp
Install these libraries @GarvTambi
GARV TAMBI
@GarvTambi

@kushagra414 Meet with the same errors again after following the installment tutorial as well as your suggestions/commands.

garv@garv-Inspiron-5567:~/Desktop/robocomp/build$ cmake ..
-- COMPILING WITH QT5
-- Found OpenMP
-- PYTHON BINDINGS: NO
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- COMPILING WITHOUT FCL SUPPORT = 0

-- RoboComp root is now set to /home/garv/Desktop/robocomp/

-- Ice version: 3.7.0
-- The following Ice libraries were not found:
-- Ice (required)
-- IceStorm (required)
-- IceUtil (optional)
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Failed to find all Ice components (missing: Ice_LIBRARY
_Ice_REQUIRED_LIBS_FOUND) (found version "3.7.0")
Call Stack (most recent call first):
/usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.10/Modules/FindIce.cmake:531 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
cmake/robocompLocal.cmake:25 (FIND_PACKAGE)
tools/rcinnerModelSimulator/src/CMakeLists.txt:40 (ROBOCOMP_INITIALIZE)

-- Configuring incomplete, errors occurred!
See also "/home/garv/Desktop/robocomp/build/CMakeFiles/CMakeOutput.log".

@kushagra414 I also use these commands

sudo apt install zeroc-ice-all-runtime
pip3 install zeroc-ice

Kushagra Shekhawat
@kushagra414
@GarvTambi The error
-- The following Ice libraries were not found: -- Ice (required) -- IceStorm (required)
should not be occuring if you have installed the ice compiler correctly.
Kushagra Shekhawat
@kushagra414
Which Linux distro are you using?
GARV TAMBI
@GarvTambi
@kushagra414 "Ubuntu 18.04"]

@kushagra414 I use these two commands for Ice

sudo apt install zeroc-ice-all-runtime --This command will run perfectly

but in -- pip3 install zeroc-ice
I got this error
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;file='/tmp/pip-build-gb9z8lf1/zeroc-ice/setup.py';f=getattr(tokenize, 'open', open)(file);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, file, 'exec'))" install --record /tmp/pip-lkw7ll7x-record/install-record.txt --single-version-externally-managed --compile --user --prefix=" failed with error code 1 in /tmp/pip-build-gb9z8lf1/zeroc-ice/

Kushagra Shekhawat
@kushagra414
@GarvTambi What is the output of this command sudo apt install python3-zeroc-ice
GARV TAMBI
@GarvTambi
@kushagra414 python3-zeroc-ice: command not found
Kushagra Shekhawat
@kushagra414

@GarvTambi What is the output of this command sudo apt install python3-zeroc-ice

Use the above command

GARV TAMBI
@GarvTambi
@kushagra414 garv@garv-Inspiron-5567:~/Desktop/robocomp/build$ sudo apt install python3-zeroc-ice
[sudo] password for garv:
Reading package lists... Done
Building dependency tree
Reading state information... Done
python3-zeroc-ice is already the newest version (3.7.0-5ubuntu0.2).
0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.
Kushagra Shekhawat
@kushagra414
Try Uninstalling all of the above packages and install them again using
sudo apt uninstall git git-annex cmake make g++ libgsl-dev libopenscenegraph-dev cmake-qt-gui zeroc-ice-all-dev freeglut3-dev libboost-system-dev libboost-thread-dev qt5-default libqt5xmlpatterns5-dev libqt5opengl5-dev libxt-dev libboost-test-dev libboost-filesystem-dev libccd-dev zeroc-ice-all-runtime sudo apt uninstall python3-pip python3-setuptools python3-pyparsing=2.2.0+dfsg1-2 python3-numpy python3-libxml2 python3-xmltodict python3-zeroc-ice
sudo pip3 uninstall networkx pyside2 argcomplete termcolor cogap
GARV TAMBI
@GarvTambi
@kushagra414 okay ..I try and let you know the result...
Kushagra Shekhawat
@kushagra414
@GarvTambi I edited some of the code above. If you copied it then copy it again
GARV TAMBI
@GarvTambi
@kushagra414
garv@garv-Inspiron-5567:~/Desktop/robocomp$ sudo apt uninstall git git-annex cmake make g++ libgsl-dev libopenscenegraph-dev cmake-qt-gui zeroc-ice-all-dev freeglut3-dev libboost-system-dev libboost-thread-dev qt5-default libqt5xmlpatterns5-dev libqt5opengl5-dev libxt-dev libboost-test-dev libboost-filesystem-dev libccd-dev zeroc-ice-all-runtime
[sudo] password for garv:
E: Invalid operation uninstall
Kushagra Shekhawat
@kushagra414
@GarvTambi Sorry use apt-get purge instead of apt uninstall
With pip3 use uninstall
husainattar
@husainattar

find a package configuration file provided by "Qt5", but
CMake did not find one.

Could not find a package configuration file provided by "Qt5" with any of
the following names:

Qt5Config.cmake
qt5-config.cmake

Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
to a directory containing one of the above files. If "Qt5" provides a
separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first):
CMakeLists.txt:34 (include)

how to resolve this error anyone
this error occurs after typing cmake .. command
Kushagra Shekhawat
@kushagra414
@husainattar I had same problem which was resolved when I ran these commands sudo apt-get install yakuake qttools5-dev-tools qt5-assistant
husainattar
@husainattar
after installing QT5 this the error which is now occuring

-- COMPILING WITH QT5
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:28 (find_package):
Could not find a package configuration file provided by "Qt5XmlPatterns"
with any of the following names:

Qt5XmlPatternsConfig.cmake
qt5xmlpatterns-config.cmake

Add the installation prefix of "Qt5XmlPatterns" to CMAKE_PREFIX_PATH or set
"Qt5XmlPatterns_DIR" to a directory containing one of the above files. If
"Qt5XmlPatterns" provides a separate development package or SDK, be sure it
has been installed.
Call Stack (most recent call first):
cmake/modules/qt.cmake:47 (find_package)
CMakeLists.txt:34 (include)

-- Configuring incomplete, errors occurred!
See also "/home/guest/robocomp/build/CMakeFiles/CMakeOutput.log".

Kushagra Shekhawat
@kushagra414
sudo apt-get install git git-annex cmake make g++ libgsl-dev libopenscenegraph-dev cmake-qt-gui zeroc-ice-all-dev freeglut3-dev libboost-system-dev libboost-thread-dev qt5-default libqt5xmlpatterns5-dev libqt5opengl5-dev libxt-dev libboost-test-dev libboost-filesystem-dev libccd-dev zeroc-ice-all-runtime
husainattar
@husainattar
thank you very much .You save my day @kushagra414
Kushagra Shekhawat
@kushagra414
You are welcome @husainattar I am happy to help.
GARV TAMBI
@GarvTambi
@kushagra414 Finally installed with no errors ...
Thanks a ton ..I even don't show my gratitude towards you but must say Thank You very much for your support...
Special mention @Vishwaak @niveditarufus Thanks a lot to all
Xerous Wazler
@Vishwaak
We are Happy to help :) @GarvTambi
Kushagra Shekhawat
@kushagra414
That's great to hear @GarvTambi . You are welcome
Tript
@TriptSharma
Hello all, I would like to contribute to RoboComp, I am a fourth year undergraduate at Delhi Technological University, India. I am currently installing the packages as mentioned in the readme of the GitHub repo as I write this msg (well its being installed in the background :))
I am interested in some of the ideas like "Human-robot dialogue and collaboration for social navigation" and
Human recognition (identification) using multi-modal perception system
It would be great if someone could help me how to contribute to the organisation
GARV TAMBI
@GarvTambi
@TriptSharma You can simply ask the doubts where you face any Issue....
Good Luck
Tript
@TriptSharma
Sure!! Thanks
Nivedita Rufus
@niveditarufus
@GarvTambi Happy to help...:)
Shikhar Goswami
@shikhargoswami
Is anyone else facing problems on python 2 or python 3. Because I think I have installed the libraries over python 3 (pip3) but the code in the component is written on python2. For example, it is showing no module named pyside when I use python something.py but when I use python3 something.py it gives code related error
I wanted to know, when we r testing a component, is it,in your case, running?