Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Mar 11 2020 13:43
    GarvTambi commented on 0e218f5
  • Mar 04 2020 15:32
    aracelivegamagro removed as member
  • Mar 04 2020 15:23
    aracelivegamagro added as member
  • Jan 15 2020 19:03
    fmrico added as member
  • Jul 11 2019 11:45
    orensbruli commented on aed5ae1
  • Jul 11 2019 11:23
    orensbruli commented on aed5ae1
  • Apr 25 2019 22:00
    pilarbachiller edited as member
  • Apr 25 2019 22:00
    pilarbachiller added as member
  • Apr 25 2019 22:00
    orensbruli edited as member
  • Apr 25 2019 22:00
    orensbruli added as member
  • Mar 28 2019 03:41
    parasKumarSahu commented on 2ec7dec
Esteban Martinena Guerrero
@orensbruli
If you wanna try to help to fix you can stay on development, but if you just want to use, you can move to main (just a pair of weeks behind development)
ABD
@ABD-01
image.png
9 replies
Alright I switched to main branch as said by @orensbruli .
Installation done. But Command 'rcis' not found is the error now.
Esteban Martinena Guerrero
@orensbruli
@ABD-01 Have you fixed it?
ABD
@ABD-01

@ABD-01 Have you fixed it?

Yes, I've fixed It

Saurabh Suresh Powar
@Spnetic-5
image.png
I'm getting this error while installing robocomp, how should I resolve this?
ABD
@ABD-01
@Spnetic-5 Use the main branch code base, not the development one.
Saurabh Suresh Powar
@Spnetic-5
Still facing same error
Esteban Martinena Guerrero
@orensbruli
git status
Saurabh Suresh Powar
@Spnetic-5
Yes it is resolved now!
Thanks
Umer Jamil
@umerjamil16

@DarkGeekMS , Two questions, please refer to this post: https://github.com/robocomp/web/blob/master/gsoc/2020/posts/mohamed_shawky/post06.md

1) In the DSR Integration diagram, I wanted to ask why the Object-Pose-Estimation component does not directly operate on shared Graph G?
As per my study, the Graph G or shared memory also acts as system main memory buffer so in theory it should not be an issue if the Object-Pose-Estimation is operating directly on the Graph G

2) I am a little confused about ICE (which I read used for components interface). In the DSR Integration diagram, the variatoPyrep and variatoDSR component does not use ICE for communication but the graphDSR and Object-Pose-Estimation component use ICE for interface. Can you please comment on this? (sorry if I sound a little confused)

Mohamed Shawky
@DarkGeekMS

@umerjamil16
1) The Pose Estimation component is not directly connected to the graph G due to two main reasons :

  • First and most important, graspDSR performs some post-processing over the estimated poses before injecting into G. This includes sequential planning of the arm's target to be as close as possible to the arm, which ease the job of the inverse kinematics solver.
  • Second, DSR didn't have a Python wrapper by then, so I needed a C++ agent to interface with the graph G (mainly written in C++). Also, converting the DNN model was infeasible because many of the network operations were not supported by Torch JIT.

2) This is done for diagram simplification. graspDSR and Pose Estimation component communicates only through RoboComp's ICE (standard interface), however DSR agents (including viriatoDSR and graspDSR) communicate only through graph G (where some agents inject information into G and others read from it). As for viriatoDSR and viriatoPyRep, they communicate through RoboComp's ICE, where viriatoDSR is the main interface between graph G and the simulator adapter viriatoPyrep.

Umer Jamil
@umerjamil16
@DarkGeekMS Thanks :)
RawanReda
@RawanReda
image.png
Any idea how I can carry out these two steps? I'm getting this error :
cannot stat 'TriangleFunctor': No such file or directory.
Esteban Martinena Guerrero
@orensbruli
Abdelrahman Abozied
@abdelrahmanzied
Hello everyone, I'm Abdelrahman Abozied, AI Engineer intern at GatsbAIin Egypt.
I'm a student in the 3rd year of Bachelor of Computer Science at Misr University for Science and Technology in Egypt.
I'm interested in Deep Learning and Computer Vision.
Kunal shah
@kunalshah03
@niveditarufus Hello! I am Kunal Shah, a pre-final year Computer Engineering Student studying at Pune Institute of Computer Technology, India. I am interested in contributing to the project: "Software agent for traffic and pedestrian traffic monitoring in outdoor environments using RGB cameras". I wanted to integrate a machine learning model for car detection with a Robocomp camera. Can you guide me as to which component should I use? Also, can you elaborate regarding the steps to follow to proceed further?
Manjunadh Kandavalli
@manju838
image.png
Can someone encounter this error?My Coppeliasim was installed and .bashrc file the following line: export COPPELIASIM_ROOT=~/robocomp/components/CoppeliaSim_Player_V4_1_0_Ubuntu20_04
But when I am following instructions in the tutorial,I am having problem here.Any suggestions?
Pawan Wadhwani
@pawanw17

Can someone encounter this error?My Coppeliasim was installed and .bashrc file the following line: export COPPELIASIM_ROOT=~/robocomp/components/CoppeliaSim_Player_V4_1_0_Ubuntu20_04

are you sure if the path is correct? and that you sourced the .bashrc after writing the command?

Manjunadh Kandavalli
@manju838
image.png
I am getting this error now,I sourced it and repeated the tutorial steps
Manjunadh Kandavalli
@manju838
image.png
@pwanw17,This is my .bashrc file, did I mess up with any qt path parameter?
Saurabh Suresh Powar
@Spnetic-5
image.png
2 replies
I'm getting this error while running LearnBlock, my installation was completely successful!
Amr Mostafa Abdelhalim
@amrmoastafa
I keep getting this error while trying to run LearnBlock , I tried different solutions on google but it seems not to work with it , if any one can help it would be really appreciated .
5 replies
Screenshot from 2021-04-03 05-38-45.png
Pilar Bachiller
@pilarbachiller
@Spnetic-5 did you set the PYTHONPATH environment variable?
@amrmoastafa maybe it is related with the last changes we have made in the config files. I'll check it and let you know
1 reply
Saurabh Suresh Powar
@Spnetic-5
@pilarbachiller Yes I have set PYTHONPATH
I have added < export PYTHONPATH="${PYTHONPATH}:~/LearnBlock" > this to ~/.bashrc
Pilar Bachiller
@pilarbachiller
@amrmoastafa I have fixed the problem. Please, update and try again
@Spnetic-5 replace the ~ symbol with your home directory
5 replies
Pilar Bachiller
@pilarbachiller
.bashrc is in your home directory: /home/your_name, being "your_name" your user name
12 replies
Saurabh Suresh Powar
@Spnetic-5
I ran sudo 'cp -p -r ~/LearnBlock/learnbot_dsl ~/LearnBlock/learnbot_dsl/learnbotCode/LearnBlock ~/LearnBlock/learnbot_dsl/components/apriltag/src/aprilTag.py' this command ~/LearnBlock/learnbot_dsl/components/emotionrecognition2/src/emotionrecognition2.py /usr/bin
Finally, it's working I'm able to run LearnBlock, but now it's showing JSONDecodeError
2 replies
Aditya Aggarwal
@adityaaggarwal97
Hello everyone, I am Aditya Aggarwal, co-mentor of the project Sign Langauge Recognition Project. In the past few days, we have received an overwhelming list of queries and messages from the students. In order to answer the common queries, we have created a FAQ document for your reference. You can contact us over the mail for specific queries or getting your proposal reviewed, however, please expect a slightly delayed response.
FAQ document: https://docs.google.com/document/d/1AygbWDNFE5YeAfHKpgaXmsWsxH0cYfB0c4yaV-EBYYo/edit?usp=sharing
Abdelrahman Abozied
@abdelrahmanzied

Hello,
I get this error when run "sudo make install"
Error: ModuleNotFoundError: No module named 'pyparsing'
I have installed it and checked by this line : python3 -c "import pyparsing; print(pyparsing.version)"
2.2.0

How Can I solve that?

Manjunadh Kandavalli
@manju838
@abdelrahmanzied Please check the install location,if you have both pip and pip3,then maybe the location it got installed may be different from your default path
Abdelrahman Abozied
@abdelrahmanzied
@manju838 I think that also and I reinstall it in the robocop folder, but still have the error.
Where I should install it?
Manjunadh Kandavalli
@manju838
@abdelrahmanzied I think this is the location to install: usr/local/lib/python3.8/dist-packages .In case you have multiple python versions,then you have multiple dist-package folders.Use pip3 install pyparsing==2.2.0 in the default location
For checking location of package print(pyparsing.path) instead of priting version.Hope this helps
Manjunadh Kandavalli
@manju838
pyparsing.path to be precise,sorry typo before
Fernando Martin
@fernan12345
Hi, i am trying to get the enviroment of AGM ready for work, but i am getting the following problem :
2 replies
"