Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Esteban Martinena Guerrero
    @orensbruli
    Can you share the output of the installation process?
    Sahil Jha
    @sjha2048
    will the output of "make" command full fill the purpose?
    Esteban Martinena Guerrero
    @orensbruli
    I don't think so. I can't guess what is wrong with your installation if I can't follow your steps.
    Luis J. Manso
    @ljmanso
    Can you tell us which OSG version have you installed and how did you install it (source, deb, snap...)?
    Sahil Jha
    @sjha2048
    Actually I installed OSG via apt now I am trying to install it from the source
    Sahil Jha
    @sjha2048
    after installing OSG from source, osgUtil library is missing
    here's the output of the make command
    Pawan Kumar
    @Prodyte
    After compilation, i couldn't get fetch meshes and textures from " git annex get . " command.
    image.png
    Esteban Martinena Guerrero
    @orensbruli
    @sjha2048 And have you tried to look for osgUtil in your system? If not, the problem is the osg installation. If it exist you have to find why it ins't found when compiling robocomp... Have you followed the osg instructions to install from source? have you executed sudo make install for osg?https://github.com/openscenegraph/OpenSceneGraph
    Chirantan123
    @Chirantan123
    Hi, I am Chirantan Mohanty a third year undergraduate student pursuing Btech in information technology from IIIT Bhubaneshwar.
    I am trying to run install robocomp on ubuntu but when when I am typing this command -rcis simpleworld.xml it is giving this error

    Command 'rcis' not found, did you mean:

    command 'rcs' from deb rcs

    Try: sudo apt install <deb name>

    Luis J. Manso
    @ljmanso
    Hello Chirantan,
    It is important that you follow all the steps in the installation instructions. Have you set up the environment variable?
    $ echo $ROBOCOMP
    /opt/robocomp
    Chirantan123
    @Chirantan123
    I tried setting the environment variable but it is still showing the same error
    Chirantan123
    @Chirantan123
    At the beginning of the installation when i wrote the command
    sudo pip install netwokx it showed me the error sudo : pip: command not found
    then i tried this command sudo apt-get install networkx and it showed
    reading package lists done
    Building dependency tree
    Reading state information. . . Done
    E: Unable to locate package networkx
    Esteban Martinena Guerrero
    @orensbruli
    @Chirantan123 ubuntu version?
    content of /opt/robocomp?
    Luis J. Manso
    @ljmanso
    If pip is not installed you have to install it first
    (I'll check the installation instructions)
    Esteban Martinena Guerrero
    @orensbruli
    I have just tested the installation on a clean ubuntu 18.04 and it's working
    @Chirantan123 maybe you haven't correctly executed the apt install command from the installation instruction, because theres a python-pip package on that command:
    sudo apt-get install git git-annex cmake g++ libgsl-dev libopenscenegraph-dev cmake-qt-gui zeroc-ice-all-dev freeglut3-dev libboost-system-dev libboost-thread-dev qt4-dev-tools python-pip python-pyparsing=2.2.0+dfsg1-2 python-numpy python-pyside pyside-tools libxt-dev libboost-test-dev libboost-filesystem-dev python-libxml2 python-xmltodict libccd-dev python-zeroc-ice zeroc-ice-all-runtime
    Chirantan123
    @Chirantan123
    @orensbruli my Ubuntu version is 18.04
    Esteban Martinena Guerrero
    @orensbruli
    can you try to execute the previous apt command and tell us if anything is installed?
    Chirantan123
    @Chirantan123
    After this I installed pip using sudo apt-get install pip and executed the command pip install networks and it executed
    But still when I am running rcis simpleworld xml the simulor
    Simulator is not opening.
    Esteban Martinena Guerrero
    @orensbruli

    sudo apt-get install git git-annex cmake g++ libgsl-dev libopenscenegraph-dev cmake-qt-gui zeroc-ice-all-dev freeglut3-dev libboost-system-dev libboost-thread-dev qt4-dev-tools python-pip python-pyparsing=2.2.0+dfsg1-2 python-numpy python-pyside pyside-tools libxt-dev libboost-test-dev libboost-filesystem-dev python-libxml2 python-xmltodict libccd-dev python-zeroc-ice zeroc-ice-all-runtime

    Can you execute that? and tell us if anything is installed?

    Chirantan123
    @Chirantan123
    It is giving this error

    Command 'rcis' not found, did you mean:

    command 'rcs' from deb rcs

    Esteban Martinena Guerrero
    @orensbruli
    @Chirantan123 please, read me above
    Chirantan123
    @Chirantan123
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libboost-filesystem-dev is already the newest version (1.65.1.0ubuntu1).
    libboost-filesystem-dev set to manually installed.
    git-annex is already the newest version (6.20180227-1).
    libboost-test-dev is already the newest version (1.65.1.0ubuntu1).
    libboost-test-dev set to manually installed.
    libccd-dev is already the newest version (2.0-1).
    libccd-dev set to manually installed.
    cmake is already the newest version (3.10.2-1ubuntu2.18.04.1).
    g++ is already the newest version (4:7.4.0-1ubuntu2.3).
    git is already the newest version (1:2.17.1-1ubuntu0.4).
    python-pip is already the newest version (9.0.1-2.3~ubuntu1.18.04.1).
    I am getting this as output
    at the end it showing this
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/zeroc-ice-slice_3.7.0-5ubuntu0.2_all.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/zeroc-ice-compilers_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/libzeroc-ice-dev_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/php-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/p/proj/proj-bin_4.9.3-2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/python-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/python3-zeroc-ice_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/zeroc-glacier2_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/zeroc-ice-all-dev_3.7.0-5ubuntu0.2_all.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/z/zeroc-ice/zeroc-ice-utils_3.7.0-5ubuntu0.2_amd64.deb Cannot initiate the connection to in.archive.ubuntu.com:80 (2403:8940:2::f). - connect (101: Network is unreachable) Cannot initiate the connection to in.archive.ubuntu.com:80 (103.123.234.254). - connect (101: Network is unreachable) [IP: 103.123.234.254 80]
    Esteban Martinena Guerrero
    @orensbruli
    it looks like a network problem. Have you tried multiple times?
    maybe it's just a temporary problem on the ubuntu mirror
    Chirantan123
    @Chirantan123
    running this command after apt-get command

    rcis simpleworld.xml

    Command 'rcis' not found, did you mean:

    command 'rcs' from deb rcs

    Try: sudo apt install <deb name>

    Chirantan123
    @Chirantan123
    I have successfully installed robocomp on my system and its running perfectly and as I am a beginner can anyone brief me some issues on which I can work on.