Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Nikos Gereoudakis
    @stream7
    I can definitely use that now
    so is it a bug?
    Robin Frischmann
    @rofrischmann
    oh youre not using SSR?
    Nikos Gereoudakis
    @stream7
    nope
    Robin Frischmann
    @rofrischmann
    so when the Provider hits, there'r no fela <style> elements in the head, right?
    Nikos Gereoudakis
    @stream7
    nope
    Robin Frischmann
    @rofrischmann
    hmm
    then for some reason this failed?
    when did u try upgrading the versions? we released new version yesterday around 2pm CEST
    Nikos Gereoudakis
    @stream7
    it was about then
    I run the tests in the CI with and without lockfile
    so I get a greenkeeper effect
    Robin Frischmann
    @rofrischmann
    maybe u just hit the older version where there was an issue
    if u could try upgrading once again (espeially react-fela)
    Nikos Gereoudakis
    @stream7
    I run yarn upgrade-interactive and no fela package appears though
    ├─ fela-bindings@1.3.4
    │  ├─ fela-dom@^7.0.4
    │  ├─ fela-tools@^5.1.2
    │  ├─ fela-tools@5.2.2
    │  │  ├─ fela-utils@^8.1.2
    │  │  └─ fela@^6.2.2
    ├─ fela-dom@7.0.9
    │  ├─ fela-utils@^8.0.8
    │  └─ fela-utils@8.1.2
    ├─ fela-monolithic@5.0.28
    │  ├─ fela-utils@^8.1.3
    ├─ fela-plugin-embedded@5.2.13
    ├─ fela-plugin-extend@5.0.12
    │  ├─ fela-utils@^7.0.4
    │  └─ fela-utils@7.0.5
    ├─ fela-plugin-fallback-value@5.0.20
    ├─ fela-plugin-prefixer@5.0.21
    │  ├─ fela-plugin-fallback-value@^5.0.20
    ├─ fela-plugin-unit@5.1.2
    ├─ fela-preset-web@8.0.13
    │  ├─ fela-plugin-embedded@^5.2.13
    │  ├─ fela-plugin-extend@^5.0.11
    │  ├─ fela-plugin-fallback-value@^5.0.20
    │  ├─ fela-plugin-prefixer@^5.0.21
    │  └─ fela-plugin-unit@^5.1.2
    ├─ fela-tools@5.2.3
    │  ├─ fela-utils@^8.1.3
    │  └─ fela@^6.2.3
    ├─ fela-utils@8.1.3
    ├─ fela@6.2.3
    │  ├─ fela-utils@^8.1.3
    ├─ react-fela@6.2.4
    │  ├─ fela-bindings@^1.3.4
    │  ├─ fela-dom@^7.0.4
    Robin Frischmann
    @rofrischmann
    hmm but the current fela-bindings v is 3.0.4 not 1.3.4
    (no idea how the upgrade-interactive stuff works though)
    Nikos Gereoudakis
    @stream7
    Well it seems I’m two major versions behind in react-fela :D
    Robin Frischmann
    @rofrischmann
    yeah..
    independent versioning was the biggest mistake ever
    Nikos Gereoudakis
    @stream7
    Ok nvm, I need to plan the upgrade I guess
    Did you remove the HOC completely? createComponent?
    Robin Frischmann
    @rofrischmann
    na
    not yet
    Nikos Gereoudakis
    @stream7
    ok, cool :D
    Robin Frischmann
    @rofrischmann
    its not even deprecated atm
    Nikos Gereoudakis
    @stream7
    Do you have to?
    Robin Frischmann
    @rofrischmann
    but itll be as soon as we have enough codemods to make upgrading smooth
    Nikos Gereoudakis
    @stream7
    Can’t you just keep both options?
    it kind of looks a bit better for some people I guess
    Robin Frischmann
    @rofrischmann
    check the last blog post I wrote, itll explain why those go
    Nikos Gereoudakis
    @stream7
    do you have a link for that?
    Robin Frischmann
    @rofrischmann
    im fine with so. maintaining those, but I dont want to do that my own
    and I don't want it to be part of react-fela, id be fine with a different package, but its super hard to improve stuff with always having to make cC and connect work as is
    Nikos Gereoudakis
    @stream7
    Robin Frischmann
    @rofrischmann
    yeah
    Nikos Gereoudakis
    @stream7
    Ok, cool, thanks for looking into it
    Nikos Gereoudakis
    @stream7
    @rofrischmann is there an easy way to see the breaking changes of react-fela 6 -> 8 ?
    Robin Frischmann
    @rofrischmann
    Thats probably the best resource
    Nikos Gereoudakis
    @stream7
    I think there was no breaking change tbh
    so it could have still been 6 :D
    also that previous problem I had is gone too
    or maybe it is cause I’m not using SSR in this project (regarding major version bump)
    Robin Frischmann
    @rofrischmann
    There was no major change in the react-fela package itself
    But within fela-bindings or fela-dom and as it requires those we bump a major because else your fucked with ^versions
    Nikos Gereoudakis
    @stream7
    I don’t want to know more :D
    hehe