These are chat archives for rus-speaking/android-off-topic

29th
Feb 2016
geek77
@geek77
Feb 29 2016 04:32
вот зачем мне гугл присылает промокоды для adwords с пометкой "только для новых пользователей"
издевается наверное
Rustem Saitkulov
@atetc
Feb 29 2016 07:12
Короче Лео таки взял свой оскар )
Rustem Saitkulov
@atetc
Feb 29 2016 07:20
Школоло is sad, закончилась эпоха стеба и мемов + еще и ПН )
Rustem Saitkulov
@atetc
Feb 29 2016 07:33
Двагисовцы прикольное видео запилили http://beta.2gis.ru/
iamtodor
@iamtodor
Feb 29 2016 07:58
Гиттер на убунте сломался. Шторки выезжающей слева нет о_О
Olzhas Ilyubayev
@hondrus
Feb 29 2016 09:58
@Iamtodor теперь навеки заточен в офф топике?
iamtodor
@iamtodor
Feb 29 2016 09:59
@Hondrus надеюсь, что это был не сарказм с твоей стороны) Захожу теперь через браузер))
This message was deleted
Константин Иванов
@linermgn
Feb 29 2016 10:01
мне через браузер даже удобнее в убунте, клиент ставил - снёс
в файрфоксе разрешаешь системные уведомления и закрепляешь вкладку с гиттером и очень удобно
Olzhas Ilyubayev
@hondrus
Feb 29 2016 10:02
в эмуляторе андроида есть приложение телефона?
Rizvan
@Gereyhanov
Feb 29 2016 10:09
В genymotion есть, а тем что в коробке давно не пользовался
Olzhas Ilyubayev
@hondrus
Feb 29 2016 10:18
спасиб
Ivan Tretyak
@ivantretyak
Feb 29 2016 11:47
Может ли использование паттерна мвп замедлять работу приложения? Звучит глупо, но когда я в приложении во фрагменте просто создавал тред и в нем выполнял обращение к апи, данные загружались за 1-2 секунды. После того как я реализовал мвп по примеру https://github.com/antoniolg/androidmvp/tree/master/app/src/main , те же действия занимают не менее 10 секунд.
Artem Gorev
@ArtemGorev
Feb 29 2016 11:48
нет, ты просто что-то делаешь не так, изучай кто добавляет задержку такую дикую
Kirill Ashikhmin
@KirillAshikhmin
Feb 29 2016 11:51
@elkyzmich замедляет, на пару инструкций процессору больше выполнять риходится, но это не заметно на глаз, тем более в 5-10 раз не может. Где-то есть косяк
Ivan Tretyak
@ivantretyak
Feb 29 2016 12:07
косяк нашел, стыдно говорить какой, поэтому не скажу :) вообще это правильно, к примеру, во избежание too many requests per second выполнять все запросы к апи в презентере?
geek77
@geek77
Feb 29 2016 12:13
@elkyzmich так чо за косяк?
делись граблями, вдруг кто-то тоже захочет по ним пройтись
Ivan Tretyak
@ivantretyak
Feb 29 2016 12:16
@geek77 я не думаю)) postDelayed просто был в хэндлере
geek77
@geek77
Feb 29 2016 12:16
бг
Irina
@LozariaVinok
Feb 29 2016 13:35
Привет! А у нас тут есть кто-нибудь, кто под wear разрабатывает?
Alatoo
@toktogul
Feb 29 2016 14:08
support library v7 ипортируется нормально в MainActivity , а в других классах не могу ипортировать, в чем понт ?
vkropivko
@vkropivko
Feb 29 2016 14:25
Я делал под wear
Irina
@LozariaVinok
Feb 29 2016 14:55
@vkropivko там можно как-то использовать ресурсы основного приложения?
Sanzhar Zholdiyarov
@szholdiyarov
Feb 29 2016 14:55
ребят) мне тут нужно приложение какое-нибудь простое написать) например курс валют или напоминалку
естб идеи у кого-нибудь?)
vkropivko
@vkropivko
Feb 29 2016 15:00
@LozariaVinok вроде нет , там даже градл другой
Irina
@LozariaVinok
Feb 29 2016 15:00
гадко это как-то копировать ресурсы(((
vkropivko
@vkropivko
Feb 29 2016 15:00
@szholdiyarov апи от приватбанка , там есть вся инфа
Sanzhar Zholdiyarov
@szholdiyarov
Feb 29 2016 15:10
@vkropivko спасибо за идею:)
у кого есть еще идеи?
Kirill Ashikhmin
@KirillAshikhmin
Feb 29 2016 15:19
@szholdiyarov Подумай какого приложения тебе не хватает или каким пользоваться не совсем удобно и реализуй. Так и полезнее и интереснее будет)
Sanzhar Zholdiyarov
@szholdiyarov
Feb 29 2016 15:21
@BOOMik мне простое приложение на учебе нужно) предмет такой, не хочу тратить много времени на написание. Задача показать весь процесс разработки(от дизайна до маркета), поэтому не хочу писать сложное приложение пока
Kirill Ashikhmin
@KirillAshikhmin
Feb 29 2016 15:24
@szholdiyarov Вас в учебном заведении учат андроид-разработке? Круто же) А так все равно моё предожение тем же останется. Может понравится и хочешь развить а потом продавать))
Irina
@LozariaVinok
Feb 29 2016 15:26
у нас тоже в свое время была лаба под андроид и даже под вебось, которая вроде уже благополучно похоронена)
Sanzhar Zholdiyarov
@szholdiyarov
Feb 29 2016 15:29
@BOOMik нет😂 учат не самой разработке и написанию кода, а процессу. Херня короче) moodboards, fontboadts etc.
Kirill Ashikhmin
@KirillAshikhmin
Feb 29 2016 15:30
@szholdiyarov хм
Vladimir Mironov
@nsk-mironov
Feb 29 2016 17:09
пофиг на грамматику, а вот за плавающую версию зависимости нужно бить палками
нам из-за них в проект приехала новая версия саппорта с новыми багами, хотя мы ее не обновляли
Kirill Ashikhmin
@KirillAshikhmin
Feb 29 2016 17:16
@nsk-mironov А вот когда в библиотеке прописана старая зависимость и проекту новую не поставить тоже не особо лучше...
geek77
@geek77
Feb 29 2016 17:19
с трудом представляю себе андроид-либу без саппорта в депах
т.е. вообще не представляю
так что ребята, если вы используете андроид-либу - то или не обновляйтесь, или тестируйте после обновлений все. и разобновляйтесь взад, если что-то не так
Vladimir Mironov
@nsk-mironov
Feb 29 2016 17:22
очень ценный совет, спасибо
вот только мы ничего не обновляли
но новый саппорт нам все равно приехал
потому что ребят в фейсбуке не научили ставить точные версии зависимостей
geek77
@geek77
Feb 29 2016 17:31
угу не обновляли
только фейспук сдк из гита танули
да? :)
Alexey Illarionov
@illarionov
Feb 29 2016 17:49
@geek77 если у либы нет UI, то почему бы и не?
Alexey Illarionov
@illarionov
Feb 29 2016 17:57
@geek77 support и appcompat в планеобновлений очень тяжелые либы. В новых версиях всегда есть новые баги и всегда где-нибудь ломается совместимость.
geek77
@geek77
Feb 29 2016 18:00
@illarionov это понятно. Непонятно требование не трогать версии зависимостей в мастере гита. Надо со старой - поменяй и собери, если уж сам собираешь. Не собираешь - значит у тебя уже прописана зависимость с версией из репы и эта проблема тебя не касается.
Alexey Illarionov
@illarionov
Feb 29 2016 18:07
@geek77 там без разницы, из гита или не из гита. в SDK 4.9 они в build.gradle точные версии заменили на диапазоны ((23,24]). Где там аналог рельсового bundle был? :)
geek77
@geek77
Feb 29 2016 18:13
ну при переезде на 4.9 надо учитывать и это в том числе
опять же - заюзать новую версию SDK - это не "ничего не обновляли, всё сломалось"