These are chat archives for rust-lang/rust

5th
Mar 2016
Daniil
@voddan
Mar 05 2016 11:29
Hi, I don't get auto-completion in the eclipse plugin RustDT.
I installed racer and set the path to the executable in settings.
I am on OS X Capitan, Eclipse Mars.2
Also I wasn't able to install rainicorn.
Probably I can't configure right.
Can you suggest something? A diagnostic maybe?
Erik Hedvall
@Ogeon
Mar 05 2016 11:47
I don't know if it's necessary with RustDT, but racer needs the Rust library source, as well, to be able to auto complete for it. You should then be able to write use std:: and it should give you a list of modules and types.