Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 04:40
    ryanoasis closed #369
  • 04:40
    ryanoasis commented #369
  • Oct 19 09:50
    MustafaErgul closed #417
  • Oct 19 09:50
    MustafaErgul commented #417
  • Oct 18 18:48
    David-Else commented #610
  • Oct 18 18:44
    David-Else commented #610
  • Oct 18 13:32
    csholmq opened #677
  • Oct 17 23:30
    qwattash commented #564
  • Oct 17 23:29
    qwattash commented #564
  • Oct 17 23:29
    qwattash commented #564
  • Oct 17 05:25
    ryanoasis commented #644
  • Oct 17 05:24
    ryanoasis commented #664
  • Oct 17 05:21
    ryanoasis commented #593
  • Oct 17 05:17

    ryanoasis on master

    misleading _Note_: Only for Lin… Merge pull request #671 from Gi… (compare)

  • Oct 17 05:17
    ryanoasis closed #671
  • Oct 17 05:16
    ryanoasis commented #671
  • Oct 17 04:55
    BrandonKMLee commented #300
  • Oct 15 15:00
    JCzz opened #676
  • Oct 14 14:50
    fracsinus commented #644
  • Oct 14 14:43
    fracsinus edited #644
[mectos]
@mectos
Hello, tried to use the issue of square brackets around icons. The plugin is indeed set to 1 (check with the command in stage 1), though in the second stage it fails. instead of +conceal it gives me -conceal. I presume that this is the reason it doesn't work. Thank you in advance for your time boiz.
[mectos]
@mectos
Btw, in my PC (OS is Pop_OS!, Ubuntu based) it works for some reason, it keeps showing the brackets in my Mac though :(
Shady Alfred
@ShadyAlfred
@ryanoasis I use gVim on Windows 7 with a Nerd Font. It's not that a big of issue anyways, I guess Vim's support on Windows isn't that great lol
Shaedil
@Shaedil
@ShadyAlfred I had the same scenario, except I used a monospaced Nerd Font. Worked for me!
Shady Alfred
@ShadyAlfred
@Shaedil what's the name of the font?
Shaedil
@Shaedil
Well, I used "DroidSansMono_NF" for my airline statusline. I don't know about lightline
Tsakiris Tryfon
@tsakirist
Hello, icons do not appear in vim-startify i have even enabled the option in my .vimrc : let g:webdevicons_enable_startify=1.
In the FAQ it's said that it should work out off the box but in my case it doesn't.
Neovim version: NVIM v0.5.0-dev
Shady Alfred
@ShadyAlfred
@Shaedil I confirm, with DroidSansMono it works nicely. I was using Haklug NF
Tsakiris Tryfon
@tsakirist
For anyone possibly having the same problem as me i fixed it by merely loading the startify plugin before loading devicons.
[mectos]
@mectos
@ryanoasis :(
Ryan L McIntyre
@ryanoasis
@mectos yes correct the conceal feature would have to be there for the brackets to be hidden
[mectos]
@mectos
@ryanoasis What do you mean? but the conceal expression is already written in my config file. The problem is that with the same config it works (hide properly the brackets) in my Ubuntu machine, but doesn’t work (doesn’t hide the brackets) in my Mac
Igor Lakić
@igorlakic

Hi all! :) I have one issue I cannot solve related to vim-devicons and startify. I simply cannot get devicons to show on the startify. I have devicons in my NERDtree, they are functioning properly there but cannot get them in startify.
I put these lines at the end of my "init.vim" file:

" Reload icons after init source
if exists('g:loaded_webdevicons')
  call webdevicons#refresh()
endif
" adding to vim-startify screen
let g:webdevicons_enable_startify = 1

let entry_format = "'   ['. index .']'. repeat(' ', (3 - strlen(index)))"

if exists('*WebDevIconsGetFileTypeSymbol')  " support for vim-devicons
  let entry_format .= ". WebDevIconsGetFileTypeSymbol(entry_path) .' '.  entry_path"
else
  let entry_format .= '. entry_path'
endif

I would appreciate your help. Thanks in advance! :)

hikerpig
@hikerpig

Hi all ~ I have encountered an error, have anyone seen this before ?

Plug devicons is added after denite, but I still got this, kind of confused.

[denite] Traceback (most recent call last):
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/rplugin.py", line 28, in start
[denite]     return ui.start(args[0], context)
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/ui/default.py", line 65, in start
[denite]     self._start_sources_queue(context)
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/ui/default.py", line 155, in _start_sources_queue
[denite]     self._start(context['sources_queue'][0], context)
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/ui/default.py", line 202, in _start
[denite]     self._init_denite()
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/ui/default.py", line 755, in _init_denite
[denite]     self._denite.start(self._context)
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/parent.py", line 44, in start
[denite]     self._put('start', [context])
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/parent.py", line 80, in _put
[denite]     return self._child.main(name, args, queue_id=None)  # type: ignore
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/child.py", line 71, in main
[denite]     self.start(args[0])
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/child.py", line 98, in start
[denite]     self._load_filters(context)
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/child.py", line 470, in _load_filters
[denite]     for Filter, path, module_path in rplugins:
[denite]   File "~/.vim/plugged/denite.nvim/rplugin/python3/denite/util.py", line 256, in import_rplugins
[denite]     spec.loader.exec_module(module)  # type: ignore
[denite]   File "<frozen importlib._bootstrap_external>", line 678, in exec_module
[denite]   File "<frozen importlib._bootstrap>", line 205, in _call_with_frames_removed
[denite]   File "~/.vim/plugged/vim-devicons/rplugin/python3/denite/filter/devicons_denite_converter.py", line 3, in <module>
[denite]     from .base import Base
[denite] SystemError: Parent module 'denite.filter' not loaded, cannot perform relative import
[denite] Please execute :messages command.
Igor Lakić
@igorlakic

Hi all! :) I have one issue I cannot solve related to vim-devicons and startify. I simply cannot get devicons to show on the startify. I have devicons in my NERDtree, they are functioning properly there but cannot get them in startify.
I put these lines at the end of my "init.vim" file:

" Reload icons after init source
if exists('g:loaded_webdevicons')
  call webdevicons#refresh()
endif
" adding to vim-startify screen
let g:webdevicons_enable_startify = 1

let entry_format = "'   ['. index .']'. repeat(' ', (3 - strlen(index)))"

if exists('*WebDevIconsGetFileTypeSymbol')  " support for vim-devicons
  let entry_format .= ". WebDevIconsGetFileTypeSymbol(entry_path) .' '.  entry_path"
else
  let entry_format .= '. entry_path'
endif

I would appreciate your help. Thanks in advance! :)

I've opened a new issue (ryanoasis/vim-devicons#302). I hope someone will find some time to help me solve this problem. Thanks in advance!

MinHyeokBae
@bmh8993
hi all! vim-devicons so beaty! but in my case, icon image so thick..bold...
How can I make it thinner?
MinHyeokBae
@bmh8993
hmm..I didn't do anything. resolved..;;
Sushovan
@sushovannits

Hi guys, I have just set up vim-devicons in mac and using macvim and iterm2. And I cannot see any file icons. All come as ?
Going through the troubleshooting section I see that

:echo g:WebDevIconsUnicodeDecorateFileNodesDefaultSymbol

fails for me. What should be done next?

Similar problem as @wonter
I can set the default symbol and have it display in NERDTree
Harun Sheikhali
@hsheikhali
Hey Guys I got a question -- does anyone know where I can view a selection of different icon options?
Michel Difils
@mdifils
image.png
Hi guys, I have a similar problem as @sushovannits . I have just set up vim-devicons in Ubuntu 20.04 (WSL2), I'm using neovim and I can't see any filetype icon. All comes as 
Checking the default symbol fails and setting it to 'x' shows this:
image.png
I downloaded nerd font into this folder:
Michel Difils
@mdifils
image.png
image.png
I set up the guifont in my init.vim file and devicon is the last plugin to be loaded
image.png
Michel Difils
@mdifils
I have installed vim-devicon with vim-plug manager:
image.png
Michel Difils
@mdifils
Can you please help me figure out what's wrong?
I'm using ubuntu 20.04 (WSL2), bash version 5.0.16(1), NVIM v0.4.3
Thanks
Sushovan
@sushovannits
@mdifils my problem was this one https://github.com/ryanoasis/nerd-fonts/issues/13#issuecomment-190252936
I am using iterm2 and I had to chose the option of Use a different font for non-ASCII text
Might be something similar for you?
csh
@caoshenghui
are u using windows terminal?download the LiberationMono to your windows and set terminal font
so it works right on wsl...
Shiny Hou
@kuops
image.png
when i press ?help have afterimage
neovim 0.4.3
but use vim 8.1 not happen
Daniel O'Brien
@dob9601
Hi, I was wondering if it was possible to change the airline tabline format without breaking vim-devicons
vim-devicons appears to set airline#extensions#tabline#formatter to webdevicons which appears to be a combination of airlines default tabline format but with dev icons. However, I want to use the unique_tail format instead
Daniel O'Brien
@dob9601
Never mind, I've figured out how to do so -
Harsha
@harshavardhanc
Hi Guys, I'm using arch linux with neovim+nerdtree, just tried using this plugin but I'm getting broken icons in nerdtree. Is there any fonts package we need to install to make it work?
Abdullah
@Abdullah_gitlab
Robert DeFilippi
@rrfd_twitter
Hello, does vim-devicons have a "legend" for what each icon means?
Sam Sysnomid
@sysnomid_gitlab
image.png
devicons are only showing up half on monospace font?
any help?
Sam Sysnomid
@sysnomid_gitlab
@ryanoasis
I think there was a github thread about this somewhere idk