Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    BanthaMan
    @BanthaMan
    Hey guys, I got typo up and running on heroku but I can't access categories (just get blank page), anyone having this prolem?
    Or is that the bug?
    Lokesh Sharma
    @lokeshh
    That's the issue my friend
    Lokesh Sharma
    @lokeshh
    I was confused too, haha!
    BanthaMan
    @BanthaMan
    Excellent, I had so many problems setting everything up I thought I broke it
    Ehbraheem
    @Ehbraheem
    @all anyone have a luck setting typo up in windows
    BanthaMan
    @BanthaMan
    At what step did it not work?
    Ehbraheem
    @Ehbraheem
    bluecloth gem
    BanthaMan
    @BanthaMan
    give us a console log
    Ehbraheem
    @Ehbraheem
    Valentino Massimo
    @Valmach
    is anyone getting this error from cloud 9 "We're sorry, but something went wrong"
    been trying for a couple of days to get this
    typo
    going..
    checked with Heroku Support .. they say there is an error in the application code..

    here appears to be a bug in the application code. Here it is in your logs:

    2016-10-04T17:32:13.857544+00:00 app[web.1]: == SuperclassArticles: migrating =============================================
    2016-10-04T17:32:13.857579+00:00 app[web.1]: -- Merging Articles into Contents table
    2016-10-04T17:32:13.857674+00:00 app[web.1]: -- create_table(:contents)
    2016-10-04T17:32:13.868755+00:00 app[web.1]: -> 0.0110s
    2016-10-04T17:32:13.868820+00:00 app[web.1]: -- execute("select nextval('contents_id_seq')")
    2016-10-04T17:32:13.869661+00:00 app[web.1]: -> 0.0008s
    2016-10-04T17:32:13.938607+00:00 heroku[router]: at=info method=GET path="/" host=stark-lowlands-26312.herokuapp.com request_id=8006d611-7007-4617-8001-fa71aac610f9 fwd="70.199.140.37" dyno=web.1 connect=0ms service=292ms status=500 bytes=887
    2016-10-04T17:32:13.931291+00:00 app[web.1]: -> Resetting PostgreSQL sequences
    2016-10-04T17:32:13.931310+00:00 app[web.1]: -- execute("select setval('contents_id_seq',max(id)) from contents")
    2016-10-04T17:32:13.932656+00:00 app[web.1]: -> 0.0013s
    2016-10-04T17:32:13.932719+00:00 app[web.1]: -- execute("select nextval('contents_id_seq')")
    2016-10-04T17:32:13.933469+00:00 app[web.1]: -> 0.0007s
    2016-10-04T17:32:13.933494+00:00 app[web.1]: -- remove_index(:articles, :permalink)
    2016-10-04T17:32:13.946541+00:00 app[web.1]: Completed 500 Internal Server Error in 228ms
    2016-10-04T17:32:13.951862+00:00 app[web.1]:
    2016-10-04T17:32:13.951868+00:00 app[web.1]: StandardError (An error has occurred, this and all later migrations canceled:
    2016-10-04T17:32:13.951869+00:00 app[web.1]:
    2016-10-04T17:32:13.951870+00:00 app[web.1]: Index name 'index_articles_on_permalink' on table 'articles' does not exist):
    2016-10-04T17:32:13.951870+00:00 app[web.1]: lib/migrator.rb:26:in migrate' 2016-10-04T17:32:13.951871+00:00 app[web.1]: app/models/trigger.rb:23:inrescue in fire'
    2016-10-04T17:32:13.951872+00:00 app[web.1]: app/models/trigger.rb:12:in fire' 2016-10-04T17:32:13.951872+00:00 app[web.1]: app/controllers/application_controller.rb:36:infire_triggers'

    there should be no error when uploading to heroku?.. n'est pas?.. the blog should open... in the browser via the heroku link... ?
    Sam Joseph
    @tansaku
    @Valmach sorry to be a broken record but any chance you could post the full details in the forum?
    I.e. The edx forum for the mooc
    Sam Joseph
    @tansaku
    oh sorry - think I was seeing this on a lag - ignore me - this is solved right?
    BanthaMan
    @BanthaMan
    Anyone know how to make a non admin account?
    Lokesh Sharma
    @lokeshh
    I did it with User.create
    BanthaMan
    @BanthaMan
    Ok
    BanthaMan
    @BanthaMan
    So can non admins not access admin panel in the first place?
    Lokesh Sharma
    @lokeshh
    @BanthaMan I think a better way which I just found out now is to go here, create a new user ans see for yourself: http://lokeshh-typo.herokuapp.com/admin/users
    BanthaMan
    @BanthaMan
    Thank you so much! Did not know of that page
    Valentino Massimo
    @Valmach
    @tansaku Sam you seen this before?

    @tansaku Typo Blog " Something Went Wrong"

    It seems something went wrong. Maybe some of your sidebars are actually missing and you should either reinstall them or remove them manually..

    No issues locally https://saas2x-valmach.c9users.io/admin..

    Heroku produces this 'error on the right side of blog.'

    It seems something went wrong. Maybe some of your sidebars are actually missing and you should either reinstall them or remove them manually..

    Sam Joseph
    @tansaku
    @valmach that rings a bell. Could you post in the edx forum and we'll take a look tomorrow?
    BanthaMan
    @BanthaMan
    Is there any specific way the text is meant to be combined? I'm just combining the bodies but that appears to be failing.
    Seth Chute
    @s-d-c
    After getting set up for Legacy HW 1, I ran cucumber and rspec. Cucumber tests pass as expected. all rspec tests are failing initially. Is this expected or is something wrong? Specifically, if I just run rspec tests on the categories controller they all fail with the same message:
    Failure/Error: Factory(:blog)
    ActiveRecord::RecordInvalid:
    Validation failed: There can only be one...
     # ./spec/controllers/admin/categories_controller_spec.rb:7:in `block (2 levels) in <top (required)>'
    Punita Ojha
    @punitaojha
    This message was deleted
    qutorial
    @qutorial
    Hi all. Yeah. The setting up of the typo was so harsh, that I do not know, if I am getting "The right bug" or just the setup is broken.
    What do you guys see when clicking on the 'Categories' in the left bar?
    got heroku deployment work also after a set of tries and failures
    panagiotismak
    @panagiotismak
    Hello all, is anyone having a problem when trying "bundle install --without production" for the app? i get this "There were an error parsing 'gemfile': The 'branch' option for 'gem' 'recaptcha' is not allowed. only gems with a git source can specify a branch. Bundle cannot continue"