Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Sai Krishna
    @saikrishna321
    @antoniomapc_twitter

    <dependency>
    <groupId>com.github.saikrishna321</groupId>
    <artifactId>AppiumTestDistribution</artifactId>
    <version> 1f4a3e6426 </version>
    </dependency>

    <repositories>
    <repository>
    <id>jitpack.io</id>
    <url>https://jitpack.io</url>
    </repository>
    </repositories>

    Gopinath
    @vsgopinath
    @saikrishna321 I am trying to run the sample project to check the report generation but I am getting the below error now :
    image.png
    I am using Java Version : 1.8.0_181-b13 AppiumTestDistribution Version : 9.1.0
    Sai Krishna
    @saikrishna321
    looks like u have some dependency clash
    i dont see any asm jar in the repo
    Gopinath
    @vsgopinath
    Okay. @saikrishna321 Can you tell me which java version that you are using now. I tried OpenJDK11 which is causing some other problem.
    Sai Krishna
    @saikrishna321
    Java 8 or 9 should .. nothing above that ... appointment does not support
    Gopinath
    @vsgopinath
    Okay fine. Let me downgrade to Java 9 then Thanks.
    Sai Krishna
    @saikrishna321
    I would prefer 8 ..
    Gopinath
    @vsgopinath
    Its working now. But got the below error :
    image.png
    The app is not closed after the execution in both the iOS device simulators
    Sai Krishna
    @saikrishna321
    can u share full logs pls
    Gopinath
    @vsgopinath
    Sai Krishna
    @saikrishna321
    an I don't see any issues in the log
    Gopinath
    @vsgopinath
    report is not generated and app is not closed after finishing the test
    Sai Krishna
    @saikrishna321
    r u using master ? or version 9.1.0 ?
    we have removed extent reports and moved to report portal v9.1.0 does support reportportal
    Gopinath
    @vsgopinath
    @saikrishna321 I am running the sample project only in which the version is 9.1.0 . Do I need to change the version ?
    Sai Krishna
    @saikrishna321
    yah in version 9.1.0 we have removed extent reports and have report portal
    Sivaganesh Sivakumar
    @sivaganesh1988
    Hi how to disable app installation ? Whenever I am running the existing app is getting uninstalled and new app is getting installed.
    Sai Krishna
    @saikrishna321
    you can control that will capabilities
    noReset
    sanket492
    @sanket492
    Hi Sai, need your help regarding parallel execution on multiple android devices. Posted the issue on appium community (https://discuss.appium.io/t/getting-econnrefused-for-one-system-port-when-parallel-android-tests-are-run/27561)
    Gopinath
    @vsgopinath
    @saikrishna321 Can you please let me know the working ATD version and sample capabilities for that version. It seems the demo project is outdated and I couldn't able to run the tests as some of the capabilities seems to be missing
    AOLUWASE-ford
    @AOLUWASE-ford
    @saikrishna321 I and trying to run Platform="ios" mvn clean -Dtest=Runner test on PageObjectPatternAppium framework but getting below error: [WARNING]
    [WARNING] Some problems were encountered while building the effective model for com.pagepattern.appium:PagePatternAppium:jar:0.0.1-SNAPSHOT
    [WARNING] 'dependencies.dependency.version' for log4j:log4j:jar is either LATEST or RELEASE (both of them are being deprecated) @ line 26, column 22
    [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-compiler-plugin is missing. @ line 80, column 21
    [WARNING]
    [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
    [WARNING]
    [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
    [WARNING]
    [INFO]
    [INFO] --------------< com.pagepattern.appium:PagePatternAppium >--------------
    [INFO] Building PagePatternAppium 0.0.1-SNAPSHOT
    [INFO] --------------------------------[ jar ]---------------------------------
    [WARNING] The POM for com.github.AppiumTestDistribution:AppiumTestDistribution:jar:fix-533-SNAPSHOT is missing, no dependency information available
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD FAILURE
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 0.213 s
    [INFO] Finished at: 2020-02-20T12:06:11Z
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal on project PagePatternAppium: Could not resolve dependencies for project com.pagepattern.appium:PagePatternAppium:jar:0.0.1-SNAPSHOT: Failure to find com.github.AppiumTestDistribution:AppiumTestDistribution:jar:fix-533-SNAPSHOT in https://jitpack.io was cached in the local repository, resolution will not be reattempted until the update interval of jitpack.io has elapsed or updates are forced -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException