Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 12 22:41
    pjcross assigned #899
  • Jun 12 22:41
    pjcross labeled #899
  • Jun 12 22:41
    pjcross opened #899
  • Jun 12 22:36
    pjcross closed #832
  • Jun 12 22:36
    pjcross closed #833
  • Jun 12 22:12

    Mletter1 on master

    fixing parse error (compare)

  • Jun 12 21:44

    Mletter1 on master

    cleaning old docs (compare)

  • Jun 12 19:46

    Mletter1 on master

    Update DELETE-logout.rst making old set of docs (compare)

  • Jun 12 18:21

    Mletter1 on master

    removing paths from server (compare)

  • Jun 06 07:54

    alexsielicki on react

    Update SlycatSelector.tsx Adding initial check for new CS… Merging and 15 more (compare)

  • Jun 06 07:47

    alexsielicki on master

    Updating JS packages Updating … (compare)

  • Jun 06 06:32

    alexsielicki on react

    Redux work (compare)

  • Jun 05 21:39

    Mletter1 on master

    cleanup (compare)

  • Jun 05 21:37
    Mletter1 labeled #898
  • Jun 05 21:37
    Mletter1 edited #898
  • Jun 05 21:36
    Mletter1 assigned #898
  • Jun 05 21:36
    Mletter1 assigned #898
  • Jun 05 21:36
    Mletter1 opened #898
  • Jun 05 19:50

    Mletter1 on master

    Update update-table.jsx (compare)

  • Jun 05 19:39

    Mletter1 on master

    abstracted out modal (compare)

Gabriel Arrillaga
@lustrousgorilla
just as shorthand for ko.observableArray() ?
Timothy M. Shead
@tshead2
mapping.fromJS() converts a “normal” javascript object into one based on observables.
Yes.
I’m stepping through wizard creation with a TI model.
What I’m seeing is that the Javascript is loaded, but the HTML is not.
Gabriel Arrillaga
@lustrousgorilla
interesting
Gabriel Arrillaga
@lustrousgorilla
i'm looking at a component js/template pair, but i don't see a script block in the template applying the bindings
specifically the hello world wizard
is it running somewhere else or is there a different way to connect the template with a view model?
Timothy M. Shead
@tshead2
What happens in slycat-navbar.js is we register a ko component for each wizard type, but the component doesn’t load the code or the template until it’s instantiated. They get instantiated using the “component” binding in the navbar template.
Gabriel Arrillaga
@lustrousgorilla
ah, I see
Timothy M. Shead
@tshead2
When the component is instantiated, ko uses require() to load an AMD module. The module, in-turn, returns the code and template for the component, each of which can be loaded dynamically (or not).
I just realized that there’s a more elegant way to load the wizard template so I don’t have to duplicate the code for looking-up server-root, so I’m making that change now (it simplifies the dependencies for the wizard, so may help with our bug).
Gabriel Arrillaga
@lustrousgorilla
ok, so it looks like the argument 'item' to run_wizard is just an implicitly passed 'this'
that refers to $parent
Timothy M. Shead
@tshead2
Yep.
Timothy M. Shead
@tshead2
Take the “Delete Model” wizard as an example. I’ve verified that the wizard code is loaded, but its callback for define() is never called. I tried removing all of its dependencies, but it still isn’t called. So something is interfering with the functionality of define().
Gabriel Arrillaga
@lustrousgorilla
how can I best help here? I'm starting to get a handle on your knockout code works and would be happy to dive in and look somewhere you're not
have you tried naming the module?
possibly something to do with them being anonymous shrug
Gabriel Arrillaga
@lustrousgorilla
it's strange that it's only breaking for two of the models though, ill see if I can identify any differences in how modules are being defined in those two vs in the models that work
Timothy M. Shead
@tshead2
As I understand it, modules that are loaded dynamically (like wizards) can be anonymous. Modules that aren’t loaded by curl (like bundled modules) must have module identifiers. So a good bet would be to look for anonymous modules in the model plugin bundles.
Gabriel Arrillaga
@lustrousgorilla
in at least one of the broken models, there are no anonymous modules
Timothy M. Shead
@tshead2
This theory is supported by a special debugging module for curl that I just loaded - I think I’m seeing a “Multiple anonymous defines encountered” error, though I’m not sure why it wouldn’t appear in the console by default.
Bummer.
Gabriel Arrillaga
@lustrousgorilla
what's the name of the debugging module? sounds like I should get it too
Also, I’m about to disappear into a mtg. Will check in later.
Gabriel Arrillaga
@lustrousgorilla
i know you wrapped d3 in a module, did you wrap any of the jquery or slickgrid stuff for CCA?
Timothy M. Shead
@tshead2
Actually, d3 and jquery were both already “AMD aware”, i.e. if define() is available they use it to define themselves as modules. All I did for d3 was assign a module identifier so it could be loaded in a bundle. I actually never touched slick grid, that’s an interesting place to followup.
Greg
@Awnage
We found the screenshot of car data on sourceforge. Could you place more screenshots of other analyses into readthedocs?
Matt
@Mletter1
@Awnage we have added more screenshots to the README.md at https://github.com/sandialabs/slycat. They should now be displayed on the main page.
ajpowel
@ajpowel
Hello -- I have struggled w/ Dockers & Slycat mightily, but cannot get Slycat to function as indicated in the documentation...whether in a pure OSX sense, or via these instructions:
Could you guys please help me? Thnx, AJP
Here's representative errors:
docker@default:~$ docker run -d -p 2222:22 -p 80:80 -p 443:443 --name slycat sandialabs/
slycat-developer
Unable to find image 'sandialabs/slycat-developer:latest' locally
Pulling repository docker.io/sandialabs/slycat-developer
docker: Error: image sandialabs/slycat-developer not found.
Additional notes after re-starting:
docker version
Client:
Version: 1.11.2
API version: 1.23
Go version: go1.5.4
Git commit: b9f10c9
Built: Wed Jun 1 21:20:08 2016
OS/Arch: darwin/amd64
Cannot connect to the Docker daemon. Is the docker daemon running on this host?
Matt
@Mletter1
first the docker command is wrong should be as follows
docker run -p 2222:22 -p 80:80 -p 443:443 -p 5984:5984 -d --name slycat slycat/slycat-developer
you had sandialabs/slycat-developer
second it looks like your docker daemon isn't running
eval "$(docker-machine env default)"
have you run
for osx
just ran the docker command seemed to pull fine heres the output
docker run -p 2222:22 -p 80:80 -p 443:443 -p 5984:5984 -d --name slycat slycat/slycat-developer
Unable to find image 'slycat/slycat-developer:latest' locally
latest: Pulling from slycat/slycat-developer
a3ed95caeb02: Pulling fs layer
35d9d5d11536: Pulling fs layer
18709e163fd8: Pulling fs layer
318b18a93cbb: Pulling fs layer
...
...
Matt
@Mletter1
are you trying to build your own image or use the one on docker hub?