These are chat archives for sbt/sbt-header

12th
Aug 2017
Nicolas Rinaudo
@nrinaudo
Aug 12 2017 13:16
@hseeberger am I right to understand that, as far as sbt-header is concerned, sbt 0.13.x is EOL?
or are there any plan to cross build to 0.13 and 1.0.0 for a while?
Heiko Seeberger
@hseeberger
Aug 12 2017 14:03
Just use 2.0.0
for sbt 0.13
It's feature equal to 3.0.0.
Nicolas Rinaudo
@nrinaudo
Aug 12 2017 14:08
I understand that, and that's what I might end up doing, but I have an autoplugin that I need to support both 0.13 and 1.0.0, at least for a while. And I currently cannot because sbt-header and tut do not cross-compile
that sounded like an accusation, sorry. It's a perfectly legitimate decision to make, I just wanted to make sure it was by design and not an oversight
Heiko Seeberger
@hseeberger
Aug 12 2017 14:10
Got it. Please PR cross building.
Nicolas Rinaudo
@nrinaudo
Aug 12 2017 14:10
will do, thanks!
A. Alonso Dominguez
@alonsodomin
Aug 12 2017 15:41
there is already a PR for cross building sbt-header: sbt/sbt-header#120
also notice that there is a bug in sbt 0.13.16 & 1.0.0 regarding SBT cross-builds of plugins that depend on other plugins: sbt/sbt#3393
Nicolas Rinaudo
@nrinaudo
Aug 12 2017 17:21
Interesting. I'm running in exactly the same problem
I mean the one described in your PR,not the one yu linked to
A. Alonso Dominguez
@alonsodomin
Aug 12 2017 17:24
mmm, that’s defo interesting… I assumed it was something regarding my local environment when I saw that Travis did not have that problem...
Nicolas Rinaudo
@nrinaudo
Aug 12 2017 17:25
Is it possible that the modules (not plugins) aren't published locally for 1.0.0?