Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • May 01 11:38

    cquiroz on master

    Bump actions/cache from v2.1.4 … Merge pull request #283 from cq… (compare)

  • May 01 11:38

    cquiroz on github_actions

    (compare)

  • May 01 11:38
    cquiroz closed #283
  • May 01 05:29
    dependabot[bot] labeled #283
  • May 01 05:29
    dependabot[bot] opened #283
  • May 01 05:29

    dependabot[bot] on github_actions

    Bump actions/cache from v2.1.4 … (compare)

  • Apr 27 15:42
    cquiroz closed #280
  • Apr 27 15:42

    cquiroz on master

    Update sbt-microsites to 1.3.4 Merge pull request #282 from sc… (compare)

  • Apr 27 15:42
    cquiroz closed #282
  • Apr 27 14:24
    scala-steward opened #282
  • Apr 26 15:35

    cquiroz on master

    Update sbt to 1.5.1 Merge pull request #281 from sc… (compare)

  • Apr 26 15:35
    cquiroz closed #281
  • Apr 26 07:29
    scala-steward opened #281
  • Apr 23 14:22
    scala-steward opened #280
  • Apr 22 01:06

    cquiroz on v2.2.2

    (compare)

  • Apr 22 01:05

    cquiroz on master

    Update scala 3 Signed-off-by: … Merge pull request #279 from cq… (compare)

  • Apr 22 01:05

    cquiroz on scala-update

    (compare)

  • Apr 22 01:05
    cquiroz closed #279
  • Apr 22 00:37
    cquiroz opened #279
  • Apr 21 23:29

    cquiroz on scala-update

    Update scala 3 Signed-off-by: … (compare)

Carlos Quiroz
@cquiroz
It would be interesting to see a minmial reproduction with or without circe
Matthew de Detrich
@mdedetrich
Yeah I will work on a reproduction
Also its many methods, not just that one
Matthew de Detrich
@mdedetrich
So I figured out the issue,probably due to some dependency resolution
Assuming you have a shared frontend/backend project (where you have js/shared/jvm), putting scala-java-time in both shared and js caused the issue
Putting it in only shared fixed the problem
Carlos Quiroz
@cquiroz
Hmm, ok it maybe there twice and it confuses the linked
Linker
Matthew de Detrich
@mdedetrich
Aren't you only meant to resolve a single jar only once or am I missing something here?
In any case I am happy it was resolved
Carlos Quiroz
@cquiroz
I think resoultion works fine at compilation time
But it is undefined on the linker, at any rate it is more of a question for scala.js
Matthew de Detrich
@mdedetrich
Okay I will make an issue for it
Lorenzo Gabriele
@lolgab
Hi @cquiroz,
I wanted to port scala-java-time to Scala Native :)
I started with scala-java-locales but I can't find where is "cldr-api" dependency's repository.
Is it on github?
Lorenzo Gabriele
@lolgab
Thank you @plokhotnyuk :pray:
Carlos Quiroz
@cquiroz
Yes the api comes along with the sbt plugin
The api is really small should be easy to include native support there
Lorenzo Gabriele
@lolgab
I'm already doing it :)
I will send you a PR soon :)
Lorenzo Gabriele
@lolgab
@cquiroz PR ready for review here: cquiroz/sbt-locales#93
cquiroz
@cquiroz:matrix.org
[m]
@loglab I have troubles with the publication with native
Do you know about this:
Lorenzo Gabriele
@lolgab
Scala Native is published only for 2.12.13. Strange that this is triggered only publishing...
I'm giving a look
David Hoyt
@davidhoyt
@lolgab @cquiroz came here to see if cldr-api could get published for scala native and looks like you've beat me to the punch :)
this would be published against scala 2.13 as well, right?
David Hoyt
@davidhoyt
Looks like it was resolved in master AFAICT. publishLocal works.
(I removed skip in publish for native and it worked)
Carlos Quiroz
@cquiroz
We had some troubles publishing for native if I recall
David Hoyt
@davidhoyt
from what I read that was due to using the wrong version of 2.12. might work now that that's been fixed.
@lolgab @cquiroz ultimately I'm trying to get zio built w/ scheduler support
Carlos Quiroz
@cquiroz
Do you think it was fixed without requiring a change in cldr?
Anyway feel free to send a PR with a fix and I will make a release ASAP
David Hoyt
@davidhoyt
Hard to tell if it will only manifest when you go to actually publish
I didn't fix anything
I did remove the skip in Publish for native
I verified it worked for me with publishLocal but that's as far as I can go to validate it