Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 01 23:01
    alexarchambault synchronize #1562
  • Dec 01 17:01
    dependabot[bot] labeled #1616
  • Dec 01 17:01
    dependabot[bot] labeled #1616
  • Dec 01 17:01
    dependabot[bot] opened #1616
  • Dec 01 17:01

    dependabot[bot] on github_actions

    Bump actions/checkout from 2.3.… (compare)

  • Dec 01 17:01
    dependabot[bot] labeled #1615
  • Dec 01 17:01
    dependabot[bot] labeled #1615
  • Dec 01 17:01
    dependabot[bot] opened #1615
  • Dec 01 17:01

    dependabot[bot] on github_actions

    Bump actions/setup-node from 2.… (compare)

  • Nov 30 02:49
    danilbykov closed #1480
  • Nov 29 13:49
    alexarchambault commented #1562
  • Nov 29 13:48
    alexarchambault synchronize #1562
  • Nov 29 13:23
    kpodsiad synchronize #1607
  • Nov 29 12:54
    alexarchambault synchronize #1562
  • Nov 29 11:14
    alexarchambault synchronize #1562
  • Nov 29 10:18
    alexarchambault synchronize #1562
  • Nov 29 09:44
    alexarchambault synchronize #1562
  • Nov 26 15:59
    alexarchambault synchronize #1562
  • Nov 26 15:14
    alexarchambault synchronize #1562
  • Nov 26 10:26
    alexarchambault synchronize #1562
ckipp
@ckipp:matrix.org
[m]
I'd installed JDK 8 or 11, and then use the command in VS Code, "Metals Restart Build Server", which should restart Bloop and should then start with the JDK
Alexander770
@Alexander770
During the process I allowed VScode to install .jabba\jdk\adopt@1.11.0-11. It is not enough?
Chris Kipp
@ckipp:matrix.org
[m]
🤔 if Metals installed it, it should have been enough. You can also try to set your JAVA_HOME via the Metals Java Home setting
and then do the restart
Alexander770
@Alexander770
I restarted and it works. thank you very much.
I was using intellij for scala now I try VScode. It looks a bit weird to me.
Alexander770
@Alexander770
image.png
In VScode why pushing the button above doesn't run the code?
Alexander770
@Alexander770
image.png
The challenge. In the VScode I have a dev container based on datamechnics spark&scala image.
How I specify in Dockerfile my working directory so that Bloop will see is. Here is the error I receive:
Alexander770
@Alexander770
image.png
I am trying to build scala spark project on devcontainer based on datamechanics spark&scala image.
It reports an error:
need help
Tomasz Godzik
@tgodzik
@Alexander770 there are some issues if a wroskapce is copied to a docker container since files in .bloop have local paths
I would delete it manually or reimport the build in that case
Tomasz Godzik
@tgodzik
Hi all, we created a separate channel on the Scala discord server, please go there to ask questions or discuss issues, thanks!
Siddhant Sanyam
@siddhant3s
How does Bloop discover the main class? Can I query Bloop to give me all the Main classes (class which are child of App)
Ólafur Páll Geirsson
@olafurpg
@siddhant3s here's a command to query for a main class
❯ bloop autocomplete --mode=mainsfqcn --project=cli --format=bash
com.sourcegraph.lsif_java.LsifJava
replace cli with the name of your project
Siddhant Sanyam
@siddhant3s
Woah!
Thank @olafurpg
BTW, I know you hear this a lot, but Sourcegraph is sick!
Ólafur Páll Geirsson
@olafurpg
@siddhant3s haha :smile:
xraybat
@xraybat

latest version of bloop is 1.4.9, any reason (on the bloop-side) that coursier still installs bloop v1.4.8-114-e47368ed? vscode metals extension 1.10.11 requires bloop 1.4.9 too.

from the coursier channel, it should be pulling latest artefacts.

(i can let metals start its own bloop server, just curious re. the discrepancy)
xraybat
@xraybat

ok, appears to be my mistake -- after bloop exit and restarting bloop it attached to a 1.4.9 server -- so bloop about now reports 1.4.9.

i assume it just kept restarting an older server previously.

Hunor Kovács
@kovacshuni
when trying to run bloop server or reference bloop in any way, I get
/Users/hkovacs/Library/Application Support/Coursier/bin/bloop: line 2: /Users/hkovacs/Library/Application: No such file or directory
Somehow referring to an executable from PATH just go broken
Chris Kipp
@ckipp:matrix.org
[m]
if you do a cs uninstall bloop and cs install bloop, does it fix itself?
Hunor Kovács
@kovacshuni
no, i did re-install bloop
sorry, i re-installed Coursier
but it still puts it to Application Support
which contains a space in the name
Chris Kipp
@ckipp:matrix.org
[m]
that's fine
Hunor Kovács
@kovacshuni
it's not a coursier or bloop issue, it's a mac or zsh issue
Chris Kipp
@ckipp:matrix.org
[m]
that's where cs install puts applications on mac
Hunor Kovács
@kovacshuni
and i add it to the path variable
but when it is trying to look for the bloop executable, it can't find it because of the space
see, first it know where it is: /Users/hkovacs/Library/Application Support/Coursier/bin/bloop
but then line 2: /Users/hkovacs/Library/Application:
Chris Kipp
@ckipp:matrix.org
[m]
how did you add it to your path? Did you escape the space?
Hunor Kovács
@kovacshuni
yes, I added the quotes
hmm what is line 2?
i think it is inside bloop
the script
Chris Kipp
@ckipp:matrix.org
[m]
I'm not 100% sure the space is enough is it?
like try to escape it
it depends on your shell, but I have a feeling even in quotes it things it's a seperate command
because it's probably thinking that's another path to add
so try with a Application\ Support/Coursier
Hunor Kovács
@kovacshuni
Tried it like that as well, but that way it doesn't work, I've seen blog posts about this behaviour, how not to escape twice