These are chat archives for scalajp/functional

20th
May 2015
pocketberserker
@pocketberserker
May 20 2015 00:10 UTC
うーんfunctional javaがうまくビルドできない…
kenji yoshida
@xuwei-k
May 20 2015 01:11 UTC
READMEに書いてあったり、自分が頑張って設定した.travis.yml見てもらえば分かるけど、Java7と8両方必要という、とても面倒な状態になってますね…
eugene yokota
@eed3si9n
May 20 2015 01:48 UTC
こっちに来た
kenji yoshida
@xuwei-k
May 20 2015 01:49 UTC
少なくともjson4sが 「3.2.10と3.2.11でバイナリ互換くずれるんだけど!」というissueが何度か来て、「3.3.xではバイナリ互換保証しよう?」という話くらいは出てたな
eugene yokota
@eed3si9n
May 20 2015 01:50 UTC
Java ライブラリって基本的にはずっと壊れない印象があるから、それに比べると僕達は壊しすぎなのではと思う
ここ数年で段々落ち着いてきてるっていうのがあるのかもしれないけど
テストとか JSON とかバイナリ互換性だけがずっとあることだけに意義がある minimal ライブラリとか言うと、じゃあ Java のを使えばってなる
kenji yoshida
@xuwei-k
May 20 2015 01:54 UTC
あと、これ json4s/json4s#236 は結局、eed3si9nさんからもしコメントあるなら何か書いてもらって、いずれにせよ今の時点ではどうしようもないから3.3系のjson4sは使うな(もしくは古いsbt使え?)で、issue閉じるしかないですよね /cc @seratch
eugene yokota
@eed3si9n
May 20 2015 01:56 UTC
そうですね<3.3系もしくは古いsbt
eugene yokota
@eed3si9n
May 20 2015 02:02 UTC
あと、猫番でも書いたけど sbt build.sbt は applicative な DSL なので、一応 functional
0x6875790d0a
@huydx
May 20 2015 07:09 UTC
This message was deleted
This message was deleted
Yuta Okamoto
@okapies
May 20 2015 11:33 UTC
おお…w
kenji yoshida
@xuwei-k
May 20 2015 13:37 UTC
Property.prop そのまま使ったらobjectの初期化時にテストすることになっちゃうじゃないですか!的な問題を修正した https://github.com/xuwei-k/scalaprops/compare/xuwei-k:5365b02...xuwei-k:8d2c551
前回のリリース(0.1.3)から、ある程度差分溜まったし、そろそろ次のversionだすか・・・ https://github.com/xuwei-k/scalaprops/compare/xuwei-k:131add1...xuwei-k:eb7879a