These are chat archives for scalikejdbc/ja

12th
Aug 2015
nazoking
@nazoking
Aug 12 2015 13:00

すいません、多分 sbt の基本部分のことだと思うのですが、こちらで失礼します。 scripted テストで依存関係エラーになるのですが、どうやったら成功しますか?

> scripted scalikejdbc-mapper-generator/gen
[info] Wrote C:\Users\nazoking\git\scalikejdbc\scalikejdbc-mapper-generator\target\scala-2.10\sbt-0.13\scalikejdbc-mapper-generator-2.2.8-SNAPSHOT.pom
:
[info] [info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] [warn]   ::::::::::::::::::::::::::::::::::::::::::::::
[info] [warn]   ::          UNRESOLVED DEPENDENCIES         ::
[info] [warn]   ::::::::::::::::::::::::::::::::::::::::::::::
[info] [warn]   :: org.scalikejdbc#scalikejdbc-core_2.10;2.2.8-SNAPSHOT: not found
[info] [warn]   :: org.scalikejdbc#scalikejdbc-mapper-generator-core_2.10;2.2.8-SNAPSHOT: not found
[info] [warn]   ::::::::::::::::::::::::::::::::::::::::::::::
[info] [warn]
[info] [warn]   Note: Unresolved dependencies path:
[info] [warn]           org.scalikejdbc:scalikejdbc-core_2.10:2.2.8-SNAPSHOT
[info] [warn]             +- org.scalikejdbc:scalikejdbc-mapper-generator:2.2.8-SNAPSHOT (scalaVersion=2.10, sbtVersion=0.13) (C:\Users\nazoking\AppData\Local\Temp\sbt_50440922\gen\project\plugins.sbt#L8-15)
[info] [warn]             +- default:gen-build:0.1-SNAPSHOT (scalaVersion=2.10, sbtVersion=0.13)
[info] [warn]           org.scalikejdbc:scalikejdbc-mapper-generator-core_2.10:2.2.8-SNAPSHOT (C:\Users\nazoking\AppData\Local\Temp\sbt_50440922\gen\project\plugins.sbt#L8-15)
[info] [warn]             +- org.scalikejdbc:scalikejdbc-mapper-generator:2.2.8-SNAPSHOT (scalaVersion=2.10, sbtVersion=0.13) (C:\Users\nazoking\AppData\Local\Temp\sbt_50440922\gen\project\plugins.sbt#L8-15)
[info] [warn]             +- default:gen-build:0.1-SNAPSHOT (scalaVersion=2.10, sbtVersion=0.13)
[info] sbt.ResolveException: unresolved dependency: org.scalikejdbc#scalikejdbc-core_2.10;2.2.8-SNAPSHOT: not found
[info] unresolved dependency: org.scalikejdbc#scalikejdbc-mapper-generator-core_2.10;2.2.8-SNAPSHOT: not found
[info]  at sbt.IvyActions$.sbt$IvyActions$$resolve(IvyActions.scala:291)
[info]  at sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:188)
[info]  at sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:165)
:
[info] [error] (*:update) sbt.ResolveException: unresolved dependency: org.scalikejdbc#scalikejdbc-core_2.10;2.2.8-SNAPSHOT: not found
[info] [error] unresolved dependency: org.scalikejdbc#scalikejdbc-mapper-generator-core_2.10;2.2.8-SNAPSHOT: not found

となります。

kenji yoshida
@xuwei-k
Aug 12 2015 15:03
依存プロジェクトを全部publishLocalしないとダメです