These are chat archives for scytherswings/Plex-Board

16th
Apr 2017
Andrew Newell
@scytherswings
Apr 16 2017 00:25
1.0... Hmmm. It depends on what features we determine will be must-haves. I'm most concerned about ease of maintenance and installation.
Sean Vreeland
@seanvree
Apr 16 2017 00:38
right
so...
I think I might test this docker thing out
so, if you want to luanch soonish
then we could put the windows tihngs on ICE?
until we get the servcie deal worked out
did a bit of research, and I just don't see it working unelss we have two diff branches that have two versions of the code
SH vs BASHi
so, up to you
thoughts?
I mean, it works on windows, just NOT as a service
which means that MOST peole wouldn't run it htat way
no one is gonnna leave a prompt open
Andrew Newell
@scytherswings
Apr 16 2017 00:54
Well I had thought we were close with services before
But there's too many steps
Sean Vreeland
@seanvree
Apr 16 2017 00:55
well...
Let me take a look again at it
did you mess with that portion at all in the lastest dev branch?
Andrew Newell
@scytherswings
Apr 16 2017 01:02
I tweaked a few things
But it won't behave any different right now
Sean Vreeland
@seanvree
Apr 16 2017 01:02
K, i'll pull it down and take one more look at it
Andrew Newell
@scytherswings
Apr 16 2017 01:03
Dev is the same as master btw
Since I pushed last night
Sean Vreeland
@seanvree
Apr 16 2017 01:10
yeah, but so I don' thave to swtich back and forth, I'll stay on dev
for now
question
Andrew Newell
@scytherswings
Apr 16 2017 01:12
Yeah just letting you know
Sean Vreeland
@seanvree
Apr 16 2017 01:22
kk
couple things
W, [2017-04-15T18:21:58.135419 #4144]  WARN -- : An error occurred trying to fetch an image for plex_object: 339. Will retry 0 more time(s). Error: 404 Not Found
E, [2017-04-15T18:21:58.176639 #4144] ERROR -- : There was a problem fetching or writing the image file: public/images/339.jpeg. Returning placeholder.png. Error: 404 Not Found
I, [2017-04-15T18:22:02.083722 #4144]  INFO -- : method=GET path=/ format=html controller=ServicesController action=index status=500 error='ActionView::Template::Error: Current ExecJS runtime does't support ES5. Please install node.js.' duration=11591.91 view=0.00 db=6.84 params={}
F, [2017-04-15T18:22:02.085685 #4144] FATAL -- : 
ActionView::Template::Error (Current ExecJS runtime does't support ES5. Please install node.js.):
     8: 
     9:   <!-- Bootstrap Core CSS -->
    10: 
    11:   <%= stylesheet_link_tag 'application', media: 'all', 'data-turbolinks-track' => true %>
    12:   <%= javascript_include_tag 'application', 'data-turbolinks-track' => true %>
    13:   <%= csrf_meta_tags %>
    14:   <!-- Custom CSS -->
  app/views/layouts/_header.html.erb:11:in `_app_views_layouts__header_html_erb__342552512_43661592'
  app/views/layouts/application.html.erb:4:in `_app_views_layouts_application_html_erb__765134822_57452376'
what's that mean?
so the server is running
but in the browser i'm getting "We're sorry, but something went wrong."
Andrew Newell
@scytherswings
Apr 16 2017 01:24
Let me get my laptop, can't read on my phone
Sean Vreeland
@seanvree
Apr 16 2017 01:25
coo
Andrew Newell
@scytherswings
Apr 16 2017 01:31
Is that running on windows?
Do you have node.js installed?
brb gotta drive
Sean Vreeland
@seanvree
Apr 16 2017 01:31
yeah
I pulled the latest dev
then ran start server
and it's running
I can get to in in the browser
but I just get the sorry something wrong deal
Andrew Newell
@scytherswings
Apr 16 2017 01:32
Is modems installed
Nodejs *
Sean Vreeland
@seanvree
Apr 16 2017 01:33
how can I check?

Administrator@VreePlexDesktop MINGW64 /c/Sites/Plex-Board (dev)
$ nodejs
bash: nodejs: command not found

Administrator@VreePlexDesktop MINGW64 /c/Sites/Plex-Board (dev)
$
Sean Vreeland
@seanvree
Apr 16 2017 01:42
@scytherswings
Andrew Newell
@scytherswings
Apr 16 2017 01:51
Try node -v
I was driving
@seanvree ^^
Sean Vreeland
@seanvree
Apr 16 2017 01:59
nope
so how doe the program run without node installed?
Andrew Newell
@scytherswings
Apr 16 2017 02:02
node is needed for the javascript stuff
Sean Vreeland
@seanvree
Apr 16 2017 02:02
and also, what's weird, is theat when I run the installer from the wiki, it says a later ver is alreadyin installed?
right
?
Andrew Newell
@scytherswings
Apr 16 2017 02:02
whaaaaa
Sean Vreeland
@seanvree
Apr 16 2017 02:02
okay, I'mma gonna unisntall it from win and reinstall
yeah
werid
Andrew Newell
@scytherswings
Apr 16 2017 02:02
yeah
path issues i’m guessing?
Sean Vreeland
@seanvree
Apr 16 2017 02:02
probs
Andrew Newell
@scytherswings
Apr 16 2017 02:03
I’m going to push a change to prod real quick
*master
lol
and it will give you verbose error messages in the browser
Sean Vreeland
@seanvree
Apr 16 2017 02:03
coo, I'm still on dev
Andrew Newell
@scytherswings
Apr 16 2017 02:03
i’ll push there
better idea
Sean Vreeland
@seanvree
Apr 16 2017 02:03
yeah dude, always to dev FIRST then master, right?
lol
Andrew Newell
@scytherswings
Apr 16 2017 02:04
lol yeah
ok change is in
pull it down
and restart the server
Sean Vreeland
@seanvree
Apr 16 2017 02:04
wurd, let me get node installed frirst
Andrew Newell
@scytherswings
Apr 16 2017 02:04
nono
try it first
before you install node
Sean Vreeland
@seanvree
Apr 16 2017 02:04
huh?
Andrew Newell
@scytherswings
Apr 16 2017 02:04
to see if you see better debug info inthe browser
Sean Vreeland
@seanvree
Apr 16 2017 02:04
too late
Andrew Newell
@scytherswings
Apr 16 2017 02:04
ok
that’s fine
Sean Vreeland
@seanvree
Apr 16 2017 02:04
already uinstalinsteed
Andrew Newell
@scytherswings
Apr 16 2017 02:04
nah you’re good
What I mean is, Pull my latest change and restart your server
it’ll still be missing node
but now you’ll see the error in the browser too
instead of the stupid “somthing went wrong” page
Sean Vreeland
@seanvree
Apr 16 2017 02:05
so after I ge node installed
just update.sh, right?
Andrew Newell
@scytherswings
Apr 16 2017 02:06
sure
Sean Vreeland
@seanvree
Apr 16 2017 02:09
okay, we got probs dude
when you gonna be home?
Andrew Newell
@scytherswings
Apr 16 2017 02:09
I’m home right now
Sean Vreeland
@seanvree
Apr 16 2017 02:09
you have time for a team viewer?
Andrew Newell
@scytherswings
Apr 16 2017 02:09
sure give me a sec to get booted up
k ready
Sean Vreeland
@seanvree
Apr 16 2017 02:11
KK
so
Andrew Newell
@scytherswings
Apr 16 2017 03:02
lol
wrong chat