Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 11 2017 06:40
    @marc0der banned @d_jankins_twitter
  • Mar 11 2017 13:07
    @marc0der banned @TrustOrDust_com_twitter
nightswimmings
@nightswimmings
Found on SO: https://stackoverflow.com/questions/55809928/sdkman-is-missing-a-specific-java-version. Sdkman is a great software. I think including this piece of info in https://sdkman.io/usage#installspecific, or either incldue as a feature the possibility of browsing older distros would really empower it
Tanoy Majumdar
@tanoymajumdar
Hi, I am trying to install sdkman on git bash for Windows. I run curl -s "https//get.sdkman.io" | bash but there is no prompt
TAKAHASHI Shuuji
@shuuji3
Hello!🙂 I'm not familiar with Java. I'm trying to run Java Web Start (javaws command) using SDKMAN! to use a Supermicro's legacy IPMI application. It seems that Oracle Java 8 was able to run javaws but it is removed due to Oracle's licensing problem. Currently, I assume that there is no way to install javaws using SDKMAN! and we have to install Oracle's Java manually out of SDKMAN!. It this right assumption? Thank you.
This is not related to the question but I like SDKMAN very much! Thank you for creating a very useful tool. I'm using it to build and run Spark and related applications.
mlk5060
@mlk5060
Hi there, I'm getting the following when trying to run sdk list java on Ubuntu 18.04.5 LTS and SDKMAN version 5.5.9+231. Running sdk list returns results, however
<html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.19.1</center>
</body>
</html>
No updates to SDKMAN appear to be available either (this is a fix listed here: sdkman/sdkman-cli#772):
$ sdk selfupdate
No update available at this time.

$ sdk selfupdate force
bash: line 1: html: No such file or directory
bash: line 2: syntax error near unexpected token `<'
'ash: line 2: `<head><title>404 Not Found</title></head>
Paolo Contessi
@conteit
Hi everyone.. On macOS Catalina I keep loosing the .sdkman/bin folder content.. I cannot find a possible reason, any idea?
Mick
@mickoallen
hey im unable to install on a fresh ubuntu 20
Installing SDKMAN scripts...
Create distribution directories...
Getting available candidates...
Prime the config file...
Download script archive...
######################################################################## 100.0%
[/home/mick/.sdkman/tmp/sdkman-pinning_versions+565.zip]
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of /home/mick/.sdkman/tmp/sdkman-pinning_versions+565.zip or
        /home/mick/.sdkman/tmp/sdkman-pinning_versions+565.zip.zip, and cannot find /home/mick/.sdkman/tmp/sdkman-pinning_versions+565.zip.ZIP, period.
Downloaded zip archive corrupt. Are you connected to the internet?

If problems persist, please ask for help on our Slack:
* easy sign up: https://slack.sdkman.io/
* report on channel: https://sdkman.slack.com/app_redirect?channel=user-issues
FAP
@fapdash
Mh, somehow all the java11 versions that I tried so far to install via sdkman didn't contain the source files src.zip.
Is there a way to fetch / install sources through sdkman?
Saïd BOURAS
@saidbouras

Hi everyone !
I have a problem, I am currently running SDKMAN on wsl on windows 10, and unfortunately when I tried to install a JDK/SDK, the download fails and blocks at 49.9%. If I interrupted (by a SIGTERM signal via terminal) and retry it, it's says "curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume."
I am signaling that I run on a corporate proxy that I configured correctly, SDKMAN is aware of env variables : http_proxy and http_proxy.

Can someone have an idea why donwloads get blocked in the middle ?
Thanks

sridhar-sid
@sridhar-sid
Hey, i'm trying to use sdkman in alpine linux docker as you can see below.., but when i run java -version from the bash.. i have the following error
docker run -it sdk_base:v3 bash
bash-5.0# java -version
bash: /root/.sdkman/candidates/java/current/bin/java: No such file or directory
FROM alpine

# Defining default Java and Maven version
ARG JAVA_VERSION="8.0.265-open"
ARG MAVEN_VERSION="3.6.3"

# Installing basic packages
RUN apk add bash curl git zip unzip && \
        rm -rf /var/lib/apt/lists/* && \
        rm -rf /tmp/*

# Downloading SDKMAN!
RUN curl -s "https://get.sdkman.io" | bash

# Installing Java and Maven, removing some unnecessary SDKMAN files
RUN bash -c "source $HOME/.sdkman/bin/sdkman-init.sh && \
    yes | sdk install java $JAVA_VERSION && \
    yes | sdk install maven $MAVEN_VERSION"
Any idea how to fix the above error? i couldn't find anything on google.
Jonathan Blaisure
@j0hnnyblaz3
Hello, I am running sdk list java and getting a bad request error.
1 reply
<!DOCTYPE html>
<html lang="en">
    <head>
        <title>Bad Request</title>
        <link rel="shortcut icon" href="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAAlFJREFUeNqUU8tOFEEUPVVdNV3dPe8xYRBnjGhmBgKjKzCIiQvBoIaNbly5Z+PSv3Aj7DSiP2B0rwkLGVdGgxITSCRIJGSMEQWZR3eVt5sEFBgTb/dN1yvnnHtPNTPG4PqdHgCMXnPRSZrpSuH8vUJu4DE4rYHDGAZDX62BZttHqTiIayM3gGiXQsgYLEvATaqxU+dy1U13YXapXptpNHY8iwn8KyIAzm1KBdtRZWErpI5lEWTXp5Z/vHpZ3/wyKKwYGGOdAYwR0EZwoezTYApBEIObyELl/aE1/83cp40Pt5mxqCKrE4Ck+mVWKKcI5tA8BLEhRBKJLjez6a7MLq7XZtp+yyOawwCBtkiBVZDKzRk4NN7NQBMYPHiZDFhXY+p9ff7F961vVcnl4R5I2ykJ5XFN7Ab7Gc61VoipNBKF+PDyztu5lfrSLT/wIwCxq0CAGtXHZTzqR2jtwQiXONma6hHpj9sLT7YaPxfTXuZdBGA02Wi7FS48YiTfj+i2NhqtdhP5RC8mh2/Op7y0v6eAcWVLFT8D7kWX5S9mepp+C450MV6aWL1cGnvkxbwHtLW2B9AOkLeUd9KEDuh9fl/7CEj7YH5g+3r/lWfF9In7tPz6T4IIwBJOr1SJyIGQMZQbsh5P9uBq5VJtqHh2mo49pdw5WFoEwKWqWHacaWOjQXWGcifKo6vj5RGS6zykI587XeUIQDqJSmAp+lE4qt19W5P9o8+Lma5DcjsC8JiT607lMVkdqQ0Vyh3lHhmh52tfNy78ajXv0rgYzv8nfwswANuk+7sD/Q0aAAAAAElFTkSuQmCC">
        <style>
            html, body, pre {
                margin: 0;
                padding: 0;
                font-family: Monaco, 'Lucida Console', monospace;
                background: #ECECEC;
            }
            h1 {
                margin: 0;
                background: #AD632A;
                padding: 20px 45px;
                color: #fff;
                text-shadow: 1px 1px 1px rgba(0,0,0,.3);
                border-bottom: 1px solid #9F5805;
                font-size: 28px;
            }
            p#detail {
                margin: 0;
                padding: 15px 45px;
                background: #F6A960;
                border-top: 4px solid #D29052;
                color: #733512;
                text-shadow: 1px 1px 1px rgba(255,255,255,.3);
                font-size: 14px;
                border-bottom: 1px solid #BA7F5B;
            }
        </style>
    </head>
    <body>
        <h1>Bad Request</h1>

        <p id="detail">
            For request 'GET /bad-request' [invalid version format: FUSION.APP/CONTENTS/PUBLIC:/USR/LOCAL/SHARE/DOTNET:~/.DOTNET/TOOLS:/LIBRARY/APPLE/USR/BIN:/LIBRARY/FRAMEWORKS/MONO.FRAMEWORK/VERSIONS/CURRENT/COMMANDS:/USERS/JBLAISURE/.SDKMAN/CANDIDATES/JAVA/CURRENT//BIN:/USR/LOCAL/SCALA/BIN&amp;INSTALLED=10.0.2-ZULU,11.0.8.HS-ADPT HTTP/1.0]
        </p>

    </body>
</html>
Any ideas?
Thanks!
Matt Benson
@mbenson

I'm using sdkman in Docker and using the docker container as a base, because ultimately I want to invoke docker build from Ant. When I use debian:buster-slim as a base, things work... except docker isn't installed. When I switch to the docker base image provided for this purpose, java will not execute successfully as installed by sdkman. I get errors like:

bash: /opt/sdkman/candidates/java/8.0.265-open/bin/java: No such file or directory

Does anyone have any idea what is missing? The docker image is based on Alpine Linux, if that helps

Philippe Soares
@psoares
I have the same problem with alpine
it works when using frolvlad/alpine-glibc though... so I suspect it needs libc instead of musl
Xiaoxiao
@zhaomizhi
Hello, get issue with almost install/default/use command. Try to use sdk list java to get all java version, and i pick any version and try to install i got below error:
Stop! java 11.0.9-amzn is not available. Possible causes: 11.0.9-amzn is an invalid version java binaries are incompatible with Darwin java has not been released yet
Does any one why it happened? it was working fine few days ago and no matter which version i pick from the sdk list it wont work.
Xiaoxiao
@zhaomizhi
my sdk version is SDKMAN 5.9.1+575 and os is mac 10.12.6
ClementWee
@ClementWee

Hi, I can sdk list scala and sdk list groovy, but when I try to sdk list java, I get

<!DOCTYPE html>
<html lang="en">
    <head>
        <title>Error</title>
        <link rel="shortcut icon" href="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAAlFJREFUeNqUU8tOFEEUPVVdNV3dPe8xYRBnjGhmBgKjKzCIiQvBoIaNbly5Z+PSv3Aj7DSiP2B0rwkLGVdGgxITSCRIJGSMEQWZR3eVt5sEFBgTb/dN1yvnnHtPNTPG4PqdHgCMXnPRSZrpSuH8vUJu4DE4rYHDGAZDX62BZttHqTiIayM3gGiXQsgYLEvATaqxU+dy1U13YXapXptpNHY8iwn8KyIAzm1KBdtRZWErpI5lEWTXp5Z/vHpZ3/wyKKwYGGOdAYwR0EZwoezTYApBEIObyELl/aE1/83cp40Pt5mxqCKrE4Ck+mVWKKcI5tA8BLEhRBKJLjez6a7MLq7XZtp+yyOawwCBtkiBVZDKzRk4NN7NQBMYPHiZDFhXY+p9ff7F961vVcnl4R5I2ykJ5XFN7Ab7Gc61VoipNBKF+PDyztu5lfrSLT/wIwCxq0CAGtXHZTzqR2jtwQiXONma6hHpj9sLT7YaPxfTXuZdBGA02Wi7FS48YiTfj+i2NhqtdhP5RC8mh2/Op7y0v6eAcWVLFT8D7kWX5S9mepp+C450MV6aWL1cGnvkxbwHtLW2B9AOkLeUd9KEDuh9fl/7CEj7YH5g+3r/lWfF9In7tPz6T4IIwBJOr1SJyIGQMZQbsh5P9uBq5VJtqHh2mo49pdw5WFoEwKWqWHacaWOjQXWGcifKo6vj5RGS6zykI587XeUIQDqJSmAp+lE4qt19W5P9o8+Lma5DcjsC8JiT607lMVkdqQ0Vyh3lHhmh52tfNy78ajXv0rgYzv8nfwswANuk+7sD/Q0aAAAAAElFTkSuQmCC">
        <style>
            html, body, pre {
                margin: 0;
                padding: 0;
                font-family: Monaco, 'Lucida Console', monospace;
                background: #ECECEC;
            }
            h1 {
                margin: 0;
                background: #A31012;
                padding: 20px 45px;
                color: #fff;
                text-shadow: 1px 1px 1px rgba(0,0,0,.3);
                border-bottom: 1px solid #690000;
                font-size: 28px;
            }
            p#detail {
                margin: 0;
                padding: 15px 45px;
                background: #F5A0A0;
                border-top: 4px solid #D36D6D;
                color: #730000;
                text-shadow: 1px 1px 1px rgba(255,255,255,.3);
                font-size: 14px;
                border-bottom: 1px solid #BA7A7A;
            }
        </style>
    </head>
    <body>
        <h1>Oops, an error occurred</h1>

        <p id="detail">
            This exception has been logged with id <strong>7hldejkbf</strong>.
        </p>

    </body>
</html>

I am using a fresh download of SDKMAN 5.9.1+575 on Ubuntu 20.04 LTS

Jason Zaugg
@retronym
@ClementWee I’ve had builds start failing with that error today as well. Here’s a build log of a Travis CI build: https://travis-ci.org/github/retronym/travis-jdk-switch-test/builds/742626988 running the a minimal build script from https://github.com/retronym/travis-jdk-switch-test/blob/b081c00b18313b37a9b1c500f93807f11c57445c/.travis.yml
Jason Zaugg
@retronym
@ClementWee Let’s discuss on this issue that we opened a few hours ago: sdkman/sdkman-cli#820
©︎ureれも:=ネ=>℃🐳
@curelemonade2_twitter
I want to need java7 jar. But couldn't choose 'sdk list java'. min: java8, max java15. How can I manage java7 with sdkman? SDKMAN:5.10.0+617
i knowjava7 has suppotred openjdk and azul
Ward Jans
@wjans
hi all, I just installed sdkman (5.11.0+644) on a Raspbian buster but when I list available java versions I get an empty list. Am I doing something wrong? Or is there something I need to check?
# sdk version

SDKMAN 5.11.0+644
# sdk list java
================================================================================
Available Java Versions
================================================================================
 Vendor        | Use | Version      | Dist    | Status     | Identifier
--------------------------------------------------------------------------------
================================================================================
Use the Identifier for installation:

    $ sdk install java 11.0.3.hs-adpt
================================================================================
Lucas Milotich
@LucasMilotich_twitter
Hello everyone, I'm having the following problems:
image.png
image.png
1 reply
everything i tried to install, failed
I've check if tar command works ok and i don't know what other thing to look for. any ideas?
Lucas Milotich
@LucasMilotich_twitter
i realised it was for the filesize in ulimit
so doing: ulimit -f unlimited fixed the problem
Anis Lazaar
@anis00723
I have the same problem as you
Bagrat Mukaelyan
@MBagrat
Hey Guys.
In my macos machine I was installijng amazon java 8,11 using sdkman
image.png
Now I want to install netbeans via brew (brew install —cask netbeans) and facing this problem
image.png
anyone know why brew didn’t see java in my machine?
image.png
ppk0198
@ppk0198
Hi all, I am trying to setup development environment using wsl, but when I run this command grep "wsUrl" /usr/share/meteor/bundle/programs/server/assets/app/config/settings.yml
I am getting this error grep: /usr/share/meteor/bundle/programs/server/assets/app/config/settings.yml: No such file or directory
can anybody help me how to fix this?
David Dale
@davidadale
Hello, new install of SDKman I am getting ========= INTERNET NOT REACHABLE ======= when trying to install grails 2.5.0