Hello all! I was trying to create a Plone site within an already running Zope Instance. I followed the steps given here: (http://web.archive.org/web/20080611061803/http://plone.org/documentation/how-to/multiple-plone-sites-per-zope-instance-using-separate-data-fs-files-for-each-one). I was able to add group1 mount point given in 2nd step but when I create a Plone site as given in 3rd step, I face this error:
Error Type: APIError
Error Value: No tool named 'auditlog_catalog' found.
Will appreciate your help!
I'm not at all familiar with Senaite itself or its usage. I do know that in reading the older pages at Bikalims that there was an Equestrian version at one time. Looking through the current projects I didn't see anything like that so I was curious what the options were today.
Please have a look at https://github.com/bikalims/bika.equine I am not sure if that what you are referring to.
I'm bursting a smile out of my ears
Smiling myself too!
Yeah it's been a minute.
Has been more than a minute.... hope the pandemic didn't got you! - although have to say your eyes look quite tired :)
@toropok this isn't a senaite issue, it's a Plone issue. Including third-party JS in Plone is not usually difficult, but I recall that they have very specific ways that you can do it, so that you don't mess with the JS of Plone itself
@rockfruit we found that original plone JS-sripts disabled in the Senaite file main_template.pt:
<!-- Disable all Plone JS/CSS -->
<!-- <div tal:replace="structure provider:plone.scripts" /> -->
<!-- <link tal:replace="structure provider:plone.htmlhead.links" /> -->
<!-- <metal:styleslot define-slot="style_slot" /> -->
Hello guys, I'm trying to install senaite.lims but it always gets this error, can you please help
Got senaite.core 2.0.0.
Version and requirements information containing plone:
[versions] constraint on plone: 4.3.19
Base installation request: 'Plone', 'Pillow', 'senaite.lims', 'simplejson', 'plone.recipe.zope2instance'
Requirement of plone.recipe.zope2instance==4.4.1: ZODB3>=3.9
Requirement of plone.recipe.zope2instance==4.4.1: Zope2>=2.12.1
Requirement of plone.recipe.zope2instance==4.4.1: zc.recipe.egg
Requirement of plone.recipe.zope2instance==4.4.1: mailinglogger
Requirement of plone.recipe.zope2instance==4.4.1: setuptools
Requirement of plone.recipe.zope2instance==4.4.1: zc.buildout
Requirement of senaite.lims: Plone==5.2.4
Requirement of Plone==4.3.19: wicked
Requirement of Plone==4.3.19: plone.app.theming
Requirement of Plone==4.3.19: plone.app.openid
Requirement of Plone==4.3.19: plone.app.iterate
Requirement of Plone==4.3.19: plone.app.dexterity
Requirement of Plone==4.3.19: plone.app.caching
Requirement of Plone==4.3.19: Products.CMFPlone
Requirement of Plone==4.3.19: Products.CMFPlacefulWorkflow
Requirement of Plone==4.3.19: setuptools
Requirement of senaite.core==2.0.0: plone.app.jquerytools
Requirement of senaite.core==2.0.0: plone.subrequest
Requirement of senaite.core==2.0.0: plone.resource
Requirement of senaite.core==2.0.0: plone.jsonapi.core
Requirement of senaite.core==2.0.0: plone.app.z3cform
Requirement of senaite.core==2.0.0: plone.app.relationfield
Requirement of senaite.core==2.0.0: plone.app.referenceablebehavior
Requirement of senaite.core==2.0.0: plone.app.iterate
Requirement of senaite.core==2.0.0: plone.app.dexterity
Requirement of senaite.core==2.0.0: plone.api
Error: The requirement ('Plone==5.2.4') is not allowed by your [versions] constraint (4.3.19)
Pillow = 5.1.0
cssselect2 = 0.2.2
soupsieve = 1.9.5
buildout.sanitycheck = 1.0.2
collective.recipe.backup = 4.0