Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    David Hérault
    @dherault
    Hi there!
    Richard Tan
    @chardos
    Bonjour!
    Kevin Menhinick
    @kevbot-git
    Hey there! Has anyone perhaps played with the WebSocket features?
    I've got a service running offline managing to send responses, but I'm hoping to be able to use a Route Selection Expression in serverless.yml to tell serverless where to send responses to.
    The documentation on AWS isn't very helpful on this topic!
    Cheers :)
    David Hérault
    @dherault
    I've created the plugin but only supervised the websocket part, so I cannot help. Try opening a GitHub issue. Best
    James Ingold
    @james-ingold
    Hey David, just wanted to say thanks for all your work on this plugin! Glad there's a gitter chat
    Richard Tan
    @chardos

    Hey Peeps,

    Just created a new project, and returned a string from my lambda which works fine in serverless-offline.

    When I deployed my lambda it threw a 500 because it expects an object to be returned with statusCode and body. Should we emulate this behaviour in serverless-offline?

    Could give a nice error message, to improve the developer experience
    Austin G
    @Stegosource_twitter
    Does anyone know if there is a way to remove or not include the "access-control-allow-origin" header? I have my serverless functions behind an NGINX proxy and the "access-control-allow-origin" is already handled there. As a result, there is a conflict, and the browser doesn't like it
    Richard Tan
    @chardos
    @Stegosource_twitter Not sure off the top of my head I will attempt to look at this early next week
    Quenby Mitchell
    @qswinson
    Greetings! Are there any instructions on how to add a test suite to the serverless-offline project? I want to develop a JWT authorizer for HttpApi events, but am having difficulty getting my new test fixture to run with the babel-fied code
    1 reply
    Richard Tan
    @chardos
    @Stegosource_twitter I've replied to your issue on github, but you should be able to just remove the cors option from your endpoints
    Xitij Ritesh Patel
    @HorizonXP
    Hi, I'm attempting to use Serverless-offline to mock an httpApi event, but it's not picking up the routes (says none), so I keep getting 404s. If I switch to normal http events, it works fine. Anything I should attempt to do to debug?
    David Hérault
    @dherault
    Mmm, I'm not sure httpApi events are supported, @chardos did you see that in the code?
    I'm checking it out right now
    There is support for httpApi, weird its not working
    Can you present a minimal repo in an issue @HorizonXP ?
    Xitij Ritesh Patel
    @HorizonXP
    Yes, let me attempt to put that together
    David Hérault
    @dherault
    Great!
    @dherault let me know if you have trouble accessing or running it
    Quenby Mitchell
    @qswinson
    @HorizonXP you need to modify your httpApi event definitions to use properties not a string:
          - httpApi:
              method: 'POST'
              path: /data
          - httpApi:
              method: 'GET'
              path: /data
    Xitij Ritesh Patel
    @HorizonXP
    @qswinson unfortunately, I did try that beforehand, and it yielded the same results. I'll push a commit now thouhg.
    Payam Mousavi
    @pamit
    Hi. Can someone please help me with dherault/serverless-offline#1031 Thanks!
    It's an issue with using Ruby module/class to define an endpoint (function).
    Theo
    @shierro
    Hi! anyone have successfully used the latest plugin to run typescript apps?
    Theo
    @shierro

    I was able to get something to work using the library(at least for HTTP event)
    https://gist.github.com/shierro/e5136e34ae8ac12f7e3e94c7c6b7b555

    But I am facing some issue w/ testing using the "http lambda" endpoint
    https://github.com/dherault/serverless-offline/issues/969#issuecomment-649456816

    Richard Tan
    @richardtapendium
    @HorizonXP You're using version 3.8.3. Could you please update to v6?
    If it's still not working, we can investigate further