Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jun 17 20:34
    gustavosbarreto opened #1046
  • Jun 17 20:34

    gustavosbarreto on rename_to_single_user

    agent: rename simple password a… (compare)

  • Jun 17 20:13
    eduardoveiga synchronize #822
  • Jun 17 20:13

    eduardoveiga on webhook

    pkg, api: specify package for v… ui: add case for url invalid fo… (compare)

  • Jun 17 20:09
    eduardoveiga synchronize #822
  • Jun 17 20:09

    eduardoveiga on webhook

    ui: add webhook to API settings api: fix webhook to use namespa… pkg, api: specify package for v… and 1 more (compare)

  • Jun 17 19:43

    noreng-jg on billing-rebase

    api: wip (compare)

  • Jun 17 19:27

    noreng-jg on billing-rebase

    gateway: add billing webhook co… (compare)

  • Jun 17 19:24
    leonardojoao unlabeled #1045
  • Jun 17 14:55
    leonardojoao labeled #1045
  • Jun 17 14:55
    leonardojoao unlabeled #1045
  • Jun 17 14:49
    leonardojoao labeled #1045
  • Jun 17 14:49
    leonardojoao opened #1045
  • Jun 17 14:49

    leonardojoao on addTagsIgnore

    github: add draft tag to skip ci (compare)

  • Jun 17 13:02
    nakrule commented #991
  • Jun 17 11:54

    noreng-jg on billing-rebase

    api: add store methods to billi… api: update mocks (compare)

  • Jun 16 23:49
    gustavosbarreto commented #991
  • Jun 16 23:48
    gustavosbarreto commented #991
  • Jun 16 23:47
    gustavosbarreto commented #991
  • Jun 16 23:44
    gustavosbarreto labeled #991
haydenbarton96
@haydenbarton96
Attaching to shellhub-v011_ui_1
ui_1 | standard_init_linux.go:211: exec user process caused "exec format error"
ui_1 | standard_init_linux.go:211: exec user process caused "exec format error"
ui_1 | standard_init_linux.go:211: exec user process caused "exec format error"
@gustavosbarreto im googling the error now too, but strange that no errors at all came up during the entire install of docker, docker compose and shellhub
Luis Gustavo S. Barreto
@gustavosbarreto
@haydenbarton96 are you running ShellHub server on a RaspberryPi?
ShellHub server is intended to run on x64 (standard PC or VPS like AWS, Azure, DO, etc..)
On your Pi you should install ShellHub Agent instead
Luis Gustavo S. Barreto
@gustavosbarreto
Think ShellHub as your centralized SSH server for all your Pi fleet
I admit that our documentation is not the best, but we appreciate your feedback and will try to improve the documentation whenever we can
Luis Gustavo S. Barreto
@gustavosbarreto
I just released the next major version of ShellHub (v0.2.0) with significant improvements. Check it out
haydenbarton96
@haydenbarton96
Yes im running on the raspberry pi 4 with 64 bit ubuntu, i will look into shellhub agent and shellhub v0.2.0, thank you :)
Rohit Joshi
@rjoshi
I am running ShellHub V0.0.5 what is the proper way to update server and Agent to new version?
With V0.0.5 I often face an issue where Device shows as online on the server but when I try to SSH session fails. Only way to recover from this is to restart agent container at the device. Is this a known issue?
Luis Gustavo S. Barreto
@gustavosbarreto
@rjoshi I'm sorry for the late reply
To update the server you need to checkout the latest released tag (v0.2.0)
Luis Gustavo S. Barreto
@gustavosbarreto
Then stop the server by running 'docker-compose stop' and start it again running 'docker-compose up - d'
To update the agent you need to it manually
Follow these steps:
Stop the container: docker stop shellhub
Remove the container: docker rm shellhub
Luis Gustavo S. Barreto
@gustavosbarreto
Open the new Web UI and add the device by clicking on 'Add device' button
Automatic updates is on our roadmap
Luis Gustavo S. Barreto
@gustavosbarreto
(first stable release maybe)
Rohit Joshi
@rjoshi
Thanks @gustavosbarreto , I will give it shot to check if that resolve unresponsive SSH issue. Good thing I have a backup SSH tunnel established to help me through this.
One question when I updating the server would it retain the Mango DB state? Specifically, I renamed about 50 devices would I need to redo that effort manually?
Radislav Myasnikov
@chamaloriz
hey, I'm trying to run shellhub but when I try to add a user it works but I can't login where should I start to try to fix this :)
Luis Gustavo S. Barreto
@gustavosbarreto

@chamaloriz In the ShellHub working dir please run the following command (and paste output here):

docker-compose exec mongo mongo --eval "db.users.find()" main

Radislav Myasnikov
@chamaloriz
{ "_id" : ObjectId("5e74c21a777c311f7e8bad99"), "username" : "chamaloriz", "password" : "455a8ce7faa8618715a6c6ee5df3ba32407fac0bf06c420850e29ab371b70689", "tenant_id" : "97AE3A69-B861-47E7-9618-CF4DCDFE7888" }
{ "_id" : ObjectId("5e74c2cddda5993488f36c42"), "username" : "chamalorizz", "password" : "455a8ce7faa8618715a6c6ee5df3ba32407fac0bf06c420850e29ab371b70689", "tenant_id" : "4B8120E7-7C1B-4816-8655-0969B3C4E98F" }
{ "_id" : ObjectId("5e74c595ce24ae5c30e9a910"), "username" : "a", "password" : "455a8ce7faa8618715a6c6ee5df3ba32407fac0bf06c420850e29ab371b70689", "tenant_id" : "C786671F-0F24-4B67-B420-6FD970A5513D" }
{ "_id" : ObjectId("5e74c5ab1b15bfe9e46a1db1"), "username" : "b", "password" : "24c47e36c56a3c8ada8c4d6a7d14de453551b6457e01c8c20998825eb5695633", "tenant_id" : "D76E41C7-8571-4511-86D0-F8E5E85EF641" }
{ "_id" : ObjectId("5e74c790cba14ac9576beb89"), "username" : "d", "password" : "260c9432b5793e91cb95ec92ce0c5f39dc84aeadcabe5bc3aa5b0f9bea36a3cf", "tenant_id" : "21D774D3-B9C8-4CE1-9BBD-4FB916A51C9B" }
{ "_id" : ObjectId("5e74c7bdc81ab932dae369c3"), "username" : "l", "password" : "bb938b96d8b7e2a3bc3d31a0205d87d8d4af0dd5d00b4a6b111eb4d8a19c4d7f", "tenant_id" : "3DBB01CE-17FA-4406-9FA2-C202617B5474" }
{ "_id" : ObjectId("5e74c8c2eac3d49d1534ecc3"), "username" : "k", "password" : "58bd14f931ed4a41c54f97910f4089500779b3213972eba34c37803de2394073", "tenant_id" : "35A2DA81-5BF2-4A61-A9E5-2B977D09AB58" }
{ "_id" : ObjectId("5e74cf658f9870e12f1cdfc3"), "username" : "admin", "password" : "455a8ce7faa8618715a6c6ee5df3ba32407fac0bf06c420850e29ab371b70689", "tenant_id" : "FFDD8FDA-F9F5-403E-99C4-EAB190C1254E" }
{ "_id" : ObjectId("5e74cf7ed5cf7ed028dcdcec"), "username" : "adminis", "password" : "455a8ce7faa8618715a6c6ee5df3ba32407fac0bf06c420850e29ab371b70689", "tenant_id" : "AF927BC1-B6DC-4CF3-9AD4-29DD72307289" }
{ "_id" : ObjectId("5e74cf8debda04afa2a9a76b"), "username" : "test", "password" : "455a8ce7faa8618715a6c6ee5df3ba32407fac0bf06c420850e29ab371b70689", "tenant_id" : "AC9F4316-9AB7-4984-94F1-25872B484581" }
I tested it a lot :p
Luis Gustavo S. Barreto
@gustavosbarreto
@rjoshi In the newer versions the database state is retained
Radislav Myasnikov
@chamaloriz
I checked in the docker shellhub the private and public key thinking that it could be because of that
Luis Gustavo S. Barreto
@gustavosbarreto
What is the password of test user?
Radislav Myasnikov
@chamaloriz
a I think wait let me generate a new user and send you the result
Luis Gustavo S. Barreto
@gustavosbarreto
ok
Radislav Myasnikov
@chamaloriz
Screenshot 2020-03-20 at 17.45.43.png
{ "_id" : ObjectId("5e74f330f68a65ba43323785"), "username" : "chamaloriz", "password" : "808239727725960f0905042c0198369fdc5a3de2aeb853d297d7fc0b9cce121e", "tenant_id" : "7E4D1B6A-01A8-4684-8CC0-D0297DABC0AC" }
I deleted the last project and ran it again
Screenshot 2020-03-20 at 17.47.08.png
I had to install "sha256sum" manualy to run it
and I installed docker with the dmg on my mac
Luis Gustavo S. Barreto
@gustavosbarreto
The problem is in the generated password
Radislav Myasnikov
@chamaloriz
how should I fix that ? :p
what should it look like ?
Luis Gustavo S. Barreto
@gustavosbarreto
The sha256sum of 'test' should be '9f86d081884c7d659a2feaa0c55ad015a3bf4f1b2b0b822cd15d6c15b0f00a08'
Radislav Myasnikov
@chamaloriz
it's done here right ?
PASSWORD=echo -n $2 | sha256sum | awk '{ print $1 }'
Luis Gustavo S. Barreto
@gustavosbarreto
yep
Radislav Myasnikov
@chamaloriz
I can maybe show you the result in my console
wait let me try
Luis Gustavo S. Barreto
@gustavosbarreto
What is the result of echo -n test | sha25sum ?
sorry
Radislav Myasnikov
@chamaloriz
Screenshot 2020-03-20 at 17.51.41.png
it works