by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Joshua Behrens
    @JoshuaBehrens
    sw_extends is right
    nikunjw3nuts
    @nikunjw3nuts
    @JoshuaBehrens my file path : custom/plugins/IcSafetyNation/src/Resources/views/storefront
    Timothy
    @timothydc
    Anyone knows why sorting by "price ascending" on a listing page, doesn't correctly sort the products? For example a product with a price of 149,95 EUR is shown between two 150 EUR products?
    nikunjw3nuts
    @nikunjw3nuts
    @KobusPost Means ?
    Kobus Post
    @KobusPost
    sw_extends has problems with theme inheritance. When I extend the base.html.twig of my own theme I have to use extends, when I use sw_extends it loads the storefront base.html.twig instead of my theme's base.
    file path looks right
    which file are you using to extend the base with?
    nikunjw3nuts
    @nikunjw3nuts

    @KobusPost

    base.html.twig

    @KobusPost

    {% block base_header %}
    <header class="header-main" id="header">
    {% block base_header_inner %}
    <!--<div class="container">-->
    {% sw_include '@Storefront/storefront/layout/header/header.html.twig' %}
    <!--</div>-->
    {% endblock %}
    </header>
    {% endblock %}

    i need customize this block

    i need to remove 'container' class
    after header-main
    Kobus Post
    @KobusPost

    {% sw_extends '@Storefront/storefront/base.html.twig' %}
    {% block base_header %}

    <header class="header-main" id="header">
    {% block base_header_inner %}
    <!--<div>-->
    {% sw_include '@Storefront/storefront/layout/header/header.html.twig' %}
    <!--</div>-->
    {% endblock %}
    </header>
    {% endblock %}

    should do the trick

    nikunjw3nuts
    @nikunjw3nuts
    ok i try it

    {% sw_extends '@Storefront/storefront/base.html.twig' %}
    {% block base_header %}

    <header class="header-main" id="header">
    {% block base_header_inner %}
    <!--<div>-->
    {% sw_include '@Storefront/storefront/layout/header/header.html.twig' %}
    <!--</div>-->
    {% endblock %}
    </header>
    {% endblock %}

    should do the trick

    This is not working for me

    Kobus Post
    @KobusPost
    Check if your theme is loading properly. profiler -> twig -> is your base.html.twig listed there?
    Joshua Behrens
    @JoshuaBehrens
    @nikunjw3nuts I think you need storefront twice in your path
    Kobus Post
    @KobusPost
    /custom/plugins/PluginName/src/Resources/views/storefront/base.html.twig
    nikunjw3nuts
    @nikunjw3nuts

    @nikunjw3nuts I think you need storefront twice in your path

    Where ?

    /custom/plugins/PluginName/src/Resources/views/storefront/base.html.twig

    Here is my path : /custom/plugins/IcSafetyNation/src/Resources/views/storefront

    ajimenez
    @poncho-jim
    Guys I get this error in the browser and I can't run ./psh.phar install or ./bin/setup
    An exception occurred in driver: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known
    I've checked my hosts and 127.0.0.1 -> localhost
    still the same
    please help
    Kobus Post
    @KobusPost
    is DATABASE_URL set?
    ajimenez
    @poncho-jim
    I'm trying to run development mode
    I thought it was supposed to be done for you in the command
    how can I set it?
    ./bin/setup?
    Kobus Post
    @KobusPost
    can be done with .env file
    ajimenez
    @poncho-jim
    so when it asks me for path to your /public dir?
    just set url to localhost 8000?
    is this .env in the root of the development folder?
    Kobus Post
    @KobusPost
    Using docker?
    ajimenez
    @poncho-jim
    yup
    I just used this: https://github.com/shopware/development/releases latest release 6.1.5
    ran the cmd's and ran into this
    I am running this in an Ubuntu 18 env. got docker-compose, docker, bash, php 7.2
    ajimenez
    @poncho-jim
    ./psh.phar docker:start
    ./psh.phar docker:ssh
    ./psh.phar install
    I know
    BUT, the third command won't run because of this error
    (4/40) Starting
    > mysql -u 'app' -p'app' -h 'mysql' --port='3306' -e "DROP DATABASE IF EXISTS \`shopware\`"
        ERROR 2005 (HY000): Unknown MySQL server host 'mysql' (-2)
    Kobus Post
    @KobusPost
    running the command in the docker container?
    Thomas
    @alpham8
    @shyim and @KobusPost Thank you very much for that nginx-prox hint. Do you have a working example for me? Otherwise I'd guess there's too much magic going on here
    ajimenez
    @poncho-jim
    yes
    right here
    (1/1) Starting
    > docker exec -i --env COLUMNS=`tput cols` --env LINES=`tput lines` -u 1000:1000 -t beedeb7b9a6380be8abef3e070c6c3709f6f1a4e547f9e9f51b8151c5fe3488b bash
        application@beedeb7b9a63:/app$ ./psh.phar install
    and then the same
    jordan3949
    @jordan3949

    Also having some issues with theme inheritance and wondering if anyone can see any obvious issues? Shopwares example also seems to reference vendor/Storefront and I have vendor/platform/src/Storefront for some reason? Thanks.

    /vendor/shopware/platform/src/Storefront/Resources/views/storefront/layout/header/logo.html.twig

    my theme -
    /custom/plugins/MyTheme/src/Resources/views/storefront/layout/header/logo.html.twig

    and inside my theme file:

    {% sw_extends '@Storefront/storefront/layout/header/logo.html.twig' %}
    {% block layout_header_logo_link %}
    <h2>Hello world!</h2>
    {% endblock %}