by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Niklas Teich
    @NiklasTeich
    When is the constructor going to be executed? ...
    Because it looks like its not executed at all :( All other subscribers are working ..
    Raphael Emmerich
    @emmer91
    @NiklasTeich is the subscriber registered in any services.xml with the right tag?
    Niklas Teich
    @NiklasTeich
    @emmer91 Yeah, it looks identically compared to my other plugins and plugin subscribers ... i also tried StateMachineStateChangeEvent::class as a subscribed event but it also does not work :/
    If i relocate the StateMachineStateChangeEvent in another working subscriber, it also does not get triggered. So, something does not work with the StateMachineStateChangeEvent (class, STATE_MACHINE_TRANSITION_SIDE_ENTER) triggered by the PayPal plugin
    bojandavkov
    @bojandavkov
    I have migrated products from Magento, but on the category listing instead of the main product it is displayed its variant. Anyone aware of this case? Or where i cant find the collection which is filtering the proucts?
    Screenshot from 2020-04-09 15-21-01.png
    Raphael Emmerich
    @emmer91
    @NiklasTeich stupid question, the plugin is installed and active?
    Thomas
    @alpham8
    @poncho-jim It should be only one shopware shop, the other are just php sites
    Raphael Emmerich
    @emmer91
    @NiklasTeich versuch dich mal auf das Shopware\Core\System\StateMachine\Event\StateMachineTransitionEvent zu registrieren. (StateMachineTransitionEvent::class) zu subriben und dann über getTransitionSide auf das Event überprüfen, im welchen Status du bist
    Niklas Teich
    @NiklasTeich

    @emmer91 All subscribers to the StateMachineTransitionEvent are not triggered. My first working example only works because i use

    <tag name="kernel.event_listener" event="state_machine.order_transaction.state_changed" method="onOrderTransactionStateChange"/>

    I found it at https://github.com/shopware/platform/blob/2b599a79d9a41d1f9dddcc34a232225594eff5e1/src/Core/Checkout/DependencyInjection/order.xml#L106
    But - i don't get it why this event is triggered and the StateMachineTransitionEvent::class, STATE_MACHINE_TRANSITION_SIDE_ENTER ... not

    Christopher Dosin
    @ChristopherDosin

    Does anybody has already created a plugin that uses a pagination?
    I am still trying to figure out how to create a pagination from an entity and also with filters - So kinda like the product listing view - Only for your own entity 😇

    Is the whole pagination for example for the product listing done within the the ProductListingFeaturesSubscriber ?

    Raphael Emmerich
    @emmer91

    @NiklasTeich the problem is this Method i think: \Shopware\Core\System\StateMachine\Event\StateMachineStateChangeEvent::getName

    it will be used in \Shopware\Core\System\StateMachine\StateMachineRegistry::transition. Your event name should be the same as in the Element you posted: state_machine.order_transaction.state_changed

    Niklas Teich
    @NiklasTeich
    @emmer91 I tried to subscribe StateMachineStateChangeEvent::STATE_MACHINE_TRANSITION_SIDE_ENTER but it didn't work ..
    @emmer91 Or, you mean really 'state_machine.order_transaction.state_changed'? This is nowhere defined, only used in this 'extra' kernel.event_listener ...
    Raphael Emmerich
    @emmer91
    @NiklasTeich with the given Event you can check the $event->getTransitionSide() to check if you are in the Event: StateMachineStateChangeEvent::STATE_MACHINE_TRANSITION_SIDE_ENTER
    Niklas Teich
    @NiklasTeich
    @emmer91 I'm already doing this right now :) Yes, this works. Everything works now but like i said: Not as a standard event subscriber, but only as as this weird looking kernel.event_listener service tagged class.
    Carolin Reiser
    @caro4p_gitlab
    so, i created my own document type (1:1 copy from invoice currently) and an own number range for it (also copied from invoice). sadly the number doesnt count up tho uppon creating a new document (its all individual, data is correct etc) and my number field is not editable. i also realized i have no entry in the table number_range_state - guess thats my issue. how can i get my number range to have an entry there and get it updated? i guess i forgot a part somewhere, but cant figure out what. all tips are greatly appreciated :)
    ct-anaalbic
    @ct-anaalbic
    Hi to all.
    I am trying to install Shopware 6 with docker in Ubuntu, and every image is run, but when I tried to go on localhost:8000, I got 503 error like on the screenshot bellow
    ct-anaalbic
    @ct-anaalbic
    image.png
    Does anyone know what is the problem here?
    As I could see, the problem is on the server side
    Анастасия
    @KaiRale
    @ChristopherDosin I did for one plugin, but quite primitive alt
    Christopher Dosin
    @ChristopherDosin
    @KaiRale Yes, thank you. Already got it. Thanks for your help :)
    Thomas
    @alpham8

    By given this config it redirects me to recovery/install/index.php and then it returns 404 http status: https://symfony.com/doc/current/setup/web_server_configuration.html#nginx

    I tried already this: https://www.the-cake-shop.de/shopware-6-mit-nginx-konfigurieren/
    But it doesn't change anything

    Rohith Meethal
    @rohithmeethal
    Why was ProductRepository named as SalesChannelRepository and used as $productRepository throughout the controllers ?
    kiener-wybe
    @kiener-wybe

    Does anybody have any idea why my Shopware search doesn't appear to find anything except for one (or maybe some others depending on the search) product, even though I've sync'ed about 20.000 through the API, all in the same manner:
    Universal visiblity (30), they have translations in two languages, they have at least one photo, a category, a saleschannel and fields like stock and price are filled.

    I have four products with almost the same name, by the same manufacturer, in the same category but when I search for it, only one of these items shows up.

    kiener-wybe
    @kiener-wybe
    If I edit a product (andmanually change some of its values) it appears in the search afterwards. Is there something I can do to make all products appear in the search results?
    ajimenez
    @poncho-jim
    @KobusPost yes it is listed, but I can't see the service whenever I do docker ps
    ajimenez
    @poncho-jim
    please help
    ./psh.phar docker:start
    ./psh.phar docker:ssh
    ./psh.phar install
    
    (1/1) Starting
    > docker exec -i --env COLUMNS=`tput cols` --env LINES=`tput lines` -u 1000:1000 -t beedeb7b9a6380be8abef3e070c6c3709f6f1a4e547f9e9f51b8151c5fe3488b bash
        application@beedeb7b9a63:/app$ ./psh.phar install
    (4/40) Starting
    > mysql -u 'app' -p'app' -h 'mysql' --port='3306' -e "DROP DATABASE IF EXISTS \`shopware\`"
        ERROR 2005 (HY000): Unknown MySQL server host 'mysql' (-2)
    @alpham8 what do you mean?
    ajimenez
    @poncho-jim
    help please someone
    haha
    Geert van Wittlaer
    @vanWittlaer
    hey poncho man what's your problem?
    MelvinAchterhuis
    @MelvinAchterhuis
    @kiener-wybe try bin/console dal:refresh:index
    ajimenez
    @poncho-jim

    Thanks @vanWittlaer I can't run ./psh.phar install or ./bin/setup

    This is my front end and backend

    An exception occurred in driver: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

    I have mysql-server installed on this machine I am runnin Ubuntu 18, I have all the requirements

    Geert van Wittlaer
    @vanWittlaer
    not using the docker setup?
    ajimenez
    @poncho-jim

    yeah I ran

    ./psh.phar docker:start
    ./psh.phar docker:ssh

    then install inside the container and the error comes again
    (4/40) Starting
    > mysql -u 'app' -p'app' -h 'mysql' --port='3306' -e "DROP DATABASE IF EXISTS \`shopware\`"
        ERROR 2005 (HY000): Unknown MySQL server host 'mysql' (-2)
    Geert van Wittlaer
    @vanWittlaer
    can you post result of local command docker ps plesae - check mysql container is running
    ajimenez
    @poncho-jim
    I have docker-compose, docker, bash, php 7.2
    it is not running but it is configured in the docker compose file
    here you go
    Geert van Wittlaer
    @vanWittlaer
    again use docker ps to verify mysql container is running
    ajimenez
    @poncho-jim
    the container is not running
    Screenshot from 2020-04-10 11-34-54.png
    I am not sure why
    here is how my docker compose file looks like