Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    ajimenez
    @poncho-jim
    @KobusPost yes it is listed, but I can't see the service whenever I do docker ps
    ajimenez
    @poncho-jim
    please help
    ./psh.phar docker:start
    ./psh.phar docker:ssh
    ./psh.phar install
    
    (1/1) Starting
    > docker exec -i --env COLUMNS=`tput cols` --env LINES=`tput lines` -u 1000:1000 -t beedeb7b9a6380be8abef3e070c6c3709f6f1a4e547f9e9f51b8151c5fe3488b bash
        application@beedeb7b9a63:/app$ ./psh.phar install
    (4/40) Starting
    > mysql -u 'app' -p'app' -h 'mysql' --port='3306' -e "DROP DATABASE IF EXISTS \`shopware\`"
        ERROR 2005 (HY000): Unknown MySQL server host 'mysql' (-2)
    @alpham8 what do you mean?
    ajimenez
    @poncho-jim
    help please someone
    haha
    Geert van Wittlaer
    @vanWittlaer
    hey poncho man what's your problem?
    MelvinAchterhuis
    @MelvinAchterhuis
    @kiener-wybe try bin/console dal:refresh:index
    ajimenez
    @poncho-jim

    Thanks @vanWittlaer I can't run ./psh.phar install or ./bin/setup

    This is my front end and backend

    An exception occurred in driver: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

    I have mysql-server installed on this machine I am runnin Ubuntu 18, I have all the requirements

    Geert van Wittlaer
    @vanWittlaer
    not using the docker setup?
    ajimenez
    @poncho-jim

    yeah I ran

    ./psh.phar docker:start
    ./psh.phar docker:ssh

    then install inside the container and the error comes again
    (4/40) Starting
    > mysql -u 'app' -p'app' -h 'mysql' --port='3306' -e "DROP DATABASE IF EXISTS \`shopware\`"
        ERROR 2005 (HY000): Unknown MySQL server host 'mysql' (-2)
    Geert van Wittlaer
    @vanWittlaer
    can you post result of local command docker ps plesae - check mysql container is running
    ajimenez
    @poncho-jim
    I have docker-compose, docker, bash, php 7.2
    it is not running but it is configured in the docker compose file
    here you go
    Geert van Wittlaer
    @vanWittlaer
    again use docker ps to verify mysql container is running
    ajimenez
    @poncho-jim
    the container is not running
    Screenshot from 2020-04-10 11-34-54.png
    I am not sure why
    here is how my docker compose file looks like
    version: '3.7'
    
    services:
      app_server:
        image: shopware/development:latest
        links:
          - app_mysql:mysql
          - mailhog:mailhog
        extra_hosts:
          - "docker.vm:127.0.0.1"
        volumes:
          - ~/.composer:/.composer
        tmpfs:
          - /tmp:mode=1777
    
      app_mysql:
        build: dev-ops/docker/containers/mysql
        environment:
          MYSQL_ROOT_PASSWORD: root
          MYSQL_USER: app
          MYSQL_PASSWORD: app
    
      cypress:
        image: cypress/included:3.8.1
        tty: true
        ipc: host
        links:
          - app_server:docker.vm
        environment:
          - CYPRESS_baseUrl=http://docker.vm:8000
          - DISPLAY
        volumes:
          - ./vendor/shopware/platform/src/Storefront/Resources/app/storefront/test/e2e:/e2e-Storefront
          - ./vendor/shopware/platform/src/Administration/Resources/app/administration/test/e2e:/e2e-Administration
          # for Cypress to communicate with the X11 server pass this socket file
          # in addition to any other mapped volumes
          - /tmp/.X11-unix:/tmp/.X11-unix
        entrypoint: /bin/bash
    
      mailhog:
        image: mailhog/mailhog
    
      adminer:
        image: adminer:latest
        links:
          - app_mysql:mysql
    
      elasticsearch:
        image: elastic/elasticsearch:7.1.1
        environment:
          - "ES_JAVA_OPTS=-Xms512m -Xmx512m"
          - discovery.type=single-node
    Geert van Wittlaer
    @vanWittlaer
    it is difficult to spot the actual reason from here. Is your setup based on one of the Shopware repos - which one? Do you see any error messages for docker:start?
    I downloaded the latest repo
    I don't see any messages when I run ./psh.phar docker:start
    1 reply
    Geert van Wittlaer
    @vanWittlaer
    no I mean the docker setup - is it from shopware/development?
    recommend starting with shopware/development or shopware/production
    Thomas
    @alpham8
    @poncho-jim I need the nginx config for recovery/ins/index.php. The plain Symyony 4 config seems to be not enough
    recovery/Install/Index.php of course... Mobile client sucks :see_no_evil:
    ajimenez
    @poncho-jim
    @vanWittlaer I always start with the development template
    @alpham8 oh jesus what are you trying to do haha
    Max
    @aragon999
    @poncho-jim have you checked the logs of the app_mysql container? maybe it crashes on startup due to some reason
    @alpham8 why do you even want to use the web installer and not just use the console command?
    ajimenez
    @poncho-jim

    No I haven't I am thinking that that log is somewhere here development/dev-ops/docker/containers/mysql

    but I just have 4 files and none of them finish in .log

    Geert van Wittlaer
    @vanWittlaer
    the docker-compose file you posted doesn't look like the repo version. also there should be a docker-compose.override.yml
    Max
    @aragon999
    @poncho-jim yes, but you should probably learn more how to use Docker itself, I mean in the end the commands you are running are just some scripts which run docker and docker-compose commands, see here for example: https://github.com/shopware/development/blob/master/dev-ops/docker/actions/start.sh
    and if you for example do not use the -d flag when starting the container you can see the logs (otherwise it might be good to run: docker-compose logs app_mysql)
    nikunjw3nuts
    @nikunjw3nuts

    Hello all

    I want to add new taxt box in product slider is it possible ?
    See my screenshot : https://files.gitter.im/nikunjw3nuts/sYwU/image.png

    thseeker
    @thsekeer
    Hello All ..... how to add custom Font in shoping element.. ? and how to add icone filter in shopware 6 please any update.........??????
    kiener-wybe
    @kiener-wybe
    @MelvinAchterhuis That seemed to do the trick, thanks! Anything I can do about the search being incredibly slow?
    nikunjw3nuts
    @nikunjw3nuts

    Hello All,

    How to show 4 item in product slider ?

    elbsurfer
    @elbsurfer

    Kann mir jemand sagen, warum ich bei dieser Funktion

    $settingRepository = $this->container->get('my_custom.repository');
            $settingRepository->create(
                [
                    ['data' => $params['data']],
                ],
                \Shopware\Core\Framework\Context::createDefaultContext()
            );

    Die Fehlermeldung bekomme: General error: 1364 Field 'updated_at' doesn't have a default value Das Entity, hat die Spalten created_at, updated_at, die standardmäßig so angelegt werden:

    `created_at` DATETIME(3) NOT NULL,
    `updated_at` DATETIME(3) NOT NULL,
    Timothy
    @timothydc
    Anyone else having the problem where the cache folder grows to 50 GB+ in a couple of hours? I ran bin/console cache:pool:prune and 2 hours later the cache folder is back up to 50 GB.
    resava
    @resava
    hi to all,
    Shyim
    @shyim
    @elbsurfer, the sql generator is broken
    you have to make updated_at nullable
    @timothydc, how many products do you have :o
    SUCI
    @telefonosuci
    If i configure babel-loader for my storefront plugin to build React jsx, How can I exclude the platform folder from the webpack.config.js to avoid getting an error during build ?