Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Ben Le
    @goben2489
    @Arzi1994 Thank you for your link, i woring follow it
    Heiner Lohaus
    @hlohaus
    @shopware why my changes not in the changelog?
    nikunjw3nuts
    @nikunjw3nuts
    @Arzi1994 Okay thank you very much
    Carolin Reiser
    @caro4p_gitlab
    how are you guys handling testcases and licences? in shopware 5 we always used a subdirectory - (myshop.com/testcase) but since you have to access the public folder i am not to sure if thats the best way to handle it with shopware 6...
    Daniel W
    @danielwolf1
    Hi, I'm trying to run dockware dev:latest but i get a 500 server error when opening shopware in the browser. Where can I find the log file?
    Ben Le
    @goben2489
    How call api controller admin, i called but has 404 routes not found ?
    https://docs.shopware.com/en/shopware-platform-dev-en/how-to/api-controller
    Simon Kunz
    @MDSLKTR
    Hey, one question. Why is there a store api and a sales channel api which both have several features in common yet miss or add different things. Also to build a fully functioning frontend you would need both? Or am i missing something here?
    Patrick
    @Paddy65305
    can anyone tell me where die domain comes from in the sitemaps (6.1.6)?
    I have more SalesChannels and anywhere in the GZ-files is an old domain-name
    Shyim
    @shyim
    maybe you need to regenerate it
    they are cached
    Patrick
    @Paddy65305
    yes i have generate them
    but the domain is incorrect
    Shyim
    @shyim
    the domains comes from the sales channel
    Patrick
    @Paddy65305
    yes but the domain was no longer in the channels
    and I have for all channels the same domain
    Patrick
    @Paddy65305
    and this is only in the product.gz file :-|
    the other files are correct
    jensgswiss
    @jensgswiss
    Has anyone been able to work it out to upload images through the api/v1/_action/sync endpoint? I know that it’s poosible to upload one single image via api/v1/_action/media/<mediaId>/upload. But for big number of images should there a possibility via sync api. Any idea/solution?
    skr-brandcrock
    @skr-brandcrock
    Hi all
    image.png
    Backend is not working
    How to resolve this issue
    Please explain me
    thanks in advance
    "Uncaught (in promise) TypeError: Cannot read property 'push' of null in shopware forum"
    Micha Hobert
    @Isengo1989
    Hi, can ONE simply create a product with an working image with one API Call? Or do you always need two Posts ?
    kekster
    @kekster
    sw6.2 administration and plugin configuration
    route sw.plugin.settings
    where is the app/module for this?!
    i cant find it
    only plugin.list or plugin.updates
    Tschitt
    @Tschitt

    (SW6.2)
    JS-Plugins of my themes only work in hot-reload-mode. If I do storefront:dev (or :build), I get error messages.

    Chrome:

    GET http://DOMAIN.TLD/theme/xxx/css/~scss/variables net::ERR_ABORTED 404 (Not Found)
    all.js:8 Uncaught SyntaxError: Cannot use import statement outside a module

    Firefox lists too a 404 for /variables and tells me also:

    SyntaxError: import declarations may only appear at top level of a module

    In this case my JS scripts won't run.

    If I turn on hot-reload-mode (isHMRMode) and do a storefront:hot everything runs fine (and without error messages).

    I don't understand those error messages and why it works in hot-reload-mode - but only in this mode.

    I'm pretty sure I followed the how-to Shopware posted here: https://docs.shopware.com/en/shopware-platform-dev-en/theme-guide/javascript

    My structure:

    My /custom/plugins/THEMENAME/src/Resources/app/storefront/src/main.js looks like this:

    import MyThemeFunctions from './my-theme-functions/my-theme-functions.plugin';
    
    const PluginManager = window.PluginManager;
    
    PluginManager.register('MyThemeFunctions', MyThemeFunctions);

    And the following is my (shortened) /custom/plugins/THEMENAME/src/Resources/app/storefront/src/my-theme-functions/my-theme-functions.plugin.js:

    import Plugin from 'src/plugin-system/plugin.class';
    export default class MyThemeFunctions extends Plugin {
    init.... etc..pp
    
    }
    kekster
    @kekster
    route sw.plugin.settings in admin. does anyone know where i can find the module for this?!
    Victor Ndambakuwa
    @vttn
    How do you prompt file download using the httpClient?
    this.TransactionService.getInvoiceDocument(salesChannelId, Order)
       .then((response) => {
    // do something????
       })
    PheysX
    @PheysX
    is it possible to get the theme id by the saleschannel entity? smth. like ->getTheme()->getId() ?
    Patrick Stahl
    @PaddyS
    Afaik this only works the other way around: $theme->getSalesChannels()
    fwards
    @fwards
    Is it possible to extend the sw-text-editor? What is the technology behind?
    example
    fwards
    @fwards
    Okay, the plugin integrates tinymce into shopware 6? @hlohaus
    Marcus C
    @macidev
    Is there any debugging possibility if checkout in frontend failed and an order was created in the admin?
    Marcus C
    @macidev
    Always check if the mail/smtp credentials are correct.
    Peter Meijer
    @peter-bztrs
    Micha Hobert
    @Isengo1989
    Is it possible that the normal dal:refresh:index doesn't work anymore in 6.2 ? The admin gui stuff seems to work, but not in the cli
    Kevin Müller
    @xkmueller
    hello guys, does extend work with the cms elements?
    morteza shabani
    @pedramham
    Hi how i can mange pagination shopware 6 ? i want to display 10 products in each pages in the Category product page
    Dominik Mank
    @dominikmank

    heya,

    someone uses 6.2.0 production template with "bin/watch-administration.sh" and has the problem that one cannot login in administration with the proxy mode?
    Seems like this is due to the usage of the cookiestorage instead of the localstorage now, and the context.api.url parameter seems everytime "localhost" where my domain is another due development, so that the authToken writes to localhost instead my domain..

    Someone has the same problem or a solution for this?

    momocode-de
    @momocode-de
    Hi!
    Is that the intention that you can create only one mail template with a specific mail type for the same sales channel? I have the sales channels "Storefront" and "Headless" and I have created a mail template with the type "Contact form" and assigned the "Storefront" sales channel to it. When I now create another mail template with the type "Contact form", I can only select the "Headless" sales channel anymore. And when I create then another one, I can't select a sales channel anymore. Is that intended? I thought I can create as much templates as I want with a specific mail type.
    Well I think it makes sense for this example. But I thought I can create an own mail type in my plugin and the user can then create and use as much mail templates as he want with this mail type. But it seems like thats not possible :/
    The Rick
    @RicTempesta_twitter
    Hello everyone, I am quite new to Shopware. I am dealing with SW6 and I need a custom configuration of docker-compose, so I changed the docker.compose.override.yml file, but every time I run a as psh command, it is restored to its default version. How can I address it?