Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    pawonpawon
    @pawonpawon
    How do I get around this?
    Secondly - what is the normal order creation flow in Shopware? I come from a Magento background (15 years).
    Is a 'delivery' and a 'transaction' always created when an order is created?
    (even before the delivery is send out and/or the payment is done)?
    I am asking because the test order I created without the deliveries and transactions - in the admin they show "no transactions yet" and "no deliveries yet" and there is no way I can create those from the admin
    11 replies
    (plus I'm getting 500 server errors on some actions , I think because of the missing delivery and transaction objects/relations)
    pawonpawon
    @pawonpawon
    any help appreciated :)
    aleckscastro
    @aleckscastro
    The Bundle example: An InDepth guide seems to have the "Command" and "Decorator" parts missing: https://docs.shopware.com/en/shopware-platform-dev-en/how-to/indepth-guide-bundle
    aleckscastro
    @aleckscastro
    Why is the entity association created with the help from the above tutorial (Step 5: Adding associations to the entity) not available in the new tab I created following this tutorial: https://docs.shopware.com/en/shopware-platform-dev-en/how-to/new-tab-admin ?
    I get the following error: ReferenceError: product is not defined
    aleckscastro
    @aleckscastro
    The same entity association works fine under the General tab (sw-product-detail-base.html.twig), but not under my custom template (sw-product-detail-custom.html.twig)
    Mike Wink
    @mikewink
    Hello. I would like to ask if there is a sample SW6 theme that can be used to learn how to implement certain aspects like static assets (fonts, images), how to use normal CSS and how to use hot reloading in general (without the development installation). Thank you
    aleckscastro
    @aleckscastro
    @mikewink You can use Shopware's default theme as a basis. Start with /vendor/shopware/platform/src/Storefront/Resources/theme.json. Check out the "style", "script", "asset" and "sw-font-family-base" sections. You should store your theme's assets like fonts, images and icons in the folder "app/storefront/src/assets" of your theme. CSS in "app/storefront/src/scss/". Use base.scss for normal CSS or simply create a custom.scss file and and import it into base.scss. You can do the same for fonts: Create a scss file to load your fonts using src: url('../assets/font/myFont.woff'). As for hot reloading, ./psh.phar storefront:hot or ./psh.phar storefront:watch never worked for me on the storefront, only in the administration (./psh.phar administration:watch).
    Dennis Schwengler
    @EldoRay
    Hello! I am trying to import a customer in sw6. Only have email, password and id in csv file. Added some ID from DB like the hashed UUID for defaultShippingAddressId and so on. Import did not throw errors and "succeded" but no customer is added. What am I doing wrong?
    Hendrik Sรถbbing
    @soebbing
    @EldoRay You'll need to add some more details to be others able to help you. What fields are you writing to, did you fill all required fields? How did you verify that the customer was or wasn't added?
    Enzo Perrotta
    @eperrotta
    Hello guys, in the checkout page, as a logged in user, I can't change the shipping address. Clicking on the Change shipping address buttons opens the Billing address selection rather the shipping one.
    Am i missing something? Thanks!
    Enzo Perrotta
    @eperrotta

    I am missing an option from SW5 in SW6: it is possible in the shop settings under country, to "Disable tax conditions if a VAT ID is entered". I only see the tax free option in SW6?!? will this be added later?

    Is there any update about this feature?

    Mike Wink
    @mikewink
    @aleckscastro thank you very much for your detailed answer! I'm doing the same things you wrote and the docs describe. I'm still struggling with hot reload, but for now I just use PostCSS and plain CSS. ๐Ÿ‘๐Ÿผ๐Ÿ†
    Nils Harder
    @inventivo
    Can the user recompile a theme via administration?
    Peter Meijer
    @peter-bztrs
    Good morning, why can demodata only be used with the production environment APP_ENV? What's the reason behind this?
    Mike Wink
    @mikewink
    @inventivo have you tried saving the theme in question? I think that starts a recompile in the back.
    aleckscastro
    @aleckscastro
    @inventivo I think when you disable / enable the theme plugin, Shopware recompiles the theme and clears the cache. @mikewink
    Marcus Egger
    @marcusegger
    Hello guys. I can add users under system/settings/Users&permissions, but i can't see a list of users...is that intended behaviour? and am i right that there's no concept for a "super admin" to manage the admin users?
    Mike Wink
    @mikewink
    @aleckscastro or so! Either way should bring a update in the theme. ๐Ÿ‘๐Ÿผ
    @marcusegger what version are you running? I can see a list under โ€ฆ/admin#/sw/settings/user/list?โ€ฆ
    @marcusegger as there is no real permission system in place right now, I don't think that there is a concept of super admins or super user one like in other systems.
    Mike Wink
    @mikewink
    @eperrotta there is an item on the roadmap with VAT validation, maybe that will bring back the missed functionality. In the meantime you could hope for a plugin or write your own.
    @EldoRay what I like to do first is trying the action I want to accomplish using the normal backend. I then check the browser dev tools (network tab) for the POST and PATCH requests and what payload (JSON) they carry. I then use this as my blueprint for my own API calls. Worked very well so far, except for SEO URLs and media uploads, they are a bit more involved.
    Mike Wink
    @mikewink
    One question to you guys: Is the Swagger UI working in SW 6.2? I get an error 500 for the URL that worked in 6.1 and before.
    Marcus Egger
    @marcusegger
    @mikewink i'm running vesion 6.2.0 stable version
    image.png
    Sebastian Wilhelm
    @zolthan
    Hi all, does anyone know if there is a plan to remove the flicker with shopping experiences in the backend if you use Firefox? (Using Chrome there is no flicker...)
    Mike Wink
    @mikewink
    @marcusegger me too. Have you checked the network tab for any request/response errors?
    @zolthan I'm running SW6.2 right now in FF 76.0.1 and 77.0b9 Dev Edition, both on MacOS. Where do you see the flicker occur?
    Marcus Egger
    @marcusegger
    @mikewink thx, seems to be a problem in my chrome with the consume request. in firefox it's working
    Mike Wink
    @mikewink
    @marcusegger More than welcome. You will spend quite some time in the network tab. ๐Ÿ˜…
    Sebastian Wilhelm
    @zolthan
    @mikewink the flicker occurs when you add a block to an existing block in a section (FF 76.0.1 on Mac)
    Martin Tygsen
    @martintygsen_twitter
    Anyone experimented with adding properties to the Rule builder under Dynamic product groups? So it is possible to setup a Dynamic product group based on certain Property values?
    Patrick
    @Paddy65305
    how i make an update with the update-zip files? I musst update the shop to 6.1.6 because 6.2 is not testet with our plugins.
    this is not possible in admin-area correct?
    2 replies
    GaboCapo
    @GaboCapo
    adminer.png
    i installed locally on linux docker with shopware 6. what are the login data for the Adminer to view the SQL database. Thanks a lot!
    GaboCapo
    @GaboCapo
    in the docker-compose.yml i find:
    app_mysql:
    build: dev-ops/docker/containers/mysql
    environment:
    MYSQL_ROOT_PASSWORD: root
    MYSQL_USER: app
    MYSQL_PASSWORD: app
    but the login credentials are wrong. or the server/DB name.
    aleckscastro
    @aleckscastro
    @GaboCapo The server is: mysql:3306
    user: app
    pwd: app
    GaboCapo
    @GaboCapo
    Works. <3 Thanks a lot!
    reineltchris
    @reineltchris
    i updated shopware on my dockware.io container.
    I cant use use the build-storfront command anymore:
    ./bin/build-storefront.sh: Permission denied
    Shyim
    @shyim
    @Paddy65305: Download zip und unpack and request /recovery/update
    @reineltchris, default copy issues. You have copied without permissions. Maybe just correct them with chmod
    reineltchris
    @reineltchris
    @shyim it worked, thanks
    reineltchris
    @reineltchris
    instead of showing an error message for the page user it throws an exception when the captcha failed, is that right?
    Freddy Rommel
    @rommelfreddy
    Hello !
    i still miss a opportunity to add some fields for a payment method during the checkout. is there something planed?