Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    CoronaClinic
    @CoronaClinic
    Hello
    I'm going to get cms data from id on subscriber in shopware 6 plugin
    How can I get it?
    charles
    @charles0301
    it is possible to have more than one order transaction for single order and how to check this?
    lxregistry
    @lxregistry

    Is there a way to use upload file function in plugin config area.
    My payment plugin require a pem file to use in configuration.
    I tried with <component name="sw-media-upload-v2">

    <name>abc</name>
    <label>Upload pem file</label>
    <required>true</required>
    <fileAccept>application/x-pem-file</fileAccept>
    <allowMultiSelect>false</allowMultiSelect>
    </component>
    Where I can find documentation how to use upload file, store the file in a specific plugin directory?
    Any examples/docs of how to work with uploaded files please.

    fredyg
    @fredyg55999852_twitter

    Hi guys, any one to help me to get this query running with DAL in shopware 6?

    SELECT od.articleordernumber , cc.countryname , SUM(od.quantity) FROM s_order_details AS od JOIN s_order AS o ON o.id = od.orderID JOIN s_order_shippingaddress AS os ON os.orderID = od.orderID JOIN s_core_countries AS cc ON cc.id = os.countryID WHERE DATE(o.ordertime) BETWEEN DATE_FORMAT(NOW() - INTERVAL 1 MONTH, '%Y-%m-01') AND LAST_DAY(NOW() - INTERVAL 1 MONTH) GROUP BY od.articleordernumber, cc.id;

    TWry
    @TWry
    I've taken over some code which is using the following shopware API get query:
    https://myshop.com/api/v2/order?associations[lineItems][]&associations[addresses][]&associations[deliveries][]&associations[transactions][]
    I can't find documentation about it unfortunately. I need additional data from the order, i.e. the address country and salutation. Any help is greatly appreciated!
    Gunnar Polte
    @gunnar.polte_gitlab
    @KennyH1 Hi Kenny, have you found a solution for it? I have a similiar error.
    Babita-Emakers
    @Babita-Emakers
    image.png
    Email templates at the admin are displayed with empty tables, all templates are at the database but not shown at admin's email template. any solution?
    DanielZiehfreund
    @DanielZiehfreund
    I have problems with the product images on listing and product detail page.
    The images are loaded in full size on desktop view instead of the sizes in srcset.
    This causes a very bad page load time.
    Can anyone tell me how to extend or change the srcset to load the smaller images on desktop view?
    Test dbuglab
    @test91171:matrix.org
    [m]
    Hello, i have created a plugin and a scheduled task under it, but my scheduled task(script) run for certain period of time, after some time it stop working and when it reactivate my plugin it again started working. Can anyone help me why this happening?
    babita
    @babita-web
    Hi , I have edited the Email template for desktop and mobile view but while testing at gmail account its not showing the style (css) as designed but at yahoo its showing all css perfectly, can anyone tell how to make it compatible for Gmail and other domains.
    Vikramjit Singh Lehal
    @Vikramjit_gitlab
    Hi all, how to edit storefront contact form validation in shopware 6? I wana remove validation from some fields but could not find any helping doc. I know validation for few inputs fileds can be configured in admin but I don't wana do that. If anybody have an idea how to override contact form validation please help.
    hypesol
    @hypesol
    image.png
    Hi I am installing shopware on ubuntu following this documentation
    but i am getting above screen
    image.png
    and when hit only localhost then i get his error there
    and right now i am unable to use my other PHP projects
    can anyone help me to resolve this issue. i am not getting help on google on this issue
    Slawa
    @slawa_d_twitter
    image.png
    image.png

    @komali_s_gitlab @/all
    Did you found a solution for your Problem from 2019?

    Fatal error: Uncaught Doctrine\ORM\Mapping\MappingException: No identifier/primary key specified for Entity "Shopware\Models\Attribute\Shop" sub class of "Shopware\Components\Model\ModelEntity". Every Entity must have an identifier/primary key. in /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/MappingException.php:46 Stack trace: #0 /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataInfo.php(1009): Doctrine\ORM\Mapping\MappingException::identifierRequired('Shopware\Models...') #1 /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataFactory.php(265): Doctrine\ORM\Mapping\ClassMetadataInfo->validateIdentifier() #2 /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataFactory.php(245): Doctrine\ORM\Mapping\ClassMetadataFactory->validateRuntimeMetadata(Object(Doctrine\ORM\Mapping\ClassMetadata), NULL) #3 /html/develop/rivolta/rivolta/vendor/doctrine/persistence/lib/Doctrine/Common/Persistence/ in /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/MappingException.php on line 46

    Vlad
    @VDuda
    hmm anyone have experience getting Shopware 6 up in K8s? I'm trying to figure out issues with readiness/liveliness WRT APP_URL in the env
    hypesol
    @hypesol
    This is the dead forum. I am sure I am on the wrong place
    krzysztofsurdy
    @krzysztofsurdy
    Hello everyone :)
    Levon Atoyan
    @atolev
    Hey Guys.
    Take a look at our new plugin which will be available at the community store very soon.
    https://www.linkedin.com/posts/atolev_shopware-sw-sw6-activity-6783082723134320641-KivJ
    kernanuj
    @kernanuj

    Hi Guys,

    I am facing a problem "The resource owner or authorization server denied the request" when i am using shopware api. can somebody know about that, How am i resolved this issue

    ivandenisov0320
    @ivandenisov0320
    Hi everyone.
    ivandenisov0320
    @ivandenisov0320
    how to resolve internal server 500 error: "controller has no container set, did you forget to define it as a service sybscriber?"....?
    I have already add service in services.xml but 500 error.
    ivandenisov0320
    @ivandenisov0320
    help me
    Cs Soft
    @PHPManager133
    Hello All
    Anyone please help me how can I add a random product to cart , I created controller , need to know which function will add random product to cart.
    Benjamin Hedrich
    @bh
    Hi there, does anyone know how can convert a childproduct to a "flat" product (a normal product which is not a child of a parent product) without deleting it via api?
    bartoszekj
    @bartoszekj
    Hello I have a problem , I am trying adjust my plugin from 6.3 shopware to 6.4 and i have got a problem with
    Shopware\Storefront\Controller\CheckoutController" has no container set, did you forget to define it as a service subscriber? (500 Internal Server Error)
    Is here someont who could help me?
    Payal Patel
    @PayalPatel8

    Hello all,

    I have one custom module and I need to get properties list in this module as a multi-select.
    How it's possible in shopware 6?

    babita
    @babita-web
    Hello Everyone,
    why my plugin is not working After shopware 6.4 upgradation?
    It says
    Unable to load template "storefront/section/cms-section-half-width.html.twig". (Looked into: Framework, Profiling, Administration, Elasticsearch, FroshPlatformAdminer, UltraDeveloper, DneTemplateManager, DneCustomCssJs, Storefront)
    Rann1
    @Rann1
    Question guys:
    I've uploaded my database from a testenviroment to live, and the files aswell, and now all images have broken paths.. Is there any way to fix this ?
    josip-ouzecky
    @josip-ouzecky
    image.png
    Hello everyone i have a problem with bin/watch-storefront.sh command it is watching everything but when i come to https://www.shopware-new.loc:9998/
    this url i get error on picture
    babita
    @babita-web
    image.png
    Shopware 6.4 update: the plugin is not working after shopware update its gives an error
    Aron Homberg
    @kyr0
    Hey all :) I'm new to Shopware - just checked the code etc. I didn't want to deploy my own instance... just wanted to start with a free hosted instance (cloud free plan). When trying to use the Store API I always get 404... do I need to use another API endpoint URL than the public $myName.shopware.store? Does these instances don't have the API enabled?
    Geckoslair
    @geckoslair
    Hi all! I'm new to shopware. I've implemented a CI workflow from github with 6.4.0. The build and deploy succeeded, storefront seems ok, but surfing /admin i get a net::ERR_CONTENT_DECODING_FAILED 200 (OK) on /bundles/administration/static/js/vendors-node.js?16218776821494697 and /bundles/administration/static/js/app.js?16218776825559247. Do any of you have any good advice to investigate the error?