Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    but i am getting above screen
    image.png
    and when hit only localhost then i get his error there
    and right now i am unable to use my other PHP projects
    can anyone help me to resolve this issue. i am not getting help on google on this issue
    Slawa
    @slawa_d_twitter
    image.png
    image.png

    @komali_s_gitlab @/all
    Did you found a solution for your Problem from 2019?

    Fatal error: Uncaught Doctrine\ORM\Mapping\MappingException: No identifier/primary key specified for Entity "Shopware\Models\Attribute\Shop" sub class of "Shopware\Components\Model\ModelEntity". Every Entity must have an identifier/primary key. in /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/MappingException.php:46 Stack trace: #0 /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataInfo.php(1009): Doctrine\ORM\Mapping\MappingException::identifierRequired('Shopware\Models...') #1 /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataFactory.php(265): Doctrine\ORM\Mapping\ClassMetadataInfo->validateIdentifier() #2 /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataFactory.php(245): Doctrine\ORM\Mapping\ClassMetadataFactory->validateRuntimeMetadata(Object(Doctrine\ORM\Mapping\ClassMetadata), NULL) #3 /html/develop/rivolta/rivolta/vendor/doctrine/persistence/lib/Doctrine/Common/Persistence/ in /html/develop/rivolta/rivolta/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/MappingException.php on line 46

    Vlad
    @VDuda
    hmm anyone have experience getting Shopware 6 up in K8s? I'm trying to figure out issues with readiness/liveliness WRT APP_URL in the env
    hypesol
    @hypesol
    This is the dead forum. I am sure I am on the wrong place
    krzysztofsurdy
    @krzysztofsurdy
    Hello everyone :)
    Levon Atoyan
    @atolev
    Hey Guys.
    Take a look at our new plugin which will be available at the community store very soon.
    https://www.linkedin.com/posts/atolev_shopware-sw-sw6-activity-6783082723134320641-KivJ
    kernanuj
    @kernanuj

    Hi Guys,

    I am facing a problem "The resource owner or authorization server denied the request" when i am using shopware api. can somebody know about that, How am i resolved this issue

    ivandenisov0320
    @ivandenisov0320
    Hi everyone.
    ivandenisov0320
    @ivandenisov0320
    how to resolve internal server 500 error: "controller has no container set, did you forget to define it as a service sybscriber?"....?
    I have already add service in services.xml but 500 error.
    ivandenisov0320
    @ivandenisov0320
    help me
    Cs Soft
    @PHPManager133
    Hello All
    Anyone please help me how can I add a random product to cart , I created controller , need to know which function will add random product to cart.
    Benjamin Hedrich
    @bh
    Hi there, does anyone know how can convert a childproduct to a "flat" product (a normal product which is not a child of a parent product) without deleting it via api?
    bartoszekj
    @bartoszekj
    Hello I have a problem , I am trying adjust my plugin from 6.3 shopware to 6.4 and i have got a problem with
    Shopware\Storefront\Controller\CheckoutController" has no container set, did you forget to define it as a service subscriber? (500 Internal Server Error)
    Is here someont who could help me?
    Payal Patel
    @PayalPatel8

    Hello all,

    I have one custom module and I need to get properties list in this module as a multi-select.
    How it's possible in shopware 6?

    babita
    @babita-web
    Hello Everyone,
    why my plugin is not working After shopware 6.4 upgradation?
    It says
    Unable to load template "storefront/section/cms-section-half-width.html.twig". (Looked into: Framework, Profiling, Administration, Elasticsearch, FroshPlatformAdminer, UltraDeveloper, DneTemplateManager, DneCustomCssJs, Storefront)
    Rann1
    @Rann1
    Question guys:
    I've uploaded my database from a testenviroment to live, and the files aswell, and now all images have broken paths.. Is there any way to fix this ?
    josip-ouzecky
    @josip-ouzecky
    image.png
    Hello everyone i have a problem with bin/watch-storefront.sh command it is watching everything but when i come to https://www.shopware-new.loc:9998/
    this url i get error on picture
    babita
    @babita-web
    image.png
    Shopware 6.4 update: the plugin is not working after shopware update its gives an error
    Aron Homberg
    @kyr0
    Hey all :) I'm new to Shopware - just checked the code etc. I didn't want to deploy my own instance... just wanted to start with a free hosted instance (cloud free plan). When trying to use the Store API I always get 404... do I need to use another API endpoint URL than the public $myName.shopware.store? Does these instances don't have the API enabled?
    Geckoslair
    @geckoslair
    Hi all! I'm new to shopware. I've implemented a CI workflow from github with 6.4.0. The build and deploy succeeded, storefront seems ok, but surfing /admin i get a net::ERR_CONTENT_DECODING_FAILED 200 (OK) on /bundles/administration/static/js/vendors-node.js?16218776821494697 and /bundles/administration/static/js/app.js?16218776825559247. Do any of you have any good advice to investigate the error?
    Geckoslair
    @geckoslair
    UPDATE: disabling gzip/brotli compression we can surf /admin correctly
    Patrick van Limburg
    @SoulSlash3r_twitter
    Goodday all, kinda new to shopware. Have used in the past Shopware 5, but then switched over to an other platform. Now with SW6 I would like to make a fresh start. Have installed it and everything is correct. But after the install, I get an internal 500 error with : {"errors":[{"code":"0","status":"500","title":"Internal Server Error","detail":"Attempted to load class \u0022BundleHierarchyBuilder\u0022 from namespace \u0022Shopware\Core\Framework\Adapter\Twig\NamespaceHierarchy\u0022.\nDid you forget a \u0022use\u0022 statement for another namespace?"}]} any idea where I must look at this error ?
    Yogesh Makwana
    @yogesh.makwana_gitlab

    Hi, I need help,

    I am trying to connect in shopware 6 for api/v1/integration

    but somehow getting below error..

        [errors] => Array
        (
            [0] => Array
                (
                    [code] => 0
                    [status] => 404
                    [title] => Not Found
                    [detail] => No route found for "GET /api/v1/integration"
                )
         )

    Can anyone please help me

    Markus Wendorf
    @MarkusWendorf
    Was anyone able to get the child categories association via /store-api/v3/category/{id} (field name is: "children")? Tried with association "children" and "category"
    Mergim Doroci
    @pmdo:matrix.org
    [m]

    Hi everyone, while trying bin/console sitemap:generate I receive the following error:

    07:24:12 CRITICAL [console] Error thrown while running command "sitemap:generate". Message: "Provided language 3596b9b6539e4211b0b54e3 is not in list of available languages: " ["exception" => RuntimeException { …},"command" => "sitemap:generate","message" => "Provided language 3596b9b6539e4211b0b54e3f57bb1f63 is not in list of available languages: "]

    In SalesChannelContextFactory.php line 484:

    Provided language 3596b9b6539e4211b0b54e3 is not in list of available languages

    I saw that also many other people had this problem. Does anyone know the solution ? Thank you

    Ali Hassan
    @alihassanrizvi_gitlab

    Hello guys I am using shopware 6 apis to insert/update product data, but I am getting the following error
    /4/sales This field is write-protected.

    Any trick or method to bypass this so that sales field of products can be updated via api, thanks?

    subjectdenied
    @subjectdenied:matrix.org
    [m]
    hello, i'm trying to get the default development server settings working (localhost:8080) using the docker-compose approach, however i can't reach the server from my host, localhost:8000 does work
    Alphanyx
    @alphanyx
    This message was deleted
    Yogesh Makwana
    @yogesh.makwana_gitlab
    Is it possible to fetch a product from product number in shopware 6 using API?
    2 replies
    Levon Atoyan
    @atolev_gitlab
    Hi there, guys check our new powerful tool for shopware 6.
    https://store.shopware.com/en/sc-2077838038050/seo-banner-slider-revolution.html
    Bob Maier
    @monotanic:matrix.org
    [m]
    For some reason only two countries are displayed in my registration form in shopware 6. I've got about 250 active countries in the admin backend, and they're all in the database, with a "1" in the "active"-column, but only Germany and Spain and displayed in the drop down menu. The menu-form iterates through page.countries and there are only those two countries in said location (I checked with dump). I can't find any significant differences in the country-table in the database. So whyyyy are only those two countries ín page.countries?!
    1 reply
    jameswill
    @jameswill
    Hello all, I have installed shopware 6.4.1.2 on my server using CLI and I get following error. Key path "file:///home/user/public_html/shopware6412/config/jwt/public.pem" does not exist or is not readable
    I tried changing it's permissions to 0777 but then I get error "User Notice: Key file "file:///home/user/public_html/shopware6412/config/jwt/public.pem" permissions are not correct, recommend changing to 600 or 660 instead of 777
    1 reply
    dungdoan
    @dungdoan
    Hi everyone,
    I have an issue, i'm extending from product slider in shopware default.
    Currently, i want to set up dynamic products in a slide (from 1-4 products), how should i write css or javascript? Shopware uses default 3 products/slide.
    Thank everyone.