Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Feb 27 15:40

    shopwareBot on 5.6

    SW-24973 - Fix broken hreflang … Merge branch 'sw-24973/5.6/fix-… (compare)

  • Feb 27 13:51
    pascalheidmann synchronize #2320
  • Feb 27 13:50
    pascalheidmann synchronize #2320
  • Feb 27 12:29
    pascalheidmann synchronize #2320
  • Feb 27 10:45
    mitelg labeled #1309
  • Feb 26 13:05
    shopwareBot labeled #2315
  • Feb 26 13:05
    shopwareBot labeled #2315
  • Feb 26 12:56
    pascalheidmann synchronize #2322
  • Feb 26 12:49
    pascalheidmann synchronize #2320
  • Feb 26 12:46
    shopwareBot labeled #2321
  • Feb 26 12:46
    shopwareBot labeled #2321
  • Feb 26 12:38
    PaddyS labeled #2320
  • Feb 26 12:33
    PaddyS unlabeled #2315
  • Feb 26 10:21
    pascalheidmann synchronize #2322
  • Feb 26 10:21
    pascalheidmann edited #2322
  • Feb 26 09:33
    shyim labeled #2322
  • Feb 26 09:27
    pascalheidmann opened #2322
  • Feb 25 15:05
    pascalheidmann opened #2321
  • Feb 25 14:50
    pascalheidmann synchronize #2313
  • Feb 25 14:29
    pascalheidmann opened #2320
Schwanzerfaust
@Schwanzerfaust
It's all hacked anyways, whatever you add it can't make it worse
Husain Fazel
@husainfazel
Hahah, yeah - does Shopware6 make things a bit saner? I’ve never needed to write a plugin and do the amount of hackery I’ve done today just to add two variables to a static page
Schwanzerfaust
@Schwanzerfaust
Don't know
SkaveRat
@SkaveRat

Holy shit, this was an annoying bug to find:
So, the other day I asked if anyone ever had similar problems like me: having 12k+ articles and suddenly new keywords not being added to the search index.

After an annoyingly long debugging session, I now know why new words weren't added to the index anymore.
Turns out, the s_search_keywords table is "updated" with loooooots of INSERT IGNOREs (about 150k per index refresh in our case).
Fun fact: INSERT IGNORE increases the AUTO_INCREMENT counter.
Another fun fact: s_search_keywords.id is unsigned int(11) - but the column s_search_index.keywordId which references this column is a SIGNED int(11).

Result: the index refreshing job is trying to add $newword to both tables, but silently fails because it can't reference the ID 4240317481 with only a signed int(11)

Geert van Wittlaer
@vanWittlaer
A quick one (for thos who know): what is the right path to use if I wanted to extend a Backend template like Backend/ExtJs/backend/search/index.tpl in my 5.2-style plugin? Thx!
A corresponding link to the docs would be fine as well - apologize if I overlooked it
Schwanzerfaust
@Schwanzerfaust
        $container->addCompilerPass(new EventListenerCompilerPass(), PassConfig::TYPE_BEFORE_REMOVING);
        $container->addCompilerPass(new EventSubscriberCompilerPass(), PassConfig::TYPE_BEFORE_REMOVING);
        $container->addCompilerPass(new DoctrineEventSubscriberCompilerPass());
        $container->addCompilerPass(new FormPass());
        $container->addCompilerPass(new AddConstraintValidatorsPass());
        $container->addCompilerPass(new StaticResourcesCompilerPass());
        $container->addCompilerPass(new AddConsoleCommandPass());
        $container->addCompilerPass(new MatcherCompilerPass());
        $container->addCompilerPass(new LegacyApiResourcesPass());
        $container->addCompilerPass(new ConfigureApiResourcesPass(), PassConfig::TYPE_OPTIMIZE, -500);
        $container->addCompilerPass(new RegisterFieldsCompilerPass(), PassConfig::TYPE_BEFORE_OPTIMIZATION, 500);
        $container->addCompilerPass(new RegisterDynamicController());
        $container->addCompilerPass(new RegisterTypeRepositories());
        $container->addCompilerPass(new ControllerCompilerPass());
        $container->addCompilerPass(new RegisterControllerArgumentLocatorsPass('argument_resolver.service', 'shopware.controller'));
        $container->addCompilerPass(new VersionCompilerPass());
How can I add a compiler pass without having to touch Kernel.php
Did anyone say hack it?
Schwanzerfaust
@Schwanzerfaust
Hell yeah!
Eric Lin
@ericln
hi, new here, quick question, does shopware have a build-in webhook feature that pushes changes out to external system? if not what are the recommended way of doing it ? just need a starting point., thanks!
farhaj
@farhajsiddiqui_twitter
after uploading images the image is not display in backend/frontend
Heiner Lohaus
@hlohaus
@Schwanzerfaust a plugin?
or a own kernel
Yannick Fricke
@YannickFricke
@Neologist This channel is only for Shopware 5
Joshua Behrens
@JoshuaBehrens
@YannickFricke he already posted it in platform :thumbsup:
Yannick Fricke
@YannickFricke
@JoshuaBehrens Ye i know. Just as a hint :)
Joshua Behrens
@JoshuaBehrens
ok
Julian
@julianflapper
Hey, how do I disable merchant registration?
Schwanzerfaust
@Schwanzerfaust
@hlohaus How would you add a compiler pass to a plugin
farhaj
@farhajsiddiqui_twitter
after uploading images the image is not display in backend/frontend
Shyim
@shyim
override build addCompilerPass
J-CUBE-E
@J-CUBE-E
Is it technically possible to connect two different ERP systems to one shop?
Timo Helmke
@t2oh4e
Sure...
J-CUBE-E
@J-CUBE-E
what problems can arise and how can you solve this? can you simply install two connectors and run them in parallel?
Uwe Kleinmann
@kleinmann
If no data overlaps exist you probably will see few if any problems. If both systems manage the same data you will have to handle conflicts in some way.
Nesse
@Nesse
Hi, is there a way to translate or change the following urls in shopware?
  • /checkout/cart
  • /checkout/confirm
J-CUBE-E
@J-CUBE-E
@kleinmann
Yes, both systems manage the same data. we have a stock of products that should run syncron on both systems. what problems could arise here?
farhaj
@farhajsiddiqui_twitter
@shyim override build addCompilerPass? kindly tell me what I do
Uwe Kleinmann
@kleinmann
@J-CUBE-E Think about what would happen if both systems try to update or create the same product. That is usually a problem because one may overwrite the other's changes.
Julian
@julianflapper
When pressing cookie preferences, I get this error in the console: this.cookiePermissionPlugin is undefined
What can I do about that? On Shopware 5.6.4
Grzegorz Pietrzak
@Gregoraz
Hi guys. Has anyone idea how to get selected color for each position in order? I'm stucked at point: $orderDetailObj->getArticleDetail()->getConfiguratorOptions(); collection shows empty and I'm sure I've got articles there
with color
Memo Ict
@MemoIct_twitter
On loading categorie I get the folowing error:
[27-Jan-2020 09:43:54 Europe/Berlin] PHP Fatal error: Uncaught Error: Call to a member function getCoverId() on null in /home/memodev/kabeldirect.memodev.nu/engine/Shopware/Bundle/StoreFrontBundle/Service/Core/ListProductService.php:242
Shyim
@shyim
Your product does not have manufacturer
Peter Meijer
@peter-bztrs
So, I have client using the premium Bonus System plugin.
The client has set his shipping cost free above 50 euro.
The customer on the shop orders for 100 euro and uses a voucher wich gives 60 euro discount.
The customer needs to pay 40 euro and additional shipping fee.
Now our client requests that this customer gets free shipping.
How can I arrange this...?
girni
@girni

Hello,

I got a question about custom plugins. Lets say I want to install this plugin into my shopware appliaction:

https://github.com/elkmod/SwagVueStorefront

So I've done the installation process described in this link, but any of the files in git weren't added or changed. Which means if I push the project to remote repo and other developer will checkout it, he won't get the plugin I've installed. Could you explain me what's the idea behind this or how can I install this plugin in the proper way to allow my other team members to get this plugin in their instance of the project?

Peter Meijer
@peter-bztrs
For Shopware 6 questions: https://gitter.im/shopware/platform :-)
Ghost
@ghost~5db2e313d73408ce4fcefd7d
Hi everyone. I'm stuck with the shopping worlds template management. The shop has 2 subshops and all three shops use the same main category, but three different themes. Three template files have been created (index-ex1.tpl, index-ex2.tpl and index-ex3.tpl), and in each only one contains the content of the index.tpl. I understand the trick, but i don't understand how to assign a shopping world to a template. I can't see that option. It's an older version so there is no shop selection...
Ghost
@ghost~5db2e313d73408ce4fcefd7d
Got it, sorry. I spent a whole day without seeing the template dropdown in the layout tab.
bananarne
@bananarne
does shopware have something like a public api, which i can use to get, for example, a picture of a given product id?
bananarne
@bananarne
so i use the usual api? i just won't be able to, say, create a product
but rather give me information about the product in shopware will obey?
Michael Telgmann
@mitelg
@bananarne you have the admin API, where you manage all entities. and you have the saleschannel API, where you read the entities for using them e.g. in the storefront
ups sorry, thought that was a SW6 question :smile:
Michael Stadler
@daMichl

Hi together.
i made some testplugin for SW5 inside the docker container from shopwarelabs: https://github.com/shopwareLabs/shopware-docker. Installed Shopware 5.6 branch from github inside.
plugin works. all is fine. the only thing is: if i install the plugin packaged as a zip (like in the documentation: the folder of the plugin wrapped inside the zip) the plugin will be uploaded and shopware says the uploade was a success, but the plugin does not show up in the plugin manager. i compared the zip with example plugins from the shopware tutorial pages and did not recognize any differences, but the example plugins do work...
does maybe anyone know some problems that can occure even if all seems fine?

heres the plugin as a zip: https://github.com/daMichl/swplugin-mista-test-plugin/releases/tag/a778e05

Joshua Behrens
@JoshuaBehrens
@bananarne @mitelg woopsie now I confused the channels as well. Sorry for weirding things up
Thomas
@alpham8

The contact and product question form is not working. We are getting an exception. Usually it was solved by creating a new form. However, it worked, but not again. So we stuck with broken forms. Here's the exception:

[2020-01-27 17:14:01] core.ERROR: Doctrine\ORM\ORMInvalidArgumentException: A new entity was found through the relationship 'Shopware\Models\Form\Field#form' that was not configured to cascade persist operations for entity: Shopware\Models\Form\Form@0000000063c8d4be0000000026eed938. To solve this issue: Either explicitly call EntityManager#persist() on this unknown entity or configure cascade persist this association in the mapping for example @ManyToOne(..,cascade={"persist"}). If you cannot find out which entity causes the problem implement 'Shopware\Models\Form\Form#__toString()' to get a clue.
in /var/www/vhosts/example.com/httpdocs/vendor/doctrine/orm/lib/Doctrine/ORM/ORMInvalidArgumentException.php:102 Stack trace:
#0 /var/www/vhosts/example.com/httpdocs/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php(3443): Doctrine\ORM\ORMInvalidArgumentException::newEntitiesFoundThroughRelationships(Array)
#1 /var/www/vhosts/example.com/httpdocs/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php(362): Doctrine\ORM\UnitOfWork->assertThatThereAreNoUnintentionallyNonPersistedAssociations()
#2 /var/www/vhosts/example.com/httpdocs/vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(359): Doctrine\ORM\UnitOfWork->commit(NULL)
#3 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Bundle/MailBundle/Service/LogEntryBuilder.php(267): Doctrine\ORM\EntityManager->flush()
#4 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Bundle/MailBundle/Service/LogEntryBuilder.php(240): Shopware\Bundle\MailBundle\Service\LogEntryBuilder->persistContact(Object(Shopware\Models\Mail\Contact))
#5 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Bundle/MailBundle/Service/LogEntryBuilder.php(93): Shopware\Bundle\MailBundle\Service\LogEntryBuilder->assignRecipients(Object(Shopware\Models\Mail\Log), Array)
#6 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Bundle/MailBundle/Service/LogService.php(79): Shopware\Bundle\MailBundle\Service\LogEntryBuilder->build(Object(Enlight_Components_Mail))
#7 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Bundle/MailBundle/DependencyInjection/EventListener/MailSubscriber.php(64): Shopware\Bundle\MailBundle\Service\LogService->log(Object(Enlight_Components_Mail))
#8 /var/www/vhosts/example.com/httpdocs/engine/Library/Enlight/Event/Handler/Default.php(87): Shopware\Bundle\MailBundle\DependencyInjection\EventListener\MailSubscriber->onSendMail(Object(Enlight_Event_EventArgs))
#9 /var/www/vhosts/example.com/httpdocs/engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Event_EventArgs))
#10 /var/www/vhosts/example.com/httpdocs/engine/Library/Enlight/Components/Mail.php(386): Enlight_Event_EventManager->notify('Enlight_Compone...', Object(Enlight_Event_EventArgs))
#11 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Controllers/Frontend/Forms.php(134): Enlight_Components_Mail->send()
#12 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Controllers/Frontend/Forms.php(658): Shopware_Controllers_Frontend_Forms->commitForm()
#13 /var/www/vhosts/example.com/httpdocs/engine/Shopware/Controllers/Frontend/Forms.php(86): Shopware_Controllers_Frontend_Forms->handleFormPost('23')
#14 /var/www/vhosts/example.com/httpdocs/engine/Library/Enlight/Controller/Action.php(192): Shopware_Controllers_Frontend_Forms->indexAction()
#15 /var/www/vhosts/example.com/httpdocs/engine/Library/Enlight/Controller/Dispatcher/Default.php(478): Enlight_Controller_Action->dispatch('indexAction')
#16 /var/www/vhosts/example.com/httpdocs/engine/Library/Enlight/Controller/Front.php(228): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
(and much more, till #27)

Any help would be great. This is a bit urgent

Shopware files are allright