by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    shpasser
    @shpasser
    As for Driver [gae] not supported I don't have a clue. Please try entering the command manually and tell me what happens then. In any case, the gae:setup command was not tested in --no-interaction mode.
    shpasser
    @shpasser
    I was able to run the command as you described it on my local environment(homestead) and I could not see any issues. I think you'll have to look and see what happens in the logs.
    cyannick
    @cyannick
    Yes indeed appname and appname-app are the same. And using --no-interaction works just fine, I use this to automated my build process.
    Geoffry Nagy
    @Geoffzable
    Hi @shpasser, I am a colleague of @cyannick and I cracked the problem but cannot find a suitable solution
    The error "Driver [gae] not supported." is caused by loading the Mail driver when executing the gae:setup command
    We use Laravel's built-in EventServiceProvider to subscribe couple Listeners to Events
    Some events relevant to sending mails, loading "Illuminate\Contracts\Mail\Mailer"
    which seems to happen too soon in the bootstrap
    Probably because it tries to resolve the Mailer contract too soon before any of your changes can happen to the compiled config file
    Maybe it's a lead
    I look forward to your opinion
    shpasser
    @shpasser

    What causes the php artisan gae:setup command to load the mail driver?

    As far as I remember it does not have any requirements of using the Mailer.

    And what would be the reason that the driver name is configured before it is actually can be used?

    I think that something here is done not in a "usual" manner, maybe it is connected to the way the php artisan gae:setup is executed?

    Geoffry Nagy
    @Geoffzable
    Eventserviceprovider is loaded, loading listener classes in the $subscribe array, one of these classes expect Mailer interface on construct. I circumvented the error by removing Mailer from the construct and calling it with the App facade
    Julius Kinuthia
    @juliusknth

    Hi @shpasser, I am getting this error when deploying would you know what the issue might be?

    Error 400: --- begin server output ---
    Max number of files and blobs is 10000.

    shpasser
    @shpasser
    I suppose there is some issue with the upload. According to the message it looks like there is a limit on max number of files that you can upload.
    Julius Kinuthia
    @juliusknth
    Ok thanks, we used a different google account an it worked. so we still are not sure what the issue is
    I will try it again
    cyannick
    @cyannick
    Hi @shpasser how far are you with developing a deployment branch for Lumen 5.2?
    shpasser
    @shpasser
    Wow, I certainly missed this one. Yes I am planning, but the last three months I was very busy with work, so I put my open-source packages on hold. I hope will get back on track shortly...
    codemonkeynorth
    @codemonkeynorth
    hi
    shpasser
    @shpasser
    Hi, I'm probably going to be available for a chat later...
    codemonkeynorth
    @codemonkeynorth
    ok thanks. sleep for me now!...will pop back in in a few hours
    been struggling with guzzle under GAE local Cloud SDK shell.... it doesn't seem to like php://temp when using Curl extension., and crashes PHP when using StreamHandler :S (ie when Curl disabled)
    guzzle/guzzle#1640
    codemonkeynorth
    @codemonkeynorth
    back
    shpasser
    @shpasser
    I think this is not the first attempt to make it work under GAE. I suggest to look through GaeSupportL5 closed issues for more info on the matter.
    codemonkeynorth
    @codemonkeynorth
    hi. what i've ended up doing is having slightly different configs for local & live
    for local I have these enabled...
    extension = "php_curl.dll"
    google_app_engine.disable_readonly_filesystem=1
    curl.cainfo = "C:\cert\ca-bundle.crt"
    that allows Guzzle to work locally
    for live i disable all thouse
    Guzzle then works thru StreamHandler
    oh actually locally i had to make the following change to guzzle as well...
    if(isset($_SERVER['SERVER_SOFTWARE']) && 0 === strpos($_SERVER['SERVER_SOFTWARE'], 'Development/')) {
    $conf[CURLOPT_FILE] = fopen('c://temp/test.txt', 'w+');
    and editing vendor files isnt ideal
    codemonkeynorth
    @codemonkeynorth
    and that's only a fix in as much as it fixes the specific bit i need it to
    Drew Roberts
    @DrewRoberts_twitter
    shpasser, I'm trying to use Cloud9 for development for my Google App Engine website and am having a hard time running the script to setup the database. Can you give some more tips on that?
    Am i using the right variables for my database connection?
    php artisan gae:setup --config --cache-config --bucket="tipoff.appspot.com" --db-socket="/cloudsql/tipoff:us-east1:website34" --db-name="website34" --db-host="102.196.143.21" app-id
    Does that look correct?
    Talip DurmuĊŸ
    @taliptako
    Hello
    Can i run shell commands with app engine standart php env
    if i can not how you install composer dependencies
    Sups87
    @Sups87
    you install composer dependencies before you deploy
    shpasser
    @shpasser
    @DrewRoberts_twitter I think that in order to use the IPv4 access to a database running on GAE you have to register the IP addresses that you would like to access from
    @taliptako as far as I know there is no command line interface on GAE that can used to run composer commands
    shpasser
    @shpasser
    @DrewRoberts_twitter while accessing the GAE DB instance using an IP address --db-name and --db-host should be enough, no need for --db-socket
    mayt-moonboy
    @mayt-moonboy
    Getting "Error 400: This operation isn"t valid for this instance., invalidOperation" when trying to connect to my cloudsql database from standard environment first gen. Any thoughts?
    Daniel Pride
    @DanPride
    I am trying to download my source code. I have found a number of interesting instructions and commands, none of which work. Anybody know a hidden trick for getting my php app download?