Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    James
    @jmshey90
    The Index Single URL option now seems to not work, but Test Extraction works on the same URL
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 do you have a sample url I could use to test this?
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 I'll have to debug this, I'll get back to you in about 3 hours.
    James
    @jmshey90
    Thank you
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 not sure what exactly was wrong with indexing this page, we'll take another look next week, seems to have been a temporary issue with one of our servers, this should work as expected now. Regarding the reordering filter options bug, we've got a fix for this and will deploy it latest by Tuesday next week.
    James
    @jmshey90
    Thanks, it is working now (index)
    bobhrds
    @bobhrds

    @bobhrds looks like the mobile search box isn't properly connected to our search, can you try changing the search box selector to input[name="s"] in the Wordpress Plugin Configuration? What's currently displayed on mobile are your native wordpress search results.

    @JVankat Do you mean here, in the Configuration Editor?
    {
    "siteId": "al-anon.org",
    "showErrors": false,
    "searchBox": {
    "selector": "#ss360-trigger",
    "placeholder": "Search",
    "searchButtonLabel": "Search"
    },
    "layout": {
    "mobile": {
    "showImages": false,
    "showDataPoints": false,
    "showUrl": true,
    "type": "grid"
    },
    "desktop": {
    "type": "grid",
    "showImages": false,
    "showDataPoints": false,
    "showUrl": true,
    "gridColsLg": 1
    }
    },

    Jaroslav Vaňkát
    @JVankat
    @bobhrds yes, that's one of the options, otherwise you can simply go to the Basic Configuration page and use the Search Box Selector input: https://snipboard.io/e9RDjH.jpg
    bobhrds
    @bobhrds
    Thank you!
    bobhrds
    @bobhrds
    @JVankat I've made the change but search results on mobile do not appear similarly to desktop. Any other thoughts please and thank you again for assistance!
    Jaroslav Vaňkát
    @JVankat

    @bobhrds what happens for me on your site (I had to reload using ctrl+f5 to clear the cache, btw), is the native search form is submitted, so on mobile our search results pop up for a short while and then you get redirected to the native wp search, the following line of code under Custom Callbacks > Init Callback should do it:

    window.sxQuery('.fusion-search-form').on('submit', function(e) {e.preventDefault(); e.stopPropagation();});

    https://snipboard.io/B1CiNh.jpg

    James
    @jmshey90
    Are you going to add the ability to reorder page boosting? Or does it sort by highest number first?
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 I'm not sure I understand what exactly you mean. Do you mean reordering the list of patterns, so if a page matches multiple ones, then you could prioritize which one gets used?
    James
    @jmshey90
    Yes
    Also, in the old panel, the Page Boost would appear when you indexed a single URL, so could see if the regex was working. I can't seem to see that anymore, so not sure if I've messed up my regex or its no longer viewable?
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 okay, the order is what's important, not the priority number. We're not planning on making this list sortable, but let me take a note and we'll talk about this. And we just don't show the value in the new interface, but we'll add it soon, thanks for noticing this!
    James
    @jmshey90

    Thanks, I only have a few page boosting options atm, so I'll just manually change them.

    I think the new control panel is really great btw!

    Jaroslav Vaňkát
    @JVankat
    Glad to hear that, and appreciate all the feedback and your patience!
    James
    @jmshey90
    I see for Content Groups you can override the xpath settings for image/content/title etc... are there any plans to allow overriding of the Search Snippet Xpath as well? I'm using the default meta description, but would be handy on select groups to extract something else for the search descriptions.
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 we currently aren't planning on adding this option, but let me put it onto the backlog. Currently the solution would be having multiple content group specific xpaths in the search snippet xpath (given you can distinguish between content groups based on xpaths).
    James
    @jmshey90

    @JVankat I didn't realise xpaths could accept multiple inputs! Handy to know. Its working now.

    I had another question about popular searches/full layout. On our current search (attached), we essentially mimic your fullscreen mode with an overlay that contains a search inbot/button. However, on ours, by default we should popular searches and some promo blocks. I was wondering the feasability of doing something with SS360?

    I see that you have suggestions that pick up popular searches, but any way of getting them into the fullscreen mode? Or perhaps even just a static custom HTML panel that disappears once someone starts searching?

    Jaroslav Vaňkát
    @JVankat

    @jmshey90 I see what you mean, that's definitely something we'll focus on in the future, but currently the only solution I can think of would be using the init callback to inject the content to the search layer (=static HTML).

    E.g. ss360Config.callbacks.init = function(){sxQuery('#ss360-layer').html('<span>My Banner</span>');} (this might be slightly different for layover/fullscreen).

    Would this work for you?

    James
    @jmshey90
    I'll have a go, but sounds like something we'd be happy with =)
    Jaroslav Vaňkát
    @JVankat
    Perfect, just let me know if you need any help with this.
    Jaroslav Vaňkát
    @JVankat
    @jmshey90 just fyi, the filter options reordering should now work.
    James
    @jmshey90
    Thanks, its working for me now (filter reordering)
    James
    @jmshey90
    @JVankat is there anyway to delete the _test accounts in the new control panel?
    James
    @jmshey90
    I'm also getting Client Errors for everything and its refusing to index our site 'www.eastriding.gov.uk'
    Olesya
    @lesyaelf_gitlab
    hi @jmshey90, Jaro's off today so I'll jump in to help. Your _test account should be deactivated soon - could you tell us when you agreed to fully move your account to the new interface?
    James
    @jmshey90
    May 6
    Olesya
    @lesyaelf_gitlab
    We're also checking what might've started causing the indexing errors. I see that the response code is 499 in which case it's always good to whitelist our Crawler IPs. Please check this how-to article
    James
    @jmshey90
    I contacted our IT department with the list of IPs and they said none where blocked behind our firewall
    Can see a request being let through from: 88.99.162.232 for example
    Olesya
    @lesyaelf_gitlab
    Good to know, thanks. This URL seems to be problematic, correct? Managed to manually reindex it just now - but it's giving me a Proxy Error and here's what I see when I open it: https://snipboard.io/I2v9Lq.jpg
    James
    @jmshey90
    Thanks, I think I know what that is :laughing: we're using 2 domains for the search, didn't think to check the 2nd one! 🤦‍♂️
    Olesya
    @lesyaelf_gitlab
    I hope that's the solution then! If you keep getting indexing errors, let us know and we'll take a closer look on our end
    James
    @jmshey90
    @lesyaelf_gitlab its still not working

    I get the following error when I try to index a single page:

    The document could not be indexed, has <meta name='robots' content='noindex' />, points to a different canonical URL, or is a cloaked link.

    Olesya
    @lesyaelf_gitlab
    @jmshey90 I've just successfully re-indexed the top 3 URLs - is it still not working for you?
    James
    @jmshey90
    It is working for me now, not sure why it stopped! Thanks for checking 🙂
    Olesya
    @lesyaelf_gitlab
    Thanks for the patience and sorry for the trouble!
    Ken Kuehnel
    @kkuehnel_twitter
    I would like to test out the API feature before buying. Looks like this feature is not included in trial. Any options available to me?
    Jaroslav Vaňkát
    @JVankat
    Hi @kkuehnel_twitter can you PM your siteId, I will enable this for you.
    tomesposito92
    @tomesposito92

    I have a question for showing results. If I call window.SS360.showResults('term') twice for two different ID's - is there a way to combine the total number of requests?
    Example code

    window.SS360.showResults('term');
    window.SS360.setSiteID('differentID');
    window.SS360.showResults('term');

    This code works, however my 'Found 1 search results for "term"' gets overwritten based on the most recent showResults - So if ID1 returns 1 results and ID2 returns 0 results, one item shows in my search, but it says we found 0 search results.

    I realize this is a niche question, but is there a way to capture the totalResults on a showResults call and store that for use later?
    Jaroslav Vaňkát
    @JVankat
    Hi @tomesposito92, I'll send you a PM.
    Jaroslav Vaňkát
    @JVankat
    Hey @kkuehnel_twitter - I'll send you a PM.
    Ken Kuehnel
    @kkuehnel_twitter
    For a site with 1,000 pages, how long (generally) should the indexing take? My control panel's been stuck at 99% progress for last 10 minutes. Guessing it's not going to complete?
    Jaroslav Vaňkát
    @JVankat
    @kkuehnel_twitter in your case this looks like this is due to the crawler running for the first time --> that's where we don't know what number of pages is 100%, so it might be at 99% for a while, but I see we're still indexing new pages, so this should be fine. Otherwise indexing 1k pages shouldn't take more than a few minutes, depends mainly on the server response times.