Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    psilo909
    @psilo909
    hat das plugin global udp an?
    Tom Bombadil
    @Tom-Bom-badil
    ja - pulgin.yaml:
    nw:
        class_name: Network
        class_path: plugins.network
        ip: 0.0.0.0
        port: 2423
        http: 2422
        tcp: 'yes'
        udp: 'yes'
        udp_acl: '*'
    Mal den globalen Listener auf einen anderen Port ändern?
    psilo909
    @psilo909
    das geht bei mir:
    echo "sh.knx.gf.office.light(0)" | nc -uw 1 192.168.178.100 3456
    licht geht aus
    Tom Bombadil
    @Tom-Bom-badil
    Ja, bis vorgestern wäre das bei mir auch gegangen ;)
    psilo909
    @psilo909
    teste das mal via shell
    und erstmal nur mit nem int
    Tom Bombadil
    @Tom-Bom-badil
    bin dabei
    psilo909
    @psilo909
    jetzt habe ich ne 1.2 in ein foo item geschrieben
    echo "sh.testcam(1.2)" | nc -uw 1 192.168.178.100 3456
    hier nochmal meine plugin konfig
    nw:
        class_name: Network
        class_path: plugins.network
        ip: 192.168.178.100
        port: 9999
        tcp: 'yes'
        # tcp_acl= 127.0.0.1 | 10.0.0.150
        udp: 'yes'
        http: 8888
    ich hab dein problem glaube ich
    du hast im plugin den gleichen port definiert
    mglw beisst sich das
    weil da jetzt der generische udp listener laeuft
    der genauso wie der tcp listener reagiert
    du darfst nur das item auf dem port haben
    port: 2423
    probier mal nen anderen
    das müsste aber schon lange so gewesen sein
    Tom Bombadil
    @Tom-Bom-badil
    Nope, ist wie gesagt neu. Ich probier gleich einen anderen Port. Kommandozeile hat nichts gebracht:
    2019-05-13 19:38:20 INFO plugins.network Ignoring input sh.klima.schuppen1.Calculations.Dewpoint(0). Format not recognized.
    psilo909
    @psilo909
    das ist es zu 90%
    vielleicht hat die globale udp konfig bisher nie gezogen
    warum auch immer
    Tom Bombadil
    @Tom-Bom-badil
    sec, bin umkonfigurieren
    psilo909
    @psilo909
    jetzt zieht sie und macht dir den port dicht
    für das item
    der port kann nur das eine oder das andere ;)
    Tom Bombadil
    @Tom-Bom-badil
    nw_udp_listen: 9999 auf dem Receiver-Item ... starte neu und konfiguriere den ESP um
    psilo909
    @psilo909
    teste erstmal via shell ;)
    wenn das geht muss auch der esp gehen
    neustart via admin interface ist sehr zu empfehlen ;)
    Tom Bombadil
    @Tom-Bom-badil
    ;)
    ok, sieht besser aus, aber jetzt kommt ein acl-Problem ... mus ich wohl noch anpassen
    2019-05-13  19:42:51 DEBUG    plugins.network   UDPDispatcher: incoming connection from 192.168.178.61:1961 to 0.0.0.0:9999
    2019-05-13  19:42:51 ERROR    plugins.network   Generic network acl doesn't permit triggering from 192.168.178.61.
    psilo909
    @psilo909
    wie gesagt ich weiss nicht ob der * korrekt ist
    im acl?!
    Tom Bombadil
    @Tom-Bom-badil
    Komisch - eigetlich sollte er alle IP's akzeptieren, in der Doku steht:
    psilo909
    @psilo909
    ich hab garkein acl
    Tom Bombadil
    @Tom-Bom-badil
        item1:
            type: str
            # bind to 0.0.0.0:7777 (every IP address)
            nw_tcp_listen: 7777
    psilo909
    @psilo909
    du setzt aber udp_acl: '*'
    wobei das der default ist
    laut init
    Tom Bombadil
    @Tom-Bom-badil
    aber nur in der globalen Config - nicht am Item:
    psilo909
    @psilo909
    evtl parsed yaml den * seltsam