Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Jeff Kilbride
    @jeff-kilbride
    Somebody in the slack channel helped me out... the docker instance (host) just needed to be restarted.
    sgfgdf
    @sgfgdf_twitter
    hello, guys! i'm trying to install this package https://github.com/sgerrand/alpine-pkg-php5-mongo, but i got this error "ERROR: php5-mongo-1.6.14-r0.apk: IO ERROR". any suggestions?
    KillerSpaz
    @killerspaz
    @sgfgdf_twitter see if this helps gliderlabs/docker-alpine#155
    G. Richard Bellamy
    @rbellamy
    @smebberson ping
    Allan Garcia
    @allangarcia
    Hi, I just want to say GREAT WORK!!! I'll change my actual containers (phusion/baseimage) for this!
    Ruslan
    @disharmonized
    hi guys
    i have question about s6-overlay
    i have container, contains nginx and php-fpm
    i want to collect logs from them
    and i need to be able recognize what is what
    i need to add prefixes in logs for that
    can i do that using s6?
    or i should add prefixes in nginx config and php-fpm config?
    Scott Mebberson
    @smebberson
    @sgfgdf_twitter, did you get your issue sorted?
    Thanks @allangarcia, glad you like them.
    Scott Mebberson
    @smebberson
    @disharmonized, are you using the s6 log functionality, or just standard log functionality from nginx and php-fpm? If so, just add the prefixes as required...
    Orlando Pereira
    @Orpere
    hi
    how can i set env on alpine ?
    export don't work
    any one can help?
    Scott Mebberson
    @smebberson
    I'll get you an example...
    ping @Orpere
    Serge
    @bluetazmanian
    @smebberson Have you ever been able to install HHVM from Facebook in Alpine. I’ve tried to no success
    Scott Mebberson
    @smebberson
    @bluetazmanian, I haven't even tried actually to be honest. After a quick Google, there doesn't seem to be anything out there either.
    Serge
    @bluetazmanian
    @smebberson I know, I've actually got very far in having it but a few issues towards the end. I could share my private repos wi
    ...with you.
    Shashwat shagun
    @Shashwatsh
    Hi
    / # ping google.com
    ping: bad address 'google.com'
    / # ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    64 bytes from 8.8.8.8: seq=0 ttl=57 time=49.087 ms
    64 bytes from 8.8.8.8: seq=1 ttl=57 time=57.769 ms
    64 bytes from 8.8.8.8: seq=2 ttl=57 time=55.724 ms
    anyone knows how to solve this/
    ?*
    AndersFluur
    @AndersFluur
    Is it possible to seamlessly add support for ARM in docker-alpine? I forked the repo and modified alpine-base to specify FROM arm64v8/alpine and curl for aarch64. Works! But I need 32 bit arm as well. Must be a better way ?
    Twisted Pair in my Hair
    @tpimh

    Hi guys! My question is not about docker, but I think you still may help me or at least recommend where I can post the question so it is noticed. I'm trying to install Alpine in PRoot (in order to get it working with no superuser privileges).
    Here are the commands:

    $ mkdir alpine
    $ cp apk.static alpine
    $ ./proot -S alpine /apk.static -X http://dl-cdn.alpinelinux.org/alpine/edge/main -U --allow-untrusted --initdb add alpine-base
    fetch http://dl-cdn.alpinelinux.org/alpine/edge/main/x86_64/APKINDEX.tar.gz
    (1/16) Installing musl (1.1.16-r15)
    (2/16) Installing busybox (1.27.0-r2)
    Executing busybox-1.27.0-r2.post-install
    ERROR: busybox-1.27.0-r2.post-install: script exited with error 127
    (3/16) Installing alpine-baselayout (3.0.4-r0)
    Executing alpine-baselayout-3.0.4-r0.pre-install
    ERROR: alpine-baselayout-3.0.4-r0.pre-install: script exited with error 127
    Executing alpine-baselayout-3.0.4-r0.post-install
    ERROR: alpine-baselayout-3.0.4-r0.post-install: script exited with error 127
    (4/16) Installing openrc (0.24.1-r2)
    Executing openrc-0.24.1-r2.post-install
    ERROR: openrc-0.24.1-r2.post-install: script exited with error 127
    (5/16) Installing alpine-conf (3.6.0-r0)
    (6/16) Installing libressl2.5-libcrypto (2.5.5-r0)
    (7/16) Installing libressl2.5-libssl (2.5.5-r0)
    (8/16) Installing zlib (1.2.11-r0)
    (9/16) Installing apk-tools (2.7.2-r0)
    (10/16) Installing busybox-suid (1.27.0-r2)
    (11/16) Installing busybox-initscripts (3.1-r1)
    Executing busybox-initscripts-3.1-r1.post-install
    ERROR: busybox-initscripts-3.1-r1.post-install: script exited with error 127
    (12/16) Installing scanelf (1.2.2-r0)
    (13/16) Installing musl-utils (1.1.16-r15)
    (14/16) Installing libc-utils (0.7.1-r0)
    (15/16) Installing alpine-keys (2.1-r1)
    (16/16) Installing alpine-base (3.6.0-r0)
    Executing busybox-1.27.0-r2.trigger
    ERROR: busybox-1.27.0-r2.trigger: script exited with error 127
    4 errors; 6 MiB in 16 packages

    4 errors in scripts. The scripts look okay and I can run them. I don't know why does it fail. How can I debug the installation? I've been trying rebuilding the packages adding set -x to the scripts, but I couldn't install my versions because of signature problems. And I doubt that it will help because the scripts probably just fail to run. Is there a simpler way to debug it? It runs okay with root privileges.

    Slim Hmidi
    @slim-hmidi
    hi
    Jemli Fathi
    @jemliF
    hi

    I have the following Dockerfile:
    `FROM java:8-jdk-alpine
    MAINTAINER jemlifathi

    RUN apk update && apk --no-cache --update add maven

    COPY ./ /home/forms/
    WORKDIR /home/forms
    RUN mvn clean install

    EXPOSE 8080
    ENTRYPOINT java -jar ./target/forms-0.0.1.jar`

    I encountered this error while building my image:
    ERROR: unsatisfiable constraints: maven (missing): required by: world[maven] The command '/bin/sh -c apk update && apk --no-cache --update add maven' returned a non-zero code: 1
    Need help please
    Slim Hmidi
    @slim-hmidi

    @jemliF add this line :

    RUN echo "http://dl-cdn.alpinelinux.org/alpine/edge/community" >> /etc/apk/repositories

    before :

    RUN apk update && apk --no-cache --update add maven
    Nerio Rincon
    @n3rio
    @n3rio
    hi..
    had problems with alpine, python3.6, selenium, it seems that firefox-esr won't work in alpine container
    Kay van Bree
    @kayvanbree

    I'm trying to install nodejs on an nginx alpine Docker container

    echo "Installing node to run javascript"
    apk update
    apk add nodejs
    sync
    echo "Installed NodeJS"
    node -v`

    However I keep getting a version lower than I need
    How do I install node v8+?

    Alexander Remie
    @rmi7
    hi, I’ve got an alpine container in which I need to run an xxd revert command: xxd -r -ps, but the xxd inside alpine seems to be different from regular xxd, it has no -r revert option. how can i install an xxd version which does have the -r revert option?
    sgfgdf
    @sgfgdf_twitter
    Hi, guys! I'm trying to create an image that runs as non-root user and also mount current project directory to the container. The problem is that if I want to create files from the container I encounter problems with the permissions. The user ids of the host and container are different.
    Idan Adar
    @IdanAdar
    Hi. I've pulled the latest docker:stable-dind, and it seems to have buested our pipeline. Looks like the version of Alpine used installs Node 10.14 while we require 8.14; How can I either revert back to the previous docker image that used the Alpine version which provides that, or pin this node version?
    Idan Adar
    @IdanAdar
    Anyone? ^
    BartosMosch
    @BartosMosch
    Hi all, I have following problem. I have an alpine python 3.6 docker image with a conda env preinstalled and a private hosted conda repo. I'm trying to install opencv but facing and issue regarding jasper. Conda shows an UnsatisfiableError for Jasper -> libgcc-ng=7.2.0 which is strange because the same Jasper version on conda-forge states that Jasper needs libgcc-ng >= 7.2.0.