Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 14 11:43
    bourgeoa labeled #60
  • Nov 05 13:16
    bourgeoa closed #59
  • Nov 03 21:03

    bourgeoa on main

    Update README.md Update README.md Update README.md suggestion Co… and 1 more (compare)

  • Nov 03 21:03
    bourgeoa closed #60
  • Nov 03 20:59
    bourgeoa assigned #60
  • Oct 27 13:54
    bourgeoa commented #60
  • Oct 21 17:26
    TallTed commented #60
  • Oct 21 16:45
    bourgeoa commented #60
  • Oct 21 14:09
    TallTed commented #60
  • Oct 21 13:57
    jeff-zucker commented #60
  • Oct 21 13:52
    TallTed commented #60
  • Oct 21 13:51
    TallTed commented #60
  • Oct 21 13:37
    jeff-zucker commented #60
  • Oct 21 09:48
    bourgeoa commented #60
  • Oct 21 07:32
    bourgeoa commented #59
  • Oct 20 23:21
    jeff-zucker commented #60
  • Oct 20 22:56
    jeff-zucker commented #58
  • Oct 20 21:18
    jeff-zucker commented #59
  • Oct 20 20:22
    jeff-zucker commented #59
  • Oct 20 19:39
    jeff-zucker commented #59
Alain Bourgeois
@bourgeoa
@justinwb
In my doc i have
  • node-solid-server installation
    • pm2 script : pm2 start /usr/local/bin -- start
      exec cwd : root/solid-config
    • /usr/local/bin --> /lib/node_modules/solid-server/bin/solid
    • /solid-config
      config.json
      config/templates and views
    • update process
      cd usr/local/lib # check that it as not changed
      pm2 stop solid # the pm2 instance should be solid
      npm install solid-server # npm is not installed globally actually
         # if it where the global param would install in folder /lib (to check npm root)
      cd /solid-config # check there are no changes in folder config/templates and views
      pm2 restart solid
Alain Bourgeois
@bourgeoa
I need help. I do not succeed to start solidcommunity.net
Back in one hour
Matthias Evering
@ewingson
I'm nearly sure I can not help cause I didn't use pm2, but just in case, my normal way of install is https://gist.github.com/ewingson/c6e97a996aa51eac9f7fd1b7eaf14dc4
it's using systemctl
Michiel de Jong
@michielbdejong
I think it's /root/solid-config, not /solid-config
Alain Bourgeois
@bourgeoa
https://solidcommunity.net has been restarted
root@solidcommunity:/usr/local/bin# pm2 start solid -- start --config-file ~/solid-config/config.json
Michiel de Jong
@michielbdejong
i'll stop the screen?
Alain Bourgeois
@bourgeoa
Which screen
Michiel de Jong
@michielbdejong
I had started the process inside a screen
but closed that again now
A screen is a terminal sessions that stays running on a server when you detach from it. Try man screen.
I ran pm2 save, shall we try rebooting the server as a test?
Alain Bourgeois
@bourgeoa
@michielbdejong @justinwb Thanks for the help. I never did a new pm2 solid before.
Michiel de Jong
@michielbdejong
is it ok if I reboot the server now, as a test?
Alain Bourgeois
@bourgeoa
yes
Michiel de Jong
@michielbdejong
ok, test succeeded!
Alain Bourgeois
@bourgeoa
The problem is that pm2 lost all session this morning early. I don't now why.
I strarted a new test server yesterday with no problem.
Michiel de Jong
@michielbdejong
maybe it lost the apps because the server rebooted, and pm2 config was not persisted properly.
we now tested that it comes up ok after a reboot
Alain Bourgeois
@bourgeoa
I suppose pm2 save was missing then. How do you reboot the server ? I only use to pm2 restart solid or test-solid
Michiel de Jong
@michielbdejong
To reboot the server I use shutdown -r now
(reboot at the OS level)
Matthias Evering
@ewingson
@michielbdejong @bourgeoa @justinwb good job all of you...
Alain Bourgeois
@bourgeoa
Following today's difficulty here is a small documentation on the server setup and management
https://github.com/solid/solidcommunity.net/wiki
Alain Bourgeois
@bourgeoa
solidcommunity.net is going down a few minutes for update to v5.6.8
Alain Bourgeois
@bourgeoa
https://solidcommunity.net upgraded to v5.6.8 using mashlib v1.7.4 (dataBrowser can edit/create json and jsonld)
Michiel de Jong
@michielbdejong
hm, seems the sudo password I used yesterday evening isn' t working today, did anything change?
Michiel de Jong
@michielbdejong
@bourgeoa can you still log in? not sure what i'm doing wrong but apparently i can't type my password today :)
maybe you can remove the trailing slash on line 2 of /mnt/volume_lon1_01/.db/oidc/op/provider.json and hit pm2 restart solid
Michiel de Jong
@michielbdejong
ah nm, found the right password now.
ok, server is back to how it was before last night. sorry for the hassle
Alain Bourgeois
@bourgeoa
For information : test server is actually running an alpha version of Dpop auth-upgrade of mashlib/dataBowser. For mor information see solid/solidos#38
Alain Bourgeois
@bourgeoa
@justinwb certificat renewal is due before October 5th. Can you do it ?
If you can get a gandi APIKEY I could try to automate with https://github.com/obynio/certbot-plugin-gandi#wildcard-certificates.
Justin Bingham
@justinwb
@bourgeoa certificate is renewed :white_check_mark:
messaged you directly on the automation moving forward
Matthias Evering
@ewingson
@bourgeoa @justinwb will we need a dedicated cert for the test server ?
Bildschirmfoto_2021-10-03_12-19-53.png
Alain Bourgeois
@bourgeoa
@ewingson just needed a restart after updating the cert
Matthias Evering
@ewingson
cool then
Matthias Evering
@ewingson
referencing https://solidcommunity.net:8443/mashlib.js for a test works fine
Bildschirmfoto_2021-10-03_16-26-18.png
Matthias Evering
@ewingson
^^ oops this was meant for solidos room
Alain Bourgeois
@bourgeoa
https://solicommunity.net is stopping for upgarde. Time as short as possible.
There is a small migration ongoing see https://forum.solidproject.org/t/major-updates-to-solidos-nss-and-solidcommunity-net/4781
Alain Bourgeois
@bourgeoa
https://solidcommunity.net has been restarted running NSS@5.6.12 with new authorization.
Sarven Capadisli
@csarven
I can't seem to signin after selecting solidcommunity.net as provider. It redirects... and blanks out at https://csarven.solidcommunity.net/?code=.....
Seeing 400 POST on /token
Sarven Capadisli
@csarven
Seems to be back in action.
Alain Bourgeois
@bourgeoa
https://solidcommunity.net is stopping a few minutes for upgrade
Alain Bourgeois
@bourgeoa
https://solidcommunity.net is back running