These are chat archives for spring-cloud/spring-cloud

25th
Jul 2016
ccit-spence
@ccit-spence
Jul 25 2016 06:31
I am working on a cloud app so not sure if it is cloud related. If I have management.security.enabled = false in my properties file I get a class not found exception complaing about spring security.
If I remove the line from the properties file the error goes away
This project does not have spring security enabled
Seems to be a known bug, can’t tell if it is fixed or not
Dave Syer
@dsyer
Jul 25 2016 06:35
It's a feature. I don't think it can be fixed.
ccit-spence
@ccit-spence
Jul 25 2016 06:36
ok, interesting feature. just making sure I wasn’t doing something wroung
Stéphane Nicoll
@snicoll
Jul 25 2016 06:36
there is an issue in the tracker about that
Dave Syer
@dsyer
Jul 25 2016 06:36
It's not spring
boot
I mean "it is spring boot"
Stéphane Nicoll
@snicoll
Jul 25 2016 06:37
the management.security bit lazily creates an object that has an import on a security class.
So yes, there is an issue in the spring boot tracker sorry
spring-projects/spring-boot#3888
ccit-spence
@ccit-spence
Jul 25 2016 06:38
ok, I saw several issues related in different ways. Wasn’t clear if it was thought to be fixed. Thanks for the quick feedback!
It is in the end not a big deal since this app will have spring security enabled
was just doing some testing without it
Stevo Slavić
@sslavic
Jul 25 2016 12:34
hello
couldn't find some docs what are the differences between zuul 1.1.x and 1.2.x; are you aware of any that are preventing upgrade?
Marcos Barbero
@marcosbarbero
Jul 25 2016 18:05
@sslavic maybe there’s not a changelog regarding those version but you can check out the commits on repository:
David Steiman
@xetys
Jul 25 2016 18:53
@dsyer i had to stop my work on the feign issue i was talking about two weeks ago
but here it is now: spring-cloud/spring-cloud-netflix#1211
i hope that helps to figure out, what's wrong
Dave Syer
@dsyer
Jul 25 2016 18:55
Thanks
turick
@turick
Jul 25 2016 20:22
I just set up spring security and spring session on both my zuul edge service and a backend service. It's a very simple security config using in memory auth provider. When I try to hit my backend service through zuul, it prompts me for my username and password, then forwards me to my backend service, but to the root context of that service... it loses the rest of the path and url parameters I originally entered. Has anybody experienced this before?
In a previous life I had the same setup working with a preauthentication filter using a header token. I'm wondering if it's just a natural consequence of using basic auth and relying on spring security to provide the login form?