These are chat archives for spring-cloud/spring-cloud

1st
Mar 2017
Josh Fix
@joshfix
Mar 01 2017 16:45
i have an zuul service using hystrix-stream to send metrics to a turbine service over kafka. on the dashboard, some of the circuits appear as expected when traffic is routed over them. others glitch between showing the expected values and 0 for all fields. the graphs also display very oddly. another thing i noticed... any of the circuits that are having the issue only display about 50% of the length of the request rate line.
curious if anybody has seen or experienced this before. here is a screenshot to illustrate a circuit that is working and a circuit that is "glitching"
i happened to grab that screenshot when the bcs-edge.bcs-basemap circuit flashed all the median/mean/90th etc values to 0
i'm seeing similar things for other (non-zuul) services/circuits. some behave normally and some display the glitchy behavior
Spencer Gibb
@spencergibb
Mar 01 2017 16:48
I haven't
Josh Fix
@joshfix
Mar 01 2017 16:48
i'm running boot v1.5.1, spring cloud Camden.SR5 on all services. the turbine service is running 1.2.5.RELEASE
Marcelo Balloni
@mballoni
Mar 01 2017 16:49
@joshfix Do you have more than one node ? I had a similar issue when my spring applications were without an id. This way the hystrix stream couldn't diferentiate the events and agregate it
I've found two ways to fix this: set up a different id for each node (a random number should do it) or disable the application id from the hystrix events
Josh Fix
@joshfix
Mar 01 2017 16:50
ha! that is it... the instances that are doing that have more than one instance running
wow can't believe i didn't think of that... thank you very much
Marcelo Balloni
@mballoni
Mar 01 2017 16:51
You welcome, it look me a while to figure it out to
Josh Fix
@joshfix
Mar 01 2017 17:19
thanks again @mballoni - the solution was to set hystrix.stream.queue.send-id=false
Johannes Edmeier
@joshiste
Mar 01 2017 20:09
I guess the work to get cloud built against boot 2.0 will start after the Dalston Release with Edgware?
Dave Syer
@dsyer
Mar 01 2017 22:16
Sort of. Edgware is currently planned to be before Spring Boot 2.0
So 2.0 support will only come with Finchley.