These are chat archives for spring-cloud/spring-cloud

23rd
Jan 2018
Samkit Shah
@shsamkit
Jan 23 2018 02:49
Hello, I think the quick start pom here - http://projects.spring.io/spring-cloud/ has some version mismatch
spring-boot-starter-parent - 2.0.0.M6 and Finchley.M5, are they compatible?
Dave Syer
@dsyer
Jan 23 2018 08:54
No. Finchley.M5 is based on Boot 2.0.0.M7.
So that's a bug
Thanks
Dave Syer
@dsyer
Jan 23 2018 09:03
I fixed it in github. I think we're waiting for caches to expire now.
Works for me now
Matt Benson
@mbenson
Jan 23 2018 22:28
hi, I'm trying to declare dependencies between @RefreshScope beans. It feels somehow wrong to depend on scopedTarget.beanName. Is that my only option?
Tyler Thrailkill
@snowe2010
Jan 23 2018 22:47
anyone know what dependency I am missing to get this error?
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [io.fabric8.kubernetes.client.KubernetesClient] found for dependency [io.fabric8.kubernetes.client.KubernetesClient]: expected at least 1 bean which qualifies as autowire candidate for this dependency.
pom has:

        <dependency>
            <groupId>com.squareup.okhttp3</groupId>
            <artifactId>okhttp</artifactId>
            <version>3.6.0</version>
        </dependency>
        <dependency>
            <groupId>org.springframework.cloud</groupId>
            <artifactId>spring-cloud-starter-kubernetes</artifactId>
            <version>0.2.0.RELEASE</version>
            <exclusions>
                <exclusion>
                    <groupId>com.squareup.okhttp3</groupId>
                    <artifactId>okhttp3</artifactId>
                </exclusion>
            </exclusions>
        </dependency>

        <dependency>
            <groupId>io.fabric8</groupId>
            <artifactId>kubernetes-client</artifactId>
            <version>3.1.8</version>
        </dependency>
        <dependency>
            <groupId>io.fabric8</groupId>
            <artifactId>kubernetes-model</artifactId>
            <version>2.0.8</version>
        </dependency>
Tyler Thrailkill
@snowe2010
Jan 23 2018 22:55
seems pretty self explanatory, but including the io.fabric8 client dependency did not fix the error...