These are chat archives for spyder-ide/public

2nd
Jun 2017
rafasc
@rafasc
Jun 02 2017 14:44
can anyone confirm me if spyder3 is broken under archlinux? No module named 'PyQt4.QtWebKit'.
rafasc
@rafasc
Jun 02 2017 15:25
well, Looks like spyder prioritizes python-pyqt4 over python-pyqt5 if both are installed.
Joseph Martinot-Lagarde
@Nodd
Jun 02 2017 15:56
Yes I just had the same problem. I saw nothing special in qtpy, does spyder do something special ?
Carlos Cordoba
@ccordoba12
Jun 02 2017 16:47
They probably removed PyQt4.QtWebKit for security reasons, the same as Debian
So you need to update to Qt5
rafasc
@rafasc
Jun 02 2017 16:48
I have both of them installed.
But spyder is using qt4 by default.
rafasc
@rafasc
Jun 02 2017 17:18
something is happening to the os.environ['QT_API']. Even though it's set to pyqt5 at the start.
it is getting rewritten somewhere.
Joseph Martinot-Lagarde
@Nodd
Jun 02 2017 17:24
Same here, setting QT_API to pyqt5 changes nothing.
rafasc
@rafasc
Jun 02 2017 18:26
I dug a bit more, and looks like this import is failing from PyQt5.Qt import PYQT_VERSION_STR as PYQT_VERSION on init.py (qtpy module)
rafasc
@rafasc
Jun 02 2017 19:36
this was harder than I expected.