These are chat archives for spyder-ide/public

7th
Dec 2018
somsanithx
@somsanithx
Dec 07 2018 00:45
Hi
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 01:00
Hello. How can we help you with Spyder?
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:29
Hi
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 07:30
Hello. Do you have a question related to Spyder?
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:30
I am having version Spyder 3.2.6
context help is not working
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 07:31
That version is nearly a full year old. Please upgrade to the current version, 3.3.2, with e.g. conda update spyder or (if you don't have Anaconda) pip install -U spyder. Also, you can try updating to newer versions of the relevant packages (rope, jedi, parso).
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:33
sorry I am new for the this environment. Can you guide me where can I type "conda update spyder"
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 07:33
Do you have Anaconda? What OS are you using?
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:33
MAC
Yes I have AnaConda
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 07:34
*Mac *Anaconda
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:34
yes
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 07:35
Then you should be able to just do so from the normal Terminal. You might need to type source activate base first but it should work without that.
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:36
it shows. "# All requested packages already installed."
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 07:41
Anaconda shows latest version of spyder 3.2.6
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 07:50
This is likely because some other old package you have installed is pinning the Spyder version to 3.2.6. Run conda install spyder=3.3.2 to find out which package(s) are causing the problem. If you can't upgrade or remove those old/problem packages, then the best approach is to create a fresh environment just for Spyder, which is much easier with Spyder >3.3.0 since you can use one Spyder instance to work with any Python environment on your machine so long as it has the spyder-kernels package installed.
Specifically, I'd also recommend running conda update condaand then conda install anaconda=5.3.0 first, then conda install spyder=3.3.2 to get the rest of your environment updated since you likely have very old versions of the core package.
Mansoor Shaikh
@mansoorsaba_twitter
Dec 07 2018 09:54
I have updated all AnaConda, Spyder etc. It is working now
niepiou
@niepiou
Dec 07 2018 15:35
Try try
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 16:36
@niepiou Hey, can we help you?
Adam Levine
@Levinemealone_twitter
Dec 07 2018 21:21
hi. i cannot seem to find Spyder
i just clicked "Download Spyder with Anaconda"
and all i have is the Anaconda prompt
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 21:22
There should be a Spyder shortcut in your start menu if Anaconda installed correctly. Alternatively, you can launch it from Anaconda Navigator, or with spyder from the Anaconda prompt.
Adam Levine
@Levinemealone_twitter
Dec 07 2018 21:24
i dont have the navigator either
nothing appears when i type in Spyder into start menu
CAM Gerlach
@CAM-Gerlach
Dec 07 2018 21:25
If so, then something went wrong with your Anaconda install. However, you can still launch it from Anaconda prompt as I mentioned.
Adam Levine
@Levinemealone_twitter
Dec 07 2018 21:25
ok. i will uninstall