These are chat archives for spyder-ide/public

9th
Dec 2018
ewuramaminka
@ewuramaminka
Dec 09 2018 00:50
Hi, how do I update spyder in ubuntu 18.04 ... my spyder keeps crashing I am almost about to install another IDE
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 00:59
@ewuramaminka Depends on how you installed it. The latest version from the Debian/Ubuntu package manager is around a full year out of date, and the maintainers have stopped responding to our messages, so we recommend not using that. If you've installed it via conda (recommended) or pip (for experienced users only), you should update it like any other package, conda update spyder or pip install --U spyder respectively. The current version is 3.3.2, so if you don't have that you should update. You should also update Spyder-Kernels to the latest version supported by Spyder 3, 0.3.0, with pip install "spyder-kernels==0.3.*" or conda install spyder-kernels=0.3 respectively. If you still see crashes, updating your graphics drivers and Qt/PyQt to the latest version (conda update pyqt qt/ pip install "pyqt==5.9.*" "qt=5.9.*") might help stability on your system; if you still have trouble or already have the latest version, try downgrading back to 5.6 with conda install pyqt=5.6/pip install "pyqt==5.6.*" "qt==5.6.*".
ewuramaminka
@ewuramaminka
Dec 09 2018 01:23
wow its working perfectly. Thanks so much!!
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 01:24
Great! What fixed it, specifically?
ewuramaminka
@ewuramaminka
Dec 09 2018 01:25
@CAM-Gerlach so i did two things 1. pip3 install spyder 2. pip3 install "spyder-kernels==0.3.*" these two fixed all the updates and no crashing when i load my dicom images .. thanks very much!
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 01:30
Great, glad it fixed it! Just be aware that 1. I assume that's installed on your system Python (or perhaps another similar install); we recommend using virtualenvs/venvs (or better yet, conda environments) so you can have multiple isolated environments for your IDE and your work packages to avoid problems and contamination, and to make troubleshooting easier if things go wrong again; and 2. We provide packages and documentation on installing Spyder via pip and virtualenv and quite a few users work successfully this way (including many of our core devs). However, occasionally for scientific packages pip can result in tricky machine-specific issues that are impossible for us to help with on our end, so do make sure you're comfortable dealing with any problems that might arise.
Thanks, and happy Spydering!
ewuramaminka
@ewuramaminka
Dec 09 2018 01:32
@CAM-Gerlach very well noted. will try to use the virtualenv to avoid issues. but for now i will complete my current project. You really saved me a lot of trouble this night. Thanks.
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 01:48
Happy to hear! Good luck on everything!
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 02:00
This is a resolved issue with Python 3.7; please upgrade to Spyder 3.3.2 to fix it. Thanks
JamesChou2016
@JamesChou2016
Dec 09 2018 02:02
 ![alt](https://files.gitter.im/spyder-ide/public/OQk8/image.png)
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 02:03
You put the image link in a code block for some reason so its not displaying properly
You just linked a random screenshot of mine?
JamesChou2016
@JamesChou2016
Dec 09 2018 02:04
Sorry. I'm not familiar to the markdown grammar.
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 02:04
What were you trying to say?
JamesChou2016
@JamesChou2016
Dec 09 2018 02:04
Yes. I would like to know what theme you used in that picture?Thankes
image.png
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 02:06
Spyder 4's new dark theme with my own custom syntax highlighting theme, which the new Spyder 4 "Spyder Dark" syntax highlighting theme will look similar to. Spyder 4 beta 2 should include the dark theme in more or less final form, so if you want to try it out you can when it releases in a few weeks or even right now if you run off a Github clone.
There are some hacks to get it in Spyder 3 but you're better off waiting a few weeks for the official version or, at the very least, running off the Github clone (which may not be very stable since we're still under active development and isn't heavily tested and polished yet).
JamesChou2016
@JamesChou2016
Dec 09 2018 02:09
The Spyder Dark theme in this picture is much better than that in 3.X. I look forward to its final release. Thank you!
CAM Gerlach
@CAM-Gerlach
Dec 09 2018 02:14
There is no Spyder Dark UI theme in 3.x, just a (not so polished) syntax highlighting theme named "Spyder Dark" as well as a few other syntax highlighting ones. We're working on the replacement right now; you can check out spyder-ide/spyder#8284 for my original proposal (essentially what you see in that screenshot) and give your feedback on another currently being considered for inclusion, an adaptation of Atom's One Dark theme, over at spyder-ide/spyder#8357 .
JamesChou2016
@JamesChou2016
Dec 09 2018 02:29
Ok, I see. The themes in these issues are excellent. I'll try.