These are chat archives for spyder-ide/public

23rd
Jan 2019
danfenn
@danfenn
Jan 23 14:55
Hi. I'm running Spyder 3.3.2 with Python 3.7 on a Windows 10 PC and have an issue in which Spyder closes when I lock my computer. It doesn't happen every time, but probably closes about 80% of the time I lock it. Does anyone have any suggestions please?
CAM Gerlach
@CAM-Gerlach
Jan 23 17:38
@danfenn We haven't seen that before. By "closes", is Spyder just gone or do you see some error message (e.g. "Python has stopped working")? Can you try opening an Anaconda prompt, executing set SPYDER_DEBUG=3, running spyder, and then after a minute or so when its fully started up, locking your system (possibly multiple times until the problem is triggered)? Then, post a screenshot of the last screen of output on the Anaconda prompt here, along with any error messages; it would be helpful if you noted exactly what line was the last one printed before you pressed Win-L. Thanks!
danfenn
@danfenn
Jan 23 18:18
before_closing.PNG
I don't see an error message, it's just gone. I've just tried it a couple of times and I saw the window close as soon as I unlocked my computer. The last screen of output on the Anaconda prompt before I lock the computer is as above
I then don't get any error messages in the Anaconda prompt, it just returns to the (base) prompt
CAM Gerlach
@CAM-Gerlach
Jan 23 18:40

That's really strange. Does your Windows 10 have any aggressive power saving features turned on, like suspending apps in the background or that sort of thing? I seem to recall something like that being added to Windows 10 at some point. It could also be some wierd issue with Spyder's GUI library, Qt. Try the steps I specified in my comment above:

To try to fix that, try updating your graphics drivers, switching off either the Intel or the Nvidia GPU and seeing if it works with the other, doing conda install pyopengl, and switching to a different version of Qt (check with conda list qt; if you have 5.6.x run conda install pyqt=5.9, and for 5.9 run conda install pyqt=5.6; if you don't have Anaconda try using that instead).

@ccordoba12 any idea what could be causing @danfenn 's problem? I'm baffled and I haven't noticed it myself nor seen other reports.
Carlos Cordoba
@ccordoba12
Jan 23 18:41
Nop, sorry
Ingirmatrix
@Ingirmatrix
Jan 23 18:55
Hi, when I start spyder i have an error "LoadLibrary failed with error 1114". Can you help me please?
I solved...with an youtube -video:https://youtu.be/R9gA2eLvhQ0
CAM Gerlach
@CAM-Gerlach
Jan 23 18:58
Good to hear, @Ingirmatrix .