Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Feb 04 2020 16:57
    @goanpeca banned @tolgayilmaz
Brady Begeman
@babegeman
This is in reference to the 5.0.0 release
DL2020
@DL2020
Hi, guys! I just installed 5.0.0. There are two issue: when spyder starts, it always complain about that I have missing dependency issue of the spyder_kernels. However, my version is 2.0.1 which is satisfied the requirement. The second problem is the outline of source code not working . It works when I just installed spyder, somewhat later on it no longer work. Just show the file name in the outline pane, nothing else. Do you guys have any idea how to solve this?
1 reply
The outline issue is really annoying since I highly rely on that feature.
TMCG123
@TMCG123
Hi,
I don't get the Exception's cause property - is this not implemented ?
Diarmuid Henry
@DiarmuidHenry_twitter
Gurobipy: it's installed on my computer, and i've installed my license, yet it still says "No module named 'gurobipy'" every time I run a program with gurobipy. Any ideas?
Janath
@janathg
can I use spyder 5 from python 2.7
karlos124c
@karlos124c
give it a try with python -m pip install spyder
4.2.5 is ok like that in my personal experience, remember to help carlos cordova keep up with this worthnoting pycharm alternative
dustinlockney
@dustinlockney
I am getting the following error: 'ModuleNotFoundError: No module named 'finviz'' I did the pip install. Is my path incorrect? I'm using windows
Ishani2019
@Ishani2019
I installed spyder 5.0.0 but everytime I open the app, spyder 3.7 (the old version that I had on my pc) opens up
Mert Gör
@hwpplayer1
Hi there
We are searching for Spyder4 on Ubuntu 20.04.2
I will be back
meltayeb271283
@meltayeb271283
hello
I have a question guys
so, my spyder is currently running on the default python version (3.8.5)
but I need to do an assignment that needs python 3.7
so how do I get spyder to back-date itself to 3.7?
nrtSynn
@nrtSynn
Hi! I am searching for a vim plugin for spyder.
Saurabh Dhabe
@dhabesaurabh
Hello. I launched Spyder and it is showing me a pop up of missing dependencies.

This is what it shows in the pop up.

Mandatory

spyder_kernels >=2.0.1,<2.1.0 : 2.0.1 (NOK)

What can be done to fulfil this dependency?
Please suggest.
stonebig
@stonebig
It's a false positive error fixed in coming spyder-5.0.1 via spyder-ide/spyder#15100
bigfatpenguinQ
@BigfatpenguinQ_twitter
hi there
can i seek for help ?
bigfatpenguinQ
@BigfatpenguinQ_twitter
when i using spyder and trying to import networkx
it just said it dont have the module
i use the Mac book bigsur 11
what should i do?
dtc348
@dtc348
I installed kite for spider in Mac mini (M1, 2020), but unable to open. It stop at initialising position.
Vittorio Giammarino
@VittorioGiammarino
hi there, I have just upgraded my spyder version to 5.0.0., the code folding feature that was introduced in spyder 4. Is it for everyone or something went wrong during the upgrade or I just have to enable it?
AnnaMariaGitHub
@AnnaMariaGitHub
Hi Is there anybody who can tell me where to change the background color
from black to white
chuckf201
@chuckf201
In using spyder 5.0.0 with python 3.8 and rkinter is not working.
Devon Rowland
@Mr.Mr.lab_gitlab
Hello, I just installed Spider and I want to know how to goto a line number because there is no goto in Python. I think now Python is pretty cool. Cooler than Java Script, or where to find it in my book. I have line numbers enabled.
Devon Rowland
@Mr.Mr.lab_gitlab
What is Spyder kernel?
ilcaa72
@ilcaa72
@Mr.Mr.lab_gitlab are you referring to the error message on Spyder 5 install?
ilcaa72
@ilcaa72
the developers said its a bug and 5.0.1 will fix it, to be released soon
bulusuk
@bulusuk
Hello,
I am have a tough time getting rid of the "Spyder has encountered an internal problem" (version 4.1.5) .. I did some updates using the anaconda prompt and since then this pop seems to be prevalent every time I run a code.
The second part of my problem is that my Anaconda and Spyder are not updating to the latest versions. So should I just fully reinstall Anaconda ?
Thanks for any help !
Christian Rueda
@Crueda96
Spyder Launch ModuleNotFoundError: No module named 'PySide'
Spyder version: 3.3.5
Python version: 3.7.10
Qt version: 5.9.7
PyQt version: 5.9.2
Operating System name/version: Windows 10 x64
ilcaa72
@ilcaa72
how to i activate autocompletion? i get nothing pressing tab or ctrl+space, or anything else? once sypder is isnalled what needs to be done? thanks
georgeccfisher
@georgeccfisher
there is a spyder standalone installer for windows and for mac - why not for linux?
supertomorrowiobrother
@supertomorrowiobrother
When I create a new file, untitled0.py, in my current working directory and then execute it, the actual file untitled0.py doesn't get created in the current working directory. Where is this file? I have "Automatically save a copy of files with unsaved changes" checked in Preferences -> Editor -> Advanced Settings. I'm running Spyder 5.0 on a Mac (Big Sur)
3 replies
stonebig
@stonebig
if conda doesn't have PyQt5-5.15... would it be a problem to replace constraint 'pyqt5<5.13' per 'pyqt5<5.16' (and 'pyqtwebengine<5.13' per 'pyqtwebengine<5.16') ? PyQt-5.12 is really old
Saptak Bhoumik
@SaptakBhoumik
Hi everyone, I wrote a web browser in python
using the pyqt5 framework and I would like to have some feedback about this. Source code is at :- https://github.com/SaptakBhoumik/WebPlus
Is there something that can be done better?
I would love to hear your feedback and recommendations! :)
Thank you in advance!
ilcaa72
@ilcaa72
@SaptakBhoumik , what is it based on chrome/mozilla? extensions/addons available?
Saptak Bhoumik
@SaptakBhoumik
@ilcaa72 It is based on qt which is based on Chromium
@ilcaa72 currently add-on are not available but will be available soon