Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Feb 04 2020 16:57
    @goanpeca banned @tolgayilmaz
rajeshr48
@rajeshr48
Hi, could you please answer my basic question.
Hong-Ying Chen
@frogricky
image.png
Why not print first
Marsh
@marshadow_uwu_twitter
Guys got a quick question, is there a way to increase the resources directed to spyder? I am running some projects and they take lots of time. Thanks in advance!
jessiewang9102
@jessiewang9102
hi, i have got an error when i launch the spyder:
C:\Users\ww2m19\Anaconda3\lib\site-packages\spyder\utils\image_path_manager.py:45: UserWarning: The icon located in C:\Users\ww2m19\Anaconda3\lib\site-packages\spyder\images\dark\kite.svg is overriding the existing kite
warnings.warn(
Traceback (most recent call last):
File "C:\Users\ww2m19\Anaconda3\lib\site-packages\spyder\app\mainwindow.py", line 1617, in moveEvent
if not self.isMaximized() and not self.layouts.get_fullscreen_flag():
File "C:\Users\ww2m19\Anaconda3\lib\site-packages\spyder\app\mainwindow.py", line 1156, in getattr
return self.get_plugin(self._INTERNAL_PLUGINS_MAPPING[attr])
File "C:\Users\ww2m19\Anaconda3\lib\site-packages\spyder\app\mainwindow.py", line 169, in get_plugin
raise SpyderAPIError(
spyder.api.exceptions.SpyderAPIError: Plugin "layout" not found!
Vaibhav Thakur
@THAKURVaibhav1s_twitter
i want spyder(32bit)
Liang200018
@Liang200018
I use git checout command, and lose working tree . How should I recover those untracked files?
please help me
nathan c
@nac5604
Dang this ide has an irc??
sick
tommyturk
@tommyturk
Hi there,
I am having issues installing spyder 4 on Mac os Catalina - the program seems to crash on launch, reading 'Spyder Error' and no other information.
firat-21
@firat-21
hi, I'm suffering from latency in the Spyder while typing codes. i'm using Macbook.
is there anyone who know any solution
jrbellsr
@jrbellsr
i'm having trouble installing anaconda on linux in order to get to spyder in order to learn python. it downloads, but won't execute to install. any advice. fyi, i'm also a newbie to linux after being w windows for 25+ years. Thx for any suggestions! JB
Liang200018
@Liang200018
@hatcomGH I solve it . Thank you. I chat about git reflog to find I commit it in other branches.
arefhr
@arefhr
hi guys
when i using one module in my project(mac OS),spyder give a error 'no modoule named...'
and i try to read and act spyder FAQ but not understand
anyone can help me?
i install too my package on terminal with pip and pip3
1st Physivesment
@1stPhysivesment_twitter
Screen Shot 2564-08-04 at 10.22.07.png
Hi. I just update the new version of Spyder. What is the problem for this pop up ? (I use Mac M1)
nkirby11
@nkirby11
Hi, I'm experiencing really slow typing latency on spyder v4.2.5 on macOS Big Sur. I've tried suggestions on the Spyder FAQ but it is still very slow.
edwardghbaker
@edwardghbaker
Hey, is there a quick way to update to the latest spyder, im using a direct spyder install with miniconda
taylorpetty
@taylorpetty
how do I cite Spyder
edwardghbaker
@edwardghbaker
cite in what sense?
taylorpetty
@taylorpetty
academic publication
edwardghbaker
@edwardghbaker
i dont think you need to pal
its a program editor, so it would be like citing Microsoft word
promise20
@promise20
@nkirby11 Me too. My macOs is Catalina. I treid everything I could I think. I removed the spyder and reinstalled, and I updated the spyder version from v4.2.5 to v5.0.5 and I followed the FAQ for macOS Big Sur, and I tried to figure out what is the problem as this web page suggests (https://bleepcoder.com/ko/spyder/535131354/spyder-4-0-0-unbearably-slow-when-adding-or-removing-lines) but.. all of this efforts are.. not working.
Squaz
@eL-Squaz
Hi, I was wondering what the latest version of spyder is that run's Spyder-notebook?
MrLatinNerd
@MrLatinNerd

Hi, I've been trying to use the Git integration in Spyder 5.0.5 (running Windows 10) but it keeps giving me the error

hp, ht, pid, tid = _winapi.CreateProcess(executable, args,
NotADirectoryError: [WinError 267] The directory name is invalid

Here are the steps I took:

  1. I made sure Git was installed properly on my computer
  2. I cloned a project to the local directory C:\Users\leMingathon\Documents\GitHub\Computational-Explorations-of-Stabiliser-State-Geometry
  3. I created a new project in Spyder with the above working directory
  4. I right-clicked on one of the files and clicked either 'Commit' or 'Browse repository'. I think they both give the same error
nkirby11
@nkirby11
@promise20 Yeah it's really frustrating. Hopefully someone can provide a solution that actually works.
cuiyu747
@cuiyu747
on windows, I run spyder. where should i type in so I can update spyder to 5.0.5
promise20
@promise20
@eL-Squaz Hi, I was using spyder v4.2.5, it got slow down when typing, so I remove the spyder and reinstalled but the problem was not solved..
Jitse Niesen
@jitseniesen
@eL-Squaz Spyder 4.x is compatible with spyder-notebook, spyder 5.x is not (yet)
Amin
@aminnima50_twitter
hi, i am running pythone 3.9.6, i tried to update sypder to the latest ver. , and while i was trying to open spyder it asked for python 3.7. does the latest version of spyder need python 3.7?
Nishit Prajapati
@nishitprajapati
i tried to update and install notebook plugin, but then in view>panes, it is not showing option for notebook in spyder
what to do?
The divine Soul💞
@GayatriDuwarah_twitter
When I type the code
from vgg16 import VGG16
Then a error occurred
ModuleNotFoundError: No module named 'vgg16'
How to solve this , please reply
knifeedAbhi
@knifeedAbhi
i am trying to view a dataframe in variable explorer, but it says unable to retrieve data. What to do now???/
LuisMelGtz08
@LuisMelGtz08
Hi, I have a doubt
I would like to know if it is possible to change the version of python that Spyder uses, since I need to use python 3.5 or lower but I want to do it in the spyder development environment and I would like to know if it is possible to change the version of python
denizlerinizzz
@birmuhendizz_twitter
Hello there. I have python version 3.8. opencv is 4.5.3.56.
There is a code written in version 3.7 and I keep getting the error below. emergency aid. AttributeError: module 'cv2.cv2' has no attribute 'TrackerBoosting_create'
Rick Debbout
@debboutr
I'm trying to save a layout in spyder 5.0.5 and then have it set to the default when opening spyder. I can save it just fine, but every time I open spyder it shows me the default layout. I've tried to go to View >> Window Layouts >> Layout Preferences and it shows my saved layout, but I can't move it up in the order? is this an issue? the one thing that I am doing in my layout that I saved is disabling the editor window, I'd like that to not show up when I open if I can, but maybe it's not able to do that?
rekingr3
@rekingr3
Hello everybody. I'm trying to install Spyder on my Mac but the last version that I can use is 10.15.7 (Mac0S Catalina). In the site they say only I can do it on Big Sur. There is a way that I can use spyder on Catalina ? Thank you :)
Inocente2711
@Inocente2711
How can I install matplotlib and the other libraries on Spyder
jaronsamson
@jaronsamson
I'm using Spyder version 5.0.3. When I was still using Spyder version 4, I was making use of the Spyder line profiler plugin. Since I moved to Spyder version 5.X.X, this plugin does not seem to work (at least for me). For instance, Spyder 5 is no longer showing in the menu "Run > Profile line by line". According to Anaconda, "spyder-line profiler" (v 0.1.1) is installed on my laptop. Is it possible to use this plugin with Spyder version 5.X.X?
Mumbawa
@Mumbawa
Hello everyone! What's the best channel to report Spyder bugs?