Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Zman350x
    @Zman350x
    All of the E:100% tasks have that
    Rabit
    @rabits
    Yeah, seems the compose did not output anything. This one need to check carefully - the logs of agents and manager, version of blender and so on. To reproduce it out on my side - could you please create a ticket with as much info as you can provide please.
    Zman350x
    @Zman350x
    I've left the office, but I'll create one Thursday
    Zman350x
    @Zman350x
    Ok, back at work
    Lemme get all of the logs
    Zman350x
    @Zman350x
    Reran the test to generate some logs, where are the log files saved?
    Rabit
    @rabits
    Oh, sorry - please check this one: https://github.com/state-of-the-art/BlendNet/wiki/If-you-stuck-with-an-issue BTW did you follow the First Steps, right?
    Zman350x
    @Zman350x
    I followed the the First Steps page. I couldn't find this part though as I was doing it
    Other than that manager panel which I couldn't find, I followed it
    Also, I hooked everything up via ethernet instead of Wifi and reran (only 3 agents, none on client/manager PC). It got the point where all tasks said E:100.00%, none left on pending
    Zman350x
    @Zman350x
    I put it into an a GitHub issue state-of-the-art/BlendNet#160
    It formatted part of the error message into an emoji lol
    EM-3D
    @EM-3D
    image.png
    hi i´m testing blendnet v.03 with blender3..0 & BoneMaster 3.1 build from graphicall, the addon can create and manage VM in Gcloud but i get this "error" every time
    and the render task button gets never enable, also in the addon preferences the blender dist dropdown its empty i try to put a direct link to the blender zip installation but i dont know if that works
    EM-3D
    @EM-3D
    sorry i tested with blender LTS 3.0 official for linux too
    Rabit
    @rabits
    Thank you @Zman350x , will check the issue
    Rabit
    @rabits
    Hi @EM-3D , the usual reason for that is that the Manager instance was not started up properly, because exactly the Manager node creates this certificate in the bucket for Addon to download it.
    Try to follow the Wiki FirstSteps to setup your google cloud the first time.
    In case that's not work - please tell the step of wiki which make a trouble to do
    EM-3D
    @EM-3D
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Reloading.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: serial-getty@ttyS0.service: Current command vanished from the unit file, execution of the command list won't be resumed.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: getty@tty1.service: Current command vanished from the unit file, execution of the command list won't be resumed.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Started BlendNet Manager Service.
    [ OK ] Started BlendNet Manager Service.
    Jan 31 18:06:59 blendnet-frlfey-manager google_metadata_script_runner[500]: startup-script exit status 0
    Jan 31 18:06:59 blendnet-frlfey-manager google_metadata_script_runner[500]: Finished running startup scripts.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: google-startup-scripts.service: Succeeded.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Started Google Compute Engine Startup Scripts.
    [ OK ] Started Google Compute Engine Startup Scripts.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[2107]: blendnet-manager.service: Failed to execute command: No such file or directory
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[2107]: blendnet-manager.service: Failed at step EXEC spawning /srv/blender/blender: No such file or directory
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Reached target Multi-User System.
    [ OK ] Reached target Multi-User System.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Reached target Graphical Interface.
    [ OK ] Reached target Graphical Interface.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Starting Update UTMP about System Runlevel Changes...
    Starting Update UTMP about System Runlevel Changes...
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: blendnet-manager.service: Main process exited, code=exited, status=203/EXEC
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: blendnet-manager.service: Failed with result 'exit-code'.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: systemd-update-utmp-runlevel.service: Succeeded.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Started Update UTMP about System Runlevel Changes.
    [ OK ] Started Update UTMP about System Runlevel Changes.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Startup finished in 3.237s (kernel) + 22.922s (userspace) = 26.160s.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: blendnet-manager.service: Service RestartSec=100ms expired, scheduling restart.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: blendnet-manager.service: Scheduled restart job, restart counter is at 1.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Stopped BlendNet Manager Service.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Started BlendNet Manager Service.Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Reloading.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: serial-getty@ttyS0.service: Current command vanished from the unit file, execution of the command list won't be resumed.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: getty@tty1.service: Current command vanished from the unit file, execution of the command list won't be resumed.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Started BlendNet Manager Service.
    [ OK ] Started BlendNet Manager Service.
    Jan 31 18:06:59 blendnet-frlfey-manager google_metadata_script_runner[500]: startup-script exit status 0
    Jan 31 18:06:59 blendnet-frlfey-manager google_metadata_script_runner[500]: Finished running startup scripts.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: google-startup-scripts.service: Succeeded.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[1]: Started Google Compute Engine Startup Scripts.
    [ OK ] Started Google Compute Engine Startup Scripts.
    Jan 31 18:06:59 blendnet-frlfey-manager systemd[2107]: blendnet-manager.service: Failed to execute command: No such file or directory
    J
    ooops sorry didnt know this will fill this big
    this is the google console then the addon stops
    Rabit
    @rabits
    @EM-3D please use markdown syntax to format the log (``` will do)

    It seems the issue you have is here:

    Failed at step EXEC spawning /srv/blender/blender: No such file or directory

    Make sure the archive with blender was unpacked properly - if you changed the url it's quite possible it's unavailable from the GCP subnet

    Zman350x
    @Zman350x
    @rabits ya know how you mentioned turning off the "noise threshold" or it'd do 1024 samples... Yeah, turns out thew default is 4096, not 1024... Definitely the reason it was so slow
    Rabit
    @rabits
    Yep, that's what they changed in Blender v3... Now I'm actually not sure how to deal with it - because to provide such service we need to run one frame per node. For sure it will be much straightforward, but also will lead to losses on the cloud platform with preemptible instances...
    So @Zman350x the builds I posted in state-of-the-art/BlendNet#160 are working for you?
    Zman350x
    @Zman350x
    @rabits Yep! Still feels a bit slow tho, might just be me.
    I feel like 4 computers running 10700k's wired via ethernet should be able to do more than 42 frames in 1.66 hours on a default cube
    (128 samples rather than 4096)
    A also adjusted the default OpenImageDenoise from Accurate to Fast and Albedo and Normal to Albedo
    And only 128 frames rather than the full 250 of the full "animation" (although that won't affect the speed-per-frame)
    All just to speed the test up
    Zman350x
    @Zman350x
    Part of me feels like the bottleneck might be the network. It'd be cool if there was an option that would render like this: Manager counts number of frames and number of agents. Manager divides frames among agents evenly: "Ok, agent 1 you get frames 1-20" "Agent 2, you get 21-40" "Agent 3..." etc. Each computer goes and renders its assigned section and sends completed frames back to client PC
    Obviously this workflow doesn't work in every scenario, so a dropdown menu would be nice to select between whatever the current system is called, each task is a frame (what you mentioned implementing), my frame grouping thing, and whatever else you may implement in the future.
    Rabit
    @rabits
    So the blendnet right now focused to render much more complicated frames - like huge pictures with high resolution (that's why it's dividing the single frame over the entire cluster). Unfortunately the work is stalled and most probably I will need to rewrite the entire engine to support multiple render scenarios.
    Zman350x
    @Zman350x
    Well, luckily the final project'll be a big complicated scene, so I guess that'll help
    phellmann
    @phellmann
    hey there!
    Does anyone got blendnet with blender 3.0.0 or 3.0.1 to work? I am on windows and I followed exactly the first steps setup guide for local renderfarm with manager, agent and client via addon on my local machine
    with the latest blender 2.93 it worked like a charm but with the 3.0 its not able to process a task properly and is not saving any frames and I also cannot stop it via the blender addon panel (kill tasks, etc.). did anyone experience similiar problems? can someone support me in this? what do you need to know?
    Rabit
    @rabits
    Hi @phellmann , if you're talking about v0.3 of blendnet - the branch was updated with the fix, but I seems forgot to release the fix as archives. Let me do that quickly
    Rabit
    @rabits
    Ok, just released - not sure if it will fix your issue but worth a try
    phellmann
    @phellmann
    @rabits amazing, thanks. I will try it now
    phellmann
    @phellmann
    whats happening .. I rendered 5 frames animation as test and it takes forever. is one agent rendering one frame in multiple chunks? the agent is updating render blobs and merges stuff like crazy but I never see something. its a default scene with the default cube moving across 5 frames.
    and the manager now gives these errors on startup https://pasteboard.co/f8EfYL1Ist91.png
    phellmann
    @phellmann
    I read the default cube has issues, so I created a non-default scene but agent is saying this now: https://pasteboard.co/CUhxZlz4W2FH.png
    and the addon doesnt let me delete a task or delete all tasks. https://pasteboard.co/gE3wC6ZQ6Gmy.png the workspace is in my documents, so blender should have access to them. They can be created, but not deleted..
    phellmann
    @phellmann
    ok, got it to work now. I deleted gcloud and aws python files in the providers folder
    but the task list cannot be cleared with the actions. is this a known issue? (neither in admin mode or regular blender start)