Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 11 05:59
    eben-roux closed #1014
  • Aug 17 07:06
    frank-dspeed commented #1505
  • Jul 13 13:04
    matthewp commented #1505
  • Jul 12 09:08
    frank-dspeed commented #1505
  • Jul 12 09:07
    frank-dspeed commented #1505
  • Jul 06 20:02
    ivospinheiro commented #1520
  • Jul 06 18:58
    matthewp commented #1520
  • Jul 06 18:48
    ivospinheiro opened #1520
  • Jun 08 16:44

    matthewp on master

    Add support for node 14 (modell… Try to generalize version Merge pull request #1157 from i… (compare)

  • Jun 08 16:44
    matthewp closed #1157
  • Jun 08 16:44
    matthewp commented #1157
  • Jun 06 18:10
    icarito commented #1157
  • Jun 06 18:05
    coveralls commented #1157
  • Jun 06 18:04
    coveralls commented #1157
  • Jun 06 18:02
    icarito synchronize #1157
  • Jun 06 16:34
    coveralls commented #1157
  • Jun 06 16:33
    coveralls commented #1157
  • Jun 06 16:30
    icarito opened #1157
  • Jun 02 07:44
    greenkeeper[bot] commented #1120
  • Jun 02 07:44

    greenkeeper[bot] on globby-11.0.1

    fix(package): update globby to … (compare)

Justin Meyer
@justinbmeyer
as can-route and can-component 4.0 are now independent of each other
and may depend on can-compute 3.X
Justin Meyer
@justinbmeyer
whoops
did I put this in stealjs!
Julian
@pYr0x
;)
WooFerPPK
@WooFerPPK
When in dev mode uploading a multipart form has the bounderies properly appended to the content type. However, the built version doesn't Instead, the boundary is in the Payload only. Our code "works" without errors, but uploads don't actually work as the boundary is not in the right place. How is the built version affecting the browsers behavior?
Matthew Phillips
@matthewp
No idea, very much doubt Steal has anything to do with that
If you can create a test case please submit an issue though.
Justin Meyer
@justinbmeyer
DoneJS Contributors Meeting: https://www.youtube.com/watch?v=Lt9Ctdo9PAw
Matthew Phillips
@matthewp
For consideration: stealjs/rfcs#5
xedos
@xedoken

if i use latest steal-tools and steal, build my project to bundles. and try to load that bundles it fails.

index.js:28 GET http://127.0.0.1:8080/dist/node_modules/steal-less/less-engine.js 404 (Not Found)

i think it about steal-less module, i install it but how can i add it in a build script to bundle it with steal?

like bundleSteal: true.

like index.js:16 TypeError: Error loading "steal-less@1.0.0-rc.2#less-engine"
thank you
Swesh Mishra
@SweshMishra_twitter
I am developing my app in commonJS envirnment, with stealjs and canjs
https://stealjs.com/docs/syntax.CommonJS.html#section_Use
But I'm getting from steal when I require can
Matthew Phillips
@matthewp
@xedoken Do you have the latest steal 1.0 -rc and steal-tools 1.0 rc as well? Those are required to work with steal-less 1.0-rc
If you have those, please file a bug and I'll take a look.
Chasen Le Hara
@chasenlehara
@SweshMishra_twitter, can you share what error you’re getting?
xedos
@xedoken
@matthewp Yes. Latest RC for both libs. May be i dont need to import steal-less in project AppViewmodel? i think that the problem when i build the project, it pack the steal-less lib as a dependency. what do you think?
xedos
@xedoken

i found that steal-tools already has this bug in github.

stealjs/steal-tools#560

am i right?

Matthew Phillips
@matthewp
Yeah, but that shouldn't cause any build issues, I don't think.
xedos
@xedoken
@matthewp may be it b/c donejs latest rc? if i use steal v.16 and steal-tools v.16 it export ok. no errors. but with latest steal/steal-tools rc it fails. please look at this problem. i really need this. thank you :)
Justin Meyer
@justinbmeyer
@xedoken , @matthewp is on PTO ... won't be back until monday
Chasen Le Hara
@chasenlehara
@xedoken, @matthewp can correct me if I’m wrong, but I think that’s a high priority issue for the Steal 1.0 release, it just hasn’t been fixed yet.
Matthew Phillips
@matthewp
I'm not sure what issue we're referring to
Is there an issue number?
xedos
@xedoken
Hi, nope. I did not create an issue in github yet, in a few hours i will do that. The problem is about incorrect bundling with new steal and steal tools. May be i'm wrong,but none of the build and exports was success. So after building i try to load that bundles in local html, and it fails because of less engine. If i export as standalone, fails, if global fails too. May be you can writean instructions how i need to write a build.js to correct building and exporting with steal, steal-tools, and steal-less/css?
Sunil George
@georgesunil81
Hello! I need help running Karma with StealJS. I am getting an error where Karma is not able to find stealconfig.js and dev.js. But, my StealJS application is able to find these files!
Any ideas?
Kevin Phillips
@phillipskevin
Sunil George
@georgesunil81
Ah! thanks @phillipskevin . I will check it out now.
@phillipskevin , I see you have included 'node_modules/steal/steal.js' in the karma.conf.js but there is a pattern above that includes it already, do we have to include steal.js twice?
I am trying the same in my project now to see if it resolves the issue I am facing!
Kevin Phillips
@phillipskevin
the pattern is included: false
so yeah, that could be why yours can’t load dev.js if you don’t have a pattern like that
Sunil George
@georgesunil81
Okay. I am still getting the error in the Karma console. It is not able to find stealconfig and dev.js!
Here is my karma.conf.js -
module.exports = function(config) {
  config.set({
    basePath: '',
    frameworks: ['jasmine'],
    files: [
      { pattern: 'test/**/*.js', included: false },
      { pattern: 'node_modules/steal/**/*.js', included: false },
      { pattern: 'node_modules/**/package.json', included: false },
      { pattern: 'package.json', included: false },
      'node_modules/steal/steal.js',
      'karma.bootstrap.js'
    ],
    exclude: [ ],
    preprocessors: { },
    reporters: ['dots'],
    port: 9876,
    colors: true,
    logLevel: config.LOG_INFO,
    autoWatch: true,
    browsers: ['Chrome'],
    singleRun: false,
    concurrency: Infinity
  })
};
And here is my karma.bootstrap.js
window.__karma__.loaded = function() {
  var s = document.createElement('script');
  s.setAttribute('src', 'base/node_modules/steal/steal.js');
  s.setAttribute('data-main', 'test/');
  document.head.appendChild(s);

  s.onload = function () {
    steal.done().then(function(){
        console.log('----- StealJS is loaded -----');
      if(window.__karma__) {
        window.__karma__.start();
      }
    });
  };
};
The errors are coming from karma.bootstrap.js. It is not able to find stealconfig.js and dev.js.
Kevin Phillips
@phillipskevin
you probably need a pattern for your stealconfig
Sunil George
@georgesunil81
But, I already have the following pattern in the karma.conf.js
{ pattern: 'node_modules/steal/**/*.js', included: false },
Would it not include stealconfig.js and dev.js too?
Kevin Phillips
@phillipskevin
where is stealconfig?
Sunil George
@georgesunil81
stealconfig is in "node_modules/steal" directory.
Kevin Phillips
@phillipskevin
also, why do you need to use document.head.appendChild to inject steal?
isn’t karma doing that already?
Sunil George
@georgesunil81
Oh! Earlier I did not have the following line in my karma.config.js