Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 26 07:58
    greenkeeper[bot] commented #1122
  • Jan 26 07:58

    greenkeeper[bot] on mocha-7.0.1

    chore(package): update mocha to… (compare)

  • Jan 25 12:30
    greenkeeper[bot] commented #1154
  • Jan 25 12:27

    greenkeeper[bot] on clean-css-pin-4.2.1

    chore: pin clean-css to 4.2.1 (compare)

  • Jan 25 12:27
    greenkeeper[bot] labeled #1154
  • Jan 25 12:27
    greenkeeper[bot] opened #1154
  • Jan 25 12:24

    greenkeeper[bot] on clean-css-4.2.2

    chore(package): update clean-cs… (compare)

  • Jan 24 15:21
    coveralls commented #1153
  • Jan 24 15:17
    cherifGsoul synchronize #1153
  • Jan 24 15:17

    cherifGsoul on upgrade-node-12

    upgrade nodejs for appveyor (compare)

  • Jan 24 14:55
    coveralls commented #1153
  • Jan 24 14:52
    cherifGsoul synchronize #1153
  • Jan 24 14:52

    cherifGsoul on upgrade-node-12

    Trigger a build (compare)

  • Jan 20 18:17
    frank-dspeed opened #1517
  • Jan 20 18:16
    frank-dspeed opened #1516
  • Jan 13 20:36
    greenkeeper[bot] commented #1117
  • Jan 13 20:36

    greenkeeper[bot] on jshint-2.11.0

    chore(package): update jshint t… (compare)

  • Jan 06 22:44
    greenkeeper[bot] commented #1137
  • Jan 06 22:44

    greenkeeper[bot] on terser-4.6.1

    fix(package): update terser to … (compare)

  • Jan 05 03:07
    matthewp closed #507
Justin Meyer
@justinbmeyer
whoops
did I put this in stealjs!
Julian
@pYr0x
;)
WooFerPPK
@WooFerPPK
When in dev mode uploading a multipart form has the bounderies properly appended to the content type. However, the built version doesn't Instead, the boundary is in the Payload only. Our code "works" without errors, but uploads don't actually work as the boundary is not in the right place. How is the built version affecting the browsers behavior?
Matthew Phillips
@matthewp
No idea, very much doubt Steal has anything to do with that
If you can create a test case please submit an issue though.
Justin Meyer
@justinbmeyer
DoneJS Contributors Meeting: https://www.youtube.com/watch?v=Lt9Ctdo9PAw
Matthew Phillips
@matthewp
For consideration: stealjs/rfcs#5
xedos
@xedoken

if i use latest steal-tools and steal, build my project to bundles. and try to load that bundles it fails.

index.js:28 GET http://127.0.0.1:8080/dist/node_modules/steal-less/less-engine.js 404 (Not Found)

i think it about steal-less module, i install it but how can i add it in a build script to bundle it with steal?

like bundleSteal: true.

like index.js:16 TypeError: Error loading "steal-less@1.0.0-rc.2#less-engine"
thank you
Swesh Mishra
@SweshMishra_twitter
I am developing my app in commonJS envirnment, with stealjs and canjs
https://stealjs.com/docs/syntax.CommonJS.html#section_Use
But I'm getting from steal when I require can
Matthew Phillips
@matthewp
@xedoken Do you have the latest steal 1.0 -rc and steal-tools 1.0 rc as well? Those are required to work with steal-less 1.0-rc
If you have those, please file a bug and I'll take a look.
Chasen Le Hara
@chasenlehara
@SweshMishra_twitter, can you share what error you’re getting?
xedos
@xedoken
@matthewp Yes. Latest RC for both libs. May be i dont need to import steal-less in project AppViewmodel? i think that the problem when i build the project, it pack the steal-less lib as a dependency. what do you think?
xedos
@xedoken

i found that steal-tools already has this bug in github.

stealjs/steal-tools#560

am i right?

Matthew Phillips
@matthewp
Yeah, but that shouldn't cause any build issues, I don't think.
xedos
@xedoken
@matthewp may be it b/c donejs latest rc? if i use steal v.16 and steal-tools v.16 it export ok. no errors. but with latest steal/steal-tools rc it fails. please look at this problem. i really need this. thank you :)
Justin Meyer
@justinbmeyer
@xedoken , @matthewp is on PTO ... won't be back until monday
Chasen Le Hara
@chasenlehara
@xedoken, @matthewp can correct me if I’m wrong, but I think that’s a high priority issue for the Steal 1.0 release, it just hasn’t been fixed yet.
Matthew Phillips
@matthewp
I'm not sure what issue we're referring to
Is there an issue number?
xedos
@xedoken
Hi, nope. I did not create an issue in github yet, in a few hours i will do that. The problem is about incorrect bundling with new steal and steal tools. May be i'm wrong,but none of the build and exports was success. So after building i try to load that bundles in local html, and it fails because of less engine. If i export as standalone, fails, if global fails too. May be you can writean instructions how i need to write a build.js to correct building and exporting with steal, steal-tools, and steal-less/css?
Sunil George
@georgesunil81
Hello! I need help running Karma with StealJS. I am getting an error where Karma is not able to find stealconfig.js and dev.js. But, my StealJS application is able to find these files!
Any ideas?
Kevin Phillips
@phillipskevin
Sunil George
@georgesunil81
Ah! thanks @phillipskevin . I will check it out now.
@phillipskevin , I see you have included 'node_modules/steal/steal.js' in the karma.conf.js but there is a pattern above that includes it already, do we have to include steal.js twice?
I am trying the same in my project now to see if it resolves the issue I am facing!
Kevin Phillips
@phillipskevin
the pattern is included: false
so yeah, that could be why yours can’t load dev.js if you don’t have a pattern like that
Sunil George
@georgesunil81
Okay. I am still getting the error in the Karma console. It is not able to find stealconfig and dev.js!
Here is my karma.conf.js -
module.exports = function(config) {
  config.set({
    basePath: '',
    frameworks: ['jasmine'],
    files: [
      { pattern: 'test/**/*.js', included: false },
      { pattern: 'node_modules/steal/**/*.js', included: false },
      { pattern: 'node_modules/**/package.json', included: false },
      { pattern: 'package.json', included: false },
      'node_modules/steal/steal.js',
      'karma.bootstrap.js'
    ],
    exclude: [ ],
    preprocessors: { },
    reporters: ['dots'],
    port: 9876,
    colors: true,
    logLevel: config.LOG_INFO,
    autoWatch: true,
    browsers: ['Chrome'],
    singleRun: false,
    concurrency: Infinity
  })
};
And here is my karma.bootstrap.js
window.__karma__.loaded = function() {
  var s = document.createElement('script');
  s.setAttribute('src', 'base/node_modules/steal/steal.js');
  s.setAttribute('data-main', 'test/');
  document.head.appendChild(s);

  s.onload = function () {
    steal.done().then(function(){
        console.log('----- StealJS is loaded -----');
      if(window.__karma__) {
        window.__karma__.start();
      }
    });
  };
};
The errors are coming from karma.bootstrap.js. It is not able to find stealconfig.js and dev.js.
Kevin Phillips
@phillipskevin
you probably need a pattern for your stealconfig
Sunil George
@georgesunil81
But, I already have the following pattern in the karma.conf.js
{ pattern: 'node_modules/steal/**/*.js', included: false },
Would it not include stealconfig.js and dev.js too?
Kevin Phillips
@phillipskevin
where is stealconfig?
Sunil George
@georgesunil81
stealconfig is in "node_modules/steal" directory.
Kevin Phillips
@phillipskevin
also, why do you need to use document.head.appendChild to inject steal?
isn’t karma doing that already?
Sunil George
@georgesunil81
Oh! Earlier I did not have the following line in my karma.config.js
Kevin Phillips
@phillipskevin
try setting it up how it is in the forum post
Sunil George
@georgesunil81
'node_modules/steal/steal.js',