Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 02 15:45
    greenkeeper[bot] commented #1137
  • Dec 02 15:45

    greenkeeper[bot] on terser-4.4.2

    fix(package): update terser to … (compare)

  • Dec 01 13:57
    greenkeeper[bot] commented #1137
  • Dec 01 13:57

    greenkeeper[bot] on terser-4.4.1

    fix(package): update terser to … (compare)

  • Nov 27 12:55

    m-mujica on master

    2.2.5 (compare)

  • Nov 27 12:55

    m-mujica on v2.2.5

    2.2.5 (compare)

  • Nov 27 12:50

    m-mujica on ignore-git

    (compare)

  • Nov 27 12:50

    m-mujica on master

    Add .git folder to npmignore fi… Merge pull request #1150 from s… (compare)

  • Nov 27 12:50
    m-mujica closed #1150
  • Nov 27 12:48
    coveralls commented #1150
  • Nov 27 12:43
    m-mujica opened #1150
  • Nov 27 12:43

    m-mujica on ignore-git

    Add .git folder to npmignore fi… (compare)

  • Nov 26 05:28
    greenkeeper[bot] commented #1132
  • Nov 26 05:28

    greenkeeper[bot] on mock-fs-4.10.4

    chore(package): update mock-fs … (compare)

  • Nov 25 13:02

    m-mujica on v2.2.4

    (compare)

  • Nov 25 13:02

    m-mujica on master

    2.2.4 (compare)

  • Nov 25 12:59

    m-mujica on fix-exports

    (compare)

  • Nov 25 12:59

    m-mujica on master

    Run mocha programatically Impo… Fix race condition where last f… Rollback main test file changes… and 1 more (compare)

  • Nov 25 12:59
    m-mujica closed #1149
  • Nov 25 12:59
    m-mujica closed #1139
Paul Tichonczuk
@tracer99
<script src="../../../node_modules/steal/steal.js" main="ucp2/dashboard/pin/pin_test" data-mocha="bdd"></script>
Kevin Phillips
@phillipskevin
what happens when you try to import moment in your tests?
Paul Tichonczuk
@tracer99
cannot find /moment.js
first import is actually steal-mocha which yields a similar error
Paul Tichonczuk
@tracer99
The only thing I can think of, is that our projects sits within a larger project (not noad related).... so the root of the site is htdocs/static/ not / in the project directory structure (The webserver is configured to treat htdocts/static/ as the root of the site, I'm just refereing to the project directory structure).
Kevin Phillips
@phillipskevin
are you setting System.baseURL?
Paul Tichonczuk
@tracer99
No. but the base URL is / I'm just talking about the underlining directory structure. / in the browser points to htdocts/static in the project. package.json and node_modules are there as well.
Kevin Phillips
@phillipskevin
oh, ok
Paul Tichonczuk
@tracer99
I checked, the main projects package.json is being loaded
Kevin Phillips
@phillipskevin
when you run your tests you mean?
Paul Tichonczuk
@tracer99
yes
Kevin Phillips
@phillipskevin
Try to compare the System object between your main app and the test page
System.configMain, System.baseURL, System.npm, System.meta, System.paths
Paul Tichonczuk
@tracer99
will do
Paul Tichonczuk
@tracer99
@phillipskevin they are the same
Kevin Phillips
@phillipskevin
ok, is it possible to push a simplified version of your project somewhere I can take a look?
Paul Tichonczuk
@tracer99
hah. not easily. I'll try to reproduce it using a similar structure and see where I get.
Nico R.
@nriesco
has anyone had trouble with the generated css file after doing a donejs deploy?
I’m working on it but it seems that if I add a custom template something weird happens and the browser won’t render things correctly. That or the generated css file has errors
Anyway I sort of fixed it by including comments at the beggining and end of this custom css but like this: /*! my comment */
with css file I mean /dist/bundles/my-app/index.css
Nico R.
@nriesco
I just couldn’t replicate the error I had. I guess it had something to do with bootstrap, it was included in a plugin as well as the main app, I updated the plugin not to include bootstrap, probably that helped.
Paul Tichonczuk
@tracer99
@phillipskevin ok. I've created a sample app that exhibits the bug I'm talking about. details in README https://github.com/tracer99/node-import
Kevin Phillips
@phillipskevin
@tracer99 I probably won't have a chance to take a look at it until tomorrow. Too many meetings today.
what isn't loading correctly in your tests?
I'm not seeing moment
Jeroen Cornelissen
@jeroencornelissen
Is it possible to build steal so it runs inside it’s own ‘package’ ?
Inside a specific div we start our CanJS app, wich uses can-jquery. But this conflicts with other (older) existing jquery widgets on our page.
Our build file looks like this:
var stealTools = require("steal-tools");

var buildPromise = stealTools.build({
    main    : "main",
    config    : __dirname + "/package.json!npm"
}, {
    bundleAssets    : false,
    bundleSteal        : true
});
Paul Tichonczuk
@tracer99
@phillipskevin nothing is loading. Everything I attempt to include which is a node-module tries to grab it from / and not /node_modules
didn't bother using moment as that was not important to the problem
Kevin Phillips
@phillipskevin
ok
I’ll take a look at it
Kevin Phillips
@phillipskevin
@tracer99 steal isn’t able to load any of your devDependencies because you have npmIgnore: [ “devDependencies” ]
Paul Tichonczuk
@tracer99
I don't even know why that's there.
I got it from an example project somewhere
sigh.
thanks
Kevin Phillips
@phillipskevin
no problem
Paul Tichonczuk
@tracer99
@phillipskevin it made no difference for me
Kevin Phillips
@phillipskevin
the only other change I needed was a map for ”chai”: “chai/chai”
Paul Tichonczuk
@tracer99
right
Kevin Phillips
@phillipskevin
is it not working for you?
Paul Tichonczuk
@tracer99
weird. it is in the example project I gave you
but not in our actual project
I'll debug further
found it. I had some directories specified to try to fix the original problem. Removing them fixed everything. Thanks again
Kevin Phillips
@phillipskevin
ok, good
Julia Allyce
@julia-allyce
hey is there anyway to force steal to transpile a specific file/module? I have a node file that is getting skipped because its uses require instead of import :(
Julia Allyce
@julia-allyce
I know I saw an issue in gh about this somewhere but I can't find it now
Julia Allyce
@julia-allyce
Ok I figured it out. You can add a translate function for the modules