Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Bartłomiej Zimoń
@uzi18
Zrob prosty test wypnij kabelek Ethernet
Daniel
@swiezaks
@uzi18 jak możesz to napisz w jaki sposób za pomocą esp posyłać dane do HA.
Bartłomiej Zimoń
@uzi18
Esp-link dalby rade ale musialbym dodac kod do sterownika
Jak czesto potrzebujesz odswiezac dane?
Daniel
@swiezaks
jak by można co 60s to by było super.
co do Nettempa to pisałem do mariusza ale bez odzewu, forum nie działa, chyba że przezli gdzieś indziej i masz jakieś info gdzie?:)
Bartłomiej Zimoń
@uzi18
Forum jest na stronie costam abc
lafar6502
@lafar6502
Czesc, mam w swoim sterowniku problem ze shieldem Ethernet - otóż procesor na tym shieldzie grzeje się niemiłosiernie, gorący tak że ciężko go dotknąć palcem. A nawet ethernetu nie używam, tylko karty SD z tego shielda. Czy w Lucjanie tak samo się dzieje? Dziś solidny upał i okazało się że sterownik się zawiesił - podejrzewam że to przez przegrzanie tego shielda.
A tak przy okazji, z uwagi na ostatnie problemy z zaopatrzeniem w ekogroszek eksperymentuję z pelletem - palnik jak się okazało spala pellet całkiem OK więc kocioł jest de facto dwupaliwowy, musiałem tylko wymienić obudowę palnika żeby zapalarkę dało się dołożyć. Przerabiam właśnie sterownik na obsługę zapalarki i wygląda to obiecująco.
WojtekGD
@WojtekGD
@lafar6502
I jak z tą zapalarką? Co do shielda to jest ciepły ale nie gorący.
Bartłomiej Zimoń
@uzi18
@lafar6502 szukalbym problemu w shieldzie moze zle cos przylutowane, wiemy ze klon Ethernet shield ma zle rezystory wlutowane od strony gniazda Megajack pod RJ45
Jakie sa tam u Ciebie oznaczenia?
Jak ta zapalarka powinna dzialac?
lafar6502
@lafar6502
czesc, problem solved - wywaliłem w ogóle shield ethernet bo służył tylko do obsługi karty SD. Musiałem tak czy siak przerobić soft, poprawić połączenia itp więc była okazja zrobić porządki. Zapalarka działa świetnie na pelecie, szkoda tylko że ceny peletu gonią ekogroszek tak że żadnej oszczędności tu na razie nie będzie. Ale jeśli chodzi o samo paliwo to jest dużo przyjemniejsze od węgla więc liczę że koszty w końcu spadną.
BTW taki tam eksperyment - wymyśliłem żeby kontrolować ilość powietrza wchodzącego do pieca z wykorzystaniem samochodowego przepływomierza (MAF). Póki co wygląda że działa, jest to wykorzystane do korygowania siły nadmuchu na bieżąco.
IMG_20220621_193026381 (1).jpg
MAF na dmuchawie
:)
Bartłomiej Zimoń
@uzi18
To jakis konkretny model?
Jak tym sterujesz, wzgledem dawki paliwa?
Czy wzgledem zapotrzebowania na moc palnika?
lafar6502
@lafar6502
Nie, aż tak zaawansowanych pomysłów nie miałem. Chodzi o to że sterownik pracuje na dwóch mocach - małej i dużej i przełączając się między nimi pracuje w trybie ciągłym. Dla każdej z mocy jest już dobrany czas podawania i nadmuch - ustawiany ręcznie. No ale okazało się że zależnie od pogody, wiatru zmienia się ciąg w kominie no i przez to też nadmuch - mimo że dmuchawa dostaje takie samo zasilanie cały czas. Więc ten przepływomierz pilnuje żeby nie było za dużego odchyłu od wartości ustalonej i koryguje w górę lub dół prędkość dmuchawy.
A MAF od Forda, choć sprawdziłem też kilka sztuk Boscha, i jeszcze ileś tam innych których nie udało mi się rozszyfrować. W najprostszej wersji MAF generuje napięcie z zakresu 0-5V proporcjonalne do przepływu powietrza.
Podpowiadano mi ze lepiej się do tego nadaje turbinka z wentylatorka od PC ale nie znalazłem takiej co by chciała działać-nie chce się kręcić przy małym nadmuchu.
S-Dedalus
@S-Dedalus
Witam. Jeśli przy próbie wejścia na WWW w Lucjanie resetuje się kontroler, to gdzie najlepiej szukać winnego? Tak wygląda log:

t:[242,231,226,197,0,229,0,255,240,0,0,0,0,0,0,0]
WEB:787099
ALL: 3ms
MAP:787297
DALL:14
ALL: 15ms
DALL:787906
ALL: 15ms
DALL:14
ALL: 15ms
DALL:15
ALL: 15ms
DALL:13
ALL: 14ms
DALL:14
ALL: 16ms
DALL:3
ALL: 3ms
TRIAC: T-9948 Z-0 T-Z-1004 F-0 0% DET-220/200
TRIAC: 0-89 1-10 S-99 ok-200
ALL: 4ms
LCD:76

t:[242,231,226,197,0,229,0,260,240,0,0,0,0,0,0,0]
DMU:788100
ALL: 80ms
ALG:788296
S#0:0x17 ESTABLISHED 80 D:192.168.1.193(41584)
S#1:0x14 LISTEN 80 D:79.185.5.200(8080)
S#2:0x0 CLOSED 0 D:0.0.0.0(0)
S#3:0x0 CLOSED 0 D:0.0.0.0(0)
RAM2:2918
GET / HTTP/1.1
TWS: malloc: 4
TWS: malloc: 2
WWW: Odczyt pliku:INDEX.HTM
LCD:78

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:78

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:76

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:76

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:78

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:77

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:76

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:78

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
LCD:77

t:[242,231,226,197,0,229,0,252,240,0,0,0,0,0,0,0]
������brak

Lucjan v.0.1.0.130.25

0
I2C: Skanowanie ...
RTC: znaleziono DS1307

Wygląda jakby po odczycie index.htm próbował coś z LCD zrobić
S-Dedalus
@S-Dedalus
Dodam, że wcześniej było ok. Jakoś tak sam z siebie zaczął się resetować przy próbie odczytu plików. Jak wchodzę np. na http://lucjan.lan/dallas to jest ok. Ale już jak próbuję otworzyć http://lucjan.lan/config.txt albo http://lucjan.lan/b.css to się resetuje. Oczywiście w przeglądarce zwraca "błąd wczytywania strony". Karta SD formatowana - bez błędów, na nowo wszystko wgrane i nic.
Bartłomiej Zimoń
@uzi18
@S-Dedalus ok a index.htm tez tak sie zwiesza?
@swiezaks faktycznie jest blad w tej temp. ujemnej
S-Dedalus
@S-Dedalus
Tak, identyczny objaw. Niezależnie czy wchodzę na lucjan.lan/ czy na lucjan.lan/index.htm
Daniel
@swiezaks
znazleziony bug- brak histerezy pompa C.O. przypaleniu recznym:)
Bartłomiej Zimoń
@uzi18
Sprawdze ale to chyba działa niezaleznie od algorytmu
@S-Dedalus moze cos sie z karta dzieje albo modulem ethernet? Sprobuj na innej karcie.
S-Dedalus
@S-Dedalus
Karta sprawdzona - jest ok. Czyli trzeba by podmienić moduł ethernet i sprawdzić. Tak myślałem ale wolałem zapytać, bo moduł 100 prawie kosztuje. W każdym razie dzięki. Będę raportował na bieżąco.
Bartłomiej Zimoń
@uzi18
Nikt dotad nie zglaszal problemow z odczytem karty
Daniel
@swiezaks
@uzi18 jest szansa na dokończenie termostatu dla c.o?bo trzeba oszczędzać :D
Bartłomiej Zimoń
@uzi18
@swiezaks jak zawsze jest
Daniel
@swiezaks
no to czekam na węgiel z PGG (po 4miesiącach próbowania w końcu ustrzeliłem ekogroszek) i na poprawkę do lucjana z termostatami. W międzyczasie wymieniłem wentylator na taki którym można bardzo dokładnie sterować obrotami przez lucjana:)
Daniel
@swiezaks
@uzi18 czy udało się znaleźć lub czy masz gdzieś w niedalekiej przyszłości poprawę termostatu?
Bartłomiej Zimoń
@uzi18
@swiezaks potrzebuje twoja konfigurację i log z wczytywana konfigu
Bartłomiej Zimoń
@uzi18
Najnowsza wersja z koncowka 130.35 powinna hulać
Bartłomiej Zimoń
@uzi18
@swiezaks jaki to wentylator?
Daniel
@swiezaks
to może na początek wkleje config bo pewnie ja coś pomieszałem. dmuchawę podam wieczorem jak pójdę do kotłowni odczytać log jak będzie potrzebny.
http://wklejamy.pl/A6yhLwJXRP
Daniel
@swiezaks
dmuchawa jaka posiadam to EWMAR-NESS RV18RD kupiona na złomie za 20zł. nie ma regulacji w pełnym zakresie ale od 25-50% czuć jak się zmieniają obroty.
Bartłomiej Zimoń
@uzi18
ok ale aby dzialaly termostaty musisz napisac cos takiego:
UT_WSPOLNY_PIN =
UT1_ZADANA =
UT1_CZUJNIK =
UT1_PIN =
UT1_HISTEREZA =
UT2_ZADANA =
UT2_CZUJNIK =
UT2_PIN =
UT2_HISTEREZA =
Bartłomiej Zimoń
@uzi18
i tak jak pisal @WojtekGD pin to numer pinu - nie powinien to byc pin CO tak jak probowales
UT_WSPOLNY_PIN nie musisz podawac
Daniel
@swiezaks
Ale jeżeli to nie może być pin C.O. to w jaki sposób zachowa się zawór 4d? jak termostat wyłączy pompkę to zawór 4d zostanie zamknięty czy dalej będzie próbował ustawić zadana temperaturę i otwierał go a co za tym idzie grawitacyjnie będą mi grzały grzejniki ? jeżeli zmienię pin do pompy C.O. to co się stanie z harmonogramem którego też używam.
Bartłomiej Zimoń
@uzi18
4d dziala względem co i temperatury za zaworem