Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    yogk
    @yogk

    Hi T Z Pardi,
    Thanks for pointing the "." This was the mistake that i was doing and did not pay attention to the exact command mentioned in the blog.
    With the "." added after /nw , I am able to get a proper UI. I will now register and test it further to understand how it works.

    Many thanks again.

    T Z Pardi
    @zsoltpardi
    Hi Yogesh, I am glad it works. It is easy to miss the ".", but it is important :-) and it's great if you put the correct shell command the UI is actually opened. Please let us know if you have any problems.
    Eddie Dickey
    @logicalpath

    Hi all, building NW.js, following instructions here:
    http://docs.nwjs.io/en/latest/For%20Developers/Building%20NW.js/#get-the-code

    I get:
    /usr/local/Cellar/python/2.7.11/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python: can't open file 'src/content/nw/tools/patcher.py': [Errno 2] No such file or directory

    The src.content.nw directory does not exist. I've asked about this in the nwjs/nw.js room but have not received a reply. Do I have to check out a rep into this dir? Thanks in advance

    Eddie Dickey
    @logicalpath
    I got past this issue by manually cloning the nw.js repo into src/content/nw
    T Z Pardi
    @zsoltpardi
    Hi Eddie, I had the same issue a while back. There is a new release for Streembit for both streembitlib and streembitui. Please let us know how it works on MAC.
    T Z Pardi
    @zsoltpardi
    The new streembitui is version 1.0.9 and there is an updated streembitlib as well, but the "npm install" should pull that permit that you have deleted the old streembitlib from the node_modules directory.
    Yogesh! Let me know please if you want to test the solution. If you can please open up the TCP port so you wouldn't use WS for transport but TCP.
    yogk
    @yogk
    error.png
    Hi TZ Pardi, to be safer i did a fresh installation of streembitui (i.e. renamed original streambitui to oldstreembitui, npm install and then git clone of streembitui to get the latest version). Next created an account "yogesh" , initialised it and searched for your name tzpardi. Now It says "The search for contact tzpardi returned no result". Secondly I also unticked the option Use WebSocket fallback and tried. but it shows same behaviour. See attached picture. Correct me if something is wrong here.
    T Z Pardi
    @zsoltpardi
    Could you please copy the content from the Seeds tab, from the very same view. Also, please click Tools and Account/Network info menu item and please copy to me the content of that view.
    Also please send me your log file at tzpardi@streembit.com. Click Tools/ Logs the first line of the Info tab indicates the path of your log file. Before you send me, please close the Streembit app to flush the log buffer the the log file.
    yogk
    @yogk
    This message was deleted
    This message was deleted
    seeds.png
    networkinfo.png
    T Z Pardi
    @zsoltpardi
    The seeds looks OK. Those the seeds are I am using as well.
    However, on the account/network info under the seeds you should see a few seeds to be listed, to which you actually connected. I don't think you have connected to any Seeds. A log file would help. Perhaps firewall or something prevents you actually connect to the network.
    T Z Pardi
    @zsoltpardi
    Which is confusing, you don't have any seeds listed in the Network view, which means you are not connected. However, in this case you shouldn't be able to search for contacts. We need to make sure the search box is only available when you are connected, and I thought I was taking care of that.
    yogk
    @yogk
    log file sent to your email id mentioned....ok i will have to logoff as its already late here..let me continue tomorrow.
    T Z Pardi
    @zsoltpardi
    OK, thanks Yogesh. I checked your log file. It seems all RPC calls timed out. You can see in the log files such lines like: "rpc call 1e437f071d1b058d7bc8f6dcfe6c43d2dd3c6b80 timed out" Normally it happens when incoming data is blocked. We say in the documentation that a peer to peer application requires a listener port, so the application try listening in port 8905 or whatever is defined in your settings view. If your firewall blocks the incoming data, then it is not possible to perform a P2P communication. There are some online tools which you can test if the port 8905 can receive incoming data.
    It seems you couldn't even publish your public key to the network. There is an error "Failed to store value at one or more nodes, reason: RPC with ID 1e437f071d1b058d7bc8f6dcfe6c43d2dd3c6b80 timed out","timestamp":"2016-07-18T16:49:37.555Z"} which indicates your TCP communication is not operational.
    Eddie Dickey
    @logicalpath

    I'm still building NW.js - I'm at the point of syncing:
    gclient sync --with_branch_heads

    I get to:
    Syncing projects: 100% (72/72), done.

    then I get:
    can't open file 'src/tools/remove_stale_pyc_files.py': [Errno 2] No such file or directory

    Anyone encounter this?

    T Z Pardi
    @zsoltpardi
    No, I haven't seen that. Lately, to speed up the development process I take the built SDK binaries from the NW website. The latest is at http://nwjs.io/blog/v0.16.0-rc1/ , This is not ideal, but NW is an Intel sponsored project and they were audited several times, it seems there is no backdoor in the software and their binaries are trustworthy. Their build takes directly the Github source. Perhaps try using the SDK binaries. We will have to sort out our build process. We have been discussing that for a while. In the meantime, until we don't have resources I am just using the binaries from the download page.
    Eddie Dickey
    @logicalpath
    Thanks @zsoltpardi I'll give the binaries a go.
    Eddie Dickey
    @logicalpath
    I was able to run streembit, add and initialize account and request add contact with tzpardi and Joachim. Next up is to build OS X app
    T Z Pardi
    @zsoltpardi
    Hi Eddie, it's great you could run it. I was busy with doing a presentation for the Berlin, IETF conference and I was not online with Streembit but I will receive later your contact request. Thanks, for the MAC binary, it would be great to have it.
    yogk
    @yogk

    @zsoltpardi , I run debian version. Have disabled the firewall (at least in the previous streembitui version i was able to send you the request but could not see if any requests were accepted so i dont think firewall could be a problem). Also TCP 8905 is configured to listening. Here is the output of netstat -l on linux Command line

    $ netstat -l
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State

    tcp 0 0 :33686 : LISTEN
    tcp 0 0 localhost:smtp
    : LISTEN
    tcp6 0 0 [::]:nfs [::]:
    LISTEN
    tcp6 0 0 [::]:43110 [::]: LISTEN
    tcp6 0 0 [::]:8905 [::]:
    LISTEN
    tcp6 0 0 [::]:sunrpc [::]: LISTEN
    tcp6 0 0 [::]:42001 [::]:
    LISTEN

    So i am clueless as to what could have gone wrong..

    yogk
    @yogk
    I created a new account "yogeshk" (note the change with k added at the end. earlier version was only yogesh). With this i am able to find tzpardi and sent you a friend request. could be this is a bug that if i had previous version of streambitui with account name "xyz" and I now use a new streambitui with the same account name "xyz" , then it does not allow to search contacts ...only when i created another name it allowed me to find contacts. accept my request sent so that i should be able to see your accepted request..
    Marc Schwab
    @mschwab56
    Hi yogk, did you backup your original yogesh account before updating to the new version? If you did you should try restoring the account.
    Eddie Dickey
    @logicalpath
    @zsoltpardi I built the osx binaries - Would love to test it by connecting to you or others on the streembit network
    Marc Schwab
    @mschwab56
    Feel free to add me on streembit to test it, my account name is mschwab
    Eddie Dickey
    @logicalpath
    Thanks @mschwab56
    Sent Request
    yogk
    @yogk
    @mschwab56: yes you are right. I had backedup my original "yogesh" account. I restored it and was able to search other contacts. I sent you a request @ "mschwab". plz accept so that i can see accepted requests..
    Eddie Dickey
    @logicalpath
    @zsoltpardi - Having issues connecting to contacts - It seems - tested with @mschwab56 and he did not see me as online and he appears offline to me. Saw this error in log:
    Failed to store value at one or more nodes, reason: RPC with ID 6de00deff1ebac3b6d2fa9c465e8526015e99714 timed out
    I can provide the log - I created 2 accounts and experience this with both accounts
    Marc Schwab
    @mschwab56
    @yogk I accepted both of your accounts as contacts
    T Z Pardi
    @zsoltpardi
    @logicalpath @yogk I assume both of your incoming traffic is blocked. So the TCP listener was created and it is listening - like @yogk indicates above - but cannot receive data. Please check your firewall settings whether the incoming traffic on port 8905 is allowed. I will do some work ASAP on this, so when there is no incoming traffic allowed then we will make that clear for user. The route of the problem is how RPC works. Via the RPC module you can send out data which explains why could you publish your data, but the receive of the reply is already blocked. We need to do more work on handling these scenarios and informing users about the errors via the UI. When the port is opened, the firewall is sorted out then Streembit seems works OK, but when there are some errors the situation is confusing. @logicalpath please email me your log file.
    Eddie Dickey
    @logicalpath
    @zsoltpardi I'll check ports on my cable modem - emailed logs
    yogk
    @yogk
    @mschwab56 : i still dont see your names after you have accepted request. As TZ pardi suggests that it could be that the tcp port is listening but cannot receive data. Dont know how to test this or which tool is available on linux ubuntu for testing this on tcp port 8905.
    yogk
    @yogk
    I mean how to test whether receiving is blocked on a particular tcp port (in this case 8905) or not .
    T Z Pardi
    @zsoltpardi
    @yogk This tool at http://www.yougetsignal.com/tools/open-ports/ should display "Port 8905 is open on xxx.xxx.xxx.xxx" the x is your Ip Address
    Marc Schwab
    @mschwab56
    I will be online for awhile if anyone wants to test their streembit
    Marc Schwab
    @mschwab56
    @yogk @logicalpath I have tested Streembit with @zsoltpardi and another person and all of the features are working for us. Let me know if you want to test again today if you got your ports open. If you are unable to get the port open you could use the Websocket fallback.
    Eddie Dickey
    @logicalpath
    Hi @mschwab56 I'll give it a go on a few hours.. I'm on Pacific Time
    Marc Schwab
    @mschwab56
    Ok sounds good! I'm on Mountain time
    Eddie Dickey
    @logicalpath
    Hello
    port 8905 is blocked
    Marc Schwab
    @mschwab56
    Ok what all have you tried to get it open?
    Eddie Dickey
    @logicalpath
    I enabled upnp - that did not help
    Im going to do port forwarding next